STS: Mensaje de error después de cambiar la contraseña: error ADO 80040E4D: ha fallado el inicio de sesión para el usuario 'sa'

Seleccione idioma Seleccione idioma
Id. de artículo: 292644 - Ver los productos a los que se aplica este artículo
importante : este artículo contiene información acerca de cómo modificar el registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si ocurre algún problema. Para obtener información sobre cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

Síntomas

Después de cambiar la contraseña de conexión de base de datos para el sitio Web de grupo de SharePoint, no puede utilizar los sitios Web basados en extensiones de servidor de Microsoft Office 2000 para las discusiones o colaboraciones.

Al ver el registro de aplicación desde dentro de Visor de sucesos, verá el mensaje de error Office Web Server siguientes:
Error ADO 80040E4D: error de usuario 'sa' inicio de sesión

Causa

Este comportamiento se produce porque los servidores virtuales basados en extensiones de servidor de Office 2000 ya no pueden tener acceso a Microsoft SQL Server 2000 Desktop Engine.

Nota : la versión anterior de Microsoft SQL Server 2000 Desktop Engine se denomina Data Engine (MSDE).

Cuando utiliza la utilidad Owsadm.exe para cambiar la contraseña de conexión de base de datos, la instalación de extensiones de servidor de Office 2000 no está configurada con la nueva contraseña.

Solución

Para evitar este problema, configure las extensiones de servidor Office 2000 para usar la nueva contraseña de conexión de base de datos. Para ello, siga estos pasos:
  1. Inicie el Administrador de OSE (HTML). Si aparece un cuadro de diálogo Escribir contraseña de red , escriba el nombre de usuario, contraseña y dominio en los cuadros correspondientes y, a continuación, haga clic en Aceptar .
  2. En la página principal del Administrador de extensiones de servidor de Microsoft Office, haga clic en Configuración de la base de datos .
  3. En la página Configuración de la base de datos, haga clic en Cambiar base de datos Office .
  4. Escriba el nombre de SQL Server y el nombre de base de datos en los cuadros correspondientes.

    Si no conoce esta información, siga estos pasos para obtener del registro de Microsoft Windows: Advertencia : si utiliza incorrectamente el Editor del registro, pueden surgir problemas graves que conlleven la reinstalación del sistema operativo. Microsoft no garantiza que pueda solucionar los problemas resultantes del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.

    1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar .
    2. En el cuadro Abrir , escriba regedit y, a continuación, haga clic en Aceptar .
    3. En el Editor del registro, expanda la subclave siguiente:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Web Server\OWS metadatos Stores\SQL MDStore1
    4. En el panel derecho, anote el valor de datos que corresponde a la entrada DNS . Por ejemplo:
      Proveedor = sqloledb; Server = server name; Database = Default_Web_Site_Collab
    5. Salga del Editor del Registro.
    6. En la página Configuración de base de datos de Office Server Extensions, escriba el nombre del servidor que anotó en el paso d en el cuadro SQL Server .
    7. En el cuadro Nombre de la base de datos , escriba el nombre de la base de datos que anotó en el paso d.
  5. En el cuadro Id de usuario , escriba sa .
  6. En el cuadro contraseña , escriba la nueva contraseña de conexión de base de datos y, a continuación, haga clic en Enviar .
  7. Reinicie el equipo servidor.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo.

Más información

Para obtener información adicional sobre cómo configurar las contraseñas de base de datos SQL, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
222828Mensaje de error: Proveedor Microsoft OLE DB para ODBC Drivers Error '80040e4d ' en

Propiedades

Id. de artículo: 292644 - Última revisión: miércoles, 21 de febrero de 2007 - Versión: 2.2
La información de este artículo se refiere a:
  • Microsoft SharePoint Team Services
  • Extensiones de servidor de Microsoft FrontPage 2002
Palabras clave: 
kbmt kbbug kberrmsg kbnofix KB292644 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 292644

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com