Service de jeton de sécurité: Message d'erreur après avoir modifié le mot de passe : 80040E4D Erreur ADO : Échec de connexion de l'utilisateur « sa »

Traductions disponibles Traductions disponibles
Numéro d'article: 292644 - Voir les produits auxquels s'applique cet article
IMPORTANT : Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, veillez à sauvegarder et assurez-vous que vous savez comment restaurer le Registre si un problème se produit. Pour savoir comment sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
256986 Description de du Registre Microsoft Windows
Agrandir tout | Réduire tout

Symptômes

Après que vous modifiez le mot de passe de connexion de base de données de votre site Web d'équipe SharePoint, vous ne pouvez pas utiliser vos sites Web basé Microsoft Office 2000 sur les extensions serveur pour discussions ou collaborations.

Lorsque vous affichez le journal des applications à partir de dans l'Observateur d'événements, vous voyez la message d'erreur Office Web Server suivantes :
Erreur ADO 80040E4D : Échec de connexion de l'utilisateur « sa »

Cause

Ce problème se produit car les serveurs virtuels basé sur les extensions serveur Office 2000 ne peuvent plus accéder Microsoft SQL Server 2000 Desktop Engine.

Remarque : la version précédente de SQL Server 2000 Desktop Engine est nommée Microsoft Data Engine (MSDE).

Lorsque vous utilisez l'utilitaire Owsadm.exe pour modifier le mot de passe de connexion de base de données, l'installation d'Office 2000 Server Extensions n'est pas configurée avec le nouveau mot de passe.

Contournement

Pour contourner ce problème, configurer les extensions de serveur Office 2000 pour utiliser le nouveau mot de passe connexion de base de données. Pour ce faire, procédez comme suit :
  1. Démarrez l'Administrateur de OSE (HTML). Si une boîte de dialogue Entrer le mot de passe réseau s'affiche, tapez votre nom d'utilisateur, mot de passe et votre domaine dans les zones correspondantes et puis cliquez sur OK .
  2. Sur la page d'accueil administrateur Microsoft Office Server Extensions, cliquez sur Paramètres de la base de données .
  3. Dans la page Paramètres de la base de données, cliquez sur base de données Office modifier .
  4. Tapez le nom du serveur SQL et le nom de la base de données dans les zones correspondantes.

    Si vous ne connaissez pas ces informations, procédez comme suit obtenir à partir du Registre Microsoft Windows : Avertissement : Si vous utilisez l'Éditeur du Registre de façon incorrecte, vous pouvez générer des graves problèmes pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantit que vous pouvez résoudre les problèmes résultant de l'utilisation incorrecte de l'Éditeur du Registre. Utilisez l'Éditeur du Registre à vos risques et périls.

    1. Cliquez sur Démarrer , puis cliquez sur Exécuter .
    2. Dans la zone Ouvrir , tapez regedit , puis cliquez sur OK .
    3. Dans l'Éditeur du Registre, développez la sous-clé suivante :
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Web Server\OWS métadonnées Stores\SQL MDStore1
    4. Dans le volet droit, enregistrer la valeur de données qui correspond à l'écriture DNS . Par exemple :
      Fournisseur = sqloledb ; Server = server name ; Database = Default_Web_Site_Collab
    5. Quittez l'Éditeur du Registre.
    6. Sur la page Paramètres de base de données Office Server Extensions, tapez le nom du serveur noté à l'étape j dans la zone SQL Server .
    7. Dans la zone Nom de la base de données , tapez le nom de la base de données que noté à l'étape d.
  5. Dans la zone ID utilisateur , tapez sa .
  6. Dans la zone mot de passe , tapez le nouveau mot de passe de connexion de base de données, puis cliquez sur Envoyer .
  7. Redémarrez l'ordinateur serveur.

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés au début de cet article.

Plus d'informations

Pour plus d'informations sur la configuration des mots de passe de base de données SQL, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
222828 Message d'erreur : les fournisseur du Microsoft OLE DB pour pilotes ODBC, erreur « 80040e4d »

Propriétés

Numéro d'article: 292644 - Dernière mise à jour: mercredi 21 février 2007 - Version: 2.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft SharePoint Team Services
  • Extensions serveur Microsoft FrontPage 2002
Mots-clés : 
kbmt kbbug kberrmsg kbnofix KB292644 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 292644
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com