Problemas conocidos que afectan a la tarea de mantenimiento de limpieza de AppX en Windows 8.1 y Windows Server 2012 R2

En este artículo se proporcionan soluciones a problemas conocidos que implican la tarea de mantenimiento de limpieza de AppX.

Se aplica a: Windows 8.1, Windows Server 2012 R2
Número de KB original: 2928948

Introducción

Para ayudar a reducir la superficie total del disco, después de instalar Windows 8.1 o Windows Server 2012 R2, se ejecuta una tarea de mantenimiento de limpieza de AppX preconfigurada después de 60 minutos de uso del equipo seguida de 15 minutos de tiempo de inactividad del equipo. Esta tarea de mantenimiento programado recupera el espacio en disco después del proceso de instalación de Windows. Para ello, la tarea elimina paquetes de recursos de Paquete de aplicación (.appx) en función del idioma, la escala y el nivel de característica DirectX (DXFL) que no están actualmente en uso para las cuentas de usuario actuales.

Síntomas

Si ejecuta Sysprep después de esta tarea de mantenimiento de limpieza de AppX, registrará el siguiente mensaje de advertencia en el registro Setupact en la carpeta C:\Windows\System32\Sysprep:

<Fecha><y hora>, advertencia SYSPRP No se pudo volver a armar la selección de región, algunos archivos y claves del Registro ya no se pueden recuperar.

<Fecha><y hora>, Info SYSPRP Exiting SysprepGeneralize (Appx).

Si captura e implementa esta imagen, el usuario final puede experimentar los siguientes síntomas:

  • Se usa la escala de visualización de aplicaciones modernas (una pantalla con valores altos de PPP en lugar de una pantalla con valores de PPP bajos).
  • El idioma de presentación incorrecto se usa para algunas aplicaciones modernas si se instalan paquetes de idioma adicionales.

Nota:

En esta situación, las aplicaciones modernas siguen funcionando. Sin embargo, es posible que no tengan los recursos necesarios para el equipo.

Causa

Este problema se debe a la eliminación de paquetes de recursos.

Solución alternativa

Para evitar este problema, utilice uno de los métodos siguientes.

Solución alternativa 1

Si va a crear una imagen para la implementación, ejecute Sysprep en un plazo de 75 minutos después del primer inicio de sesión de Windows 8.1 o Windows Server 2012 R2. Si no puede hacerlo, pruebe la solución alternativa 2.

Solución alternativa 2

Deshabilite la tarea de mantenimiento inmediatamente después del primer inicio de sesión. Para deshabilitar automáticamente la tarea de mantenimiento, ejecute el siguiente comando en un símbolo del sistema con privilegios elevados:

Schtasks.exe /change /disable /tn "\Microsoft\Windows\AppxDeploymentClient\Pre-staged app cleanup"

Para deshabilitar automáticamente la tarea de mantenimiento como parte de la Configuration Manager secuencia de tareas de compilación y captura, inserte un nuevo paso "Ejecutar línea de comandos" inmediatamente después del paso "Configurar Windows y Configuration Manager". En este nuevo paso se usa el siguiente comando:

Schtasks.exe /change /disable /tn "\Microsoft\Windows\AppxDeploymentClient\Pre-staged app cleanup"

Nota:

Inserte este nuevo paso solo en las secuencias de tareas que ejecutan Sysprep en Windows 8.1 o Windows Server 2012 R2. Windows volverá a habilitar automáticamente la tarea de mantenimiento durante la fase de generalización de Sysprep.

Solución alternativa 3

Si va a crear una imagen para la implementación, inicie el equipo en el modo de auditoría de Sysprep para realizar los cambios de configuración antes de ejecutar SysprepGeneralize para capturar la imagen que se menciona en la sección "Síntomas".

Nota:

La tarea programada no se ejecuta durante el modo auditoría.

Solución alternativa 4

Espere 24 horas para que se ejecute el proceso de actualización automática de la Tienda. O bien, busque manualmente las actualizaciones de la Tienda.

Si implementa la imagen que se menciona en la sección "Síntomas" en un equipo que requiere algunos de los paquetes de recursos que se quitaron, los recursos necesarios se actualizan automáticamente si el usuario que inicia sesión en el equipo tiene acceso a Microsoft Store. Esta actualización se produce 24 horas después del primer inicio de sesión después de usar Sysprep si la conectividad de Microsoft Store está disponible. Hay una configuración de directiva de grupo que deshabilita las actualizaciones automáticas de Microsoft Store. Esta configuración impide que se restauren los paquetes de recursos que faltan. Si faltan los paquetes de recursos, el usuario debe tener acceso a Microsoft Store para actualizar los paquetes de recursos aplicables para el equipo.

Estado

Este comportamiento es una característica del diseño de la aplicación.

Más información

Si elimina la tarea de mantenimiento, los recursos no se eliminan y la tarea nunca se ejecuta. Dado que la tarea de mantenimiento no está disponible después de la instalación, los recursos siempre usan espacio en disco en el equipo.

Recolección de datos

Si necesita ayuda del soporte técnico de Microsoft, le recomendamos que recopile la información siguiendo los pasos mencionados en Recopilación de información mediante TSS para problemas relacionados con la implementación.