Problèmes connus qui affectent la tâche de maintenance de nettoyage AppX dans Windows 8.1 et Windows Server 2012 R2

Cet article fournit des solutions aux problèmes connus qui impliquent la tâche de maintenance de nettoyage AppX.

S’applique à : Windows 8.1, Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 2928948

Introduction

Pour réduire l’encombrement global de votre disque, après avoir installé Windows 8.1 ou Windows Server 2012 R2, une tâche de maintenance de nettoyage AppX pré-intermédiaire est exécutée après 60 minutes d’utilisation de l’ordinateur suivie de 15 minutes de temps d’inactivité de l’ordinateur. Cette tâche de maintenance planifiée récupère l’espace disque après le processus d’installation de Windows. Pour ce faire, la tâche supprime les packs de ressources du package d’application (.appx) en fonction de la langue, de l’échelle et du niveau de fonctionnalité DirectX (DXFL) qui ne sont pas actuellement utilisés pour les comptes d’utilisateur actuels.

Symptômes

Si vous exécutez Sysprep après cette tâche de maintenance de nettoyage AppX, le message d’avertissement suivant est journal dans le journal Setupact dans le dossier C :\Windows\System32\Sysprep :

<Date><Heure>, Avertissement SYSPRP Impossible de ré-armer la sélection de la région, certains fichiers et clés de Registre ne sont plus récupérables.

<Date><Time>, Info SYSPRP exiting SysprepGeneralize (Appx).

Si vous capturez et déployez cette image, l’utilisateur final peut rencontrer les symptômes suivants :

  • L’échelle d’affichage des applications modernes est utilisée (un affichage haute résolution au lieu d’un écran à faible résolution).
  • Une langue d’affichage incorrecte est utilisée pour certaines applications modernes si des modules linguistiques supplémentaires sont installés.

Remarque

Dans ce cas, les applications modernes fonctionnent toujours. Toutefois, il se peut qu’ils ne disposent pas des ressources nécessaires pour l’ordinateur.

Cause

Ce problème est dû à la suppression des packs de ressources.

Solution de contournement

Pour contourner ce problème, appliquez l’une des méthodes ci-dessous.

Solution de contournement 1

Si vous créez une image pour le déploiement, exécutez Sysprep dans les 75 minutes suivant la première ouverture de session de Windows 8.1 ou Windows Server 2012 R2. Si vous ne pouvez pas le faire, essayez la solution de contournement 2.

Solution de contournement 2

Désactivez la tâche de maintenance immédiatement après la première ouverture de session. Pour désactiver automatiquement la tâche de maintenance, exécutez la commande suivante à une invite de commandes avec élévation de privilèges :

Schtasks.exe /change /disable /tn "\Microsoft\Windows\AppxDeploymentClient\Pre-staged app cleanup"

Pour désactiver automatiquement la tâche de maintenance dans le cadre de la séquence de tâches de génération et de capture Configuration Manager, insérez une nouvelle étape « Exécuter la ligne de commande » immédiatement après l’étape « Configurer Windows et Configuration Manager ». Cette nouvelle étape utilise la commande suivante :

Schtasks.exe /change /disable /tn "\Microsoft\Windows\AppxDeploymentClient\Pre-staged app cleanup"

Remarque

Insérez cette nouvelle étape uniquement dans les séquences de tâches qui exécutent Sysprep sur Windows 8.1 ou Windows Server 2012 R2. Windows réactive automatiquement la tâche de maintenance pendant la phase de généralisation sysprep.

Solution de contournement 3

Si vous créez une image pour le déploiement, démarrez l’ordinateur en mode d’audit Sysprep pour apporter des modifications à la configuration avant d’exécuter SysprepGeneralize pour capturer l’image mentionnée dans la section « Symptômes ».

Remarque

La tâche planifiée ne s’exécute pas en mode Audit.

Solution de contournement 4

Attendez 24 heures que le processus de mise à jour automatique du Store s’exécute. Vous pouvez également rechercher manuellement les mises à jour du Windows Store.

Si vous déployez l’image mentionnée dans la section « Symptômes » sur un ordinateur qui nécessite certains packages de ressources qui ont été supprimés, les ressources requises sont mises à jour automatiquement si l’utilisateur qui se connecte à l’ordinateur a accès au Microsoft Store. Cette mise à jour se produit 24 heures après la première ouverture de session après l’utilisation de Sysprep si la connectivité du Microsoft Store est disponible. Il existe un paramètre stratégie de groupe qui désactive les mises à jour automatiques du Microsoft Store. Ce paramètre empêche la restauration des packs de ressources manquants. Si les packs de ressources sont manquants, l’utilisateur doit disposer d’un accès au Microsoft Store afin de mettre à jour les packs de ressources applicables pour l’ordinateur.

Statut

Ce comportement est inhérent au produit.

Plus d’informations

Si vous supprimez la tâche de maintenance, les ressources ne sont pas supprimées et la tâche n’est jamais exécutée. Étant donné que la tâche de maintenance n’est pas disponible après l’installation, les ressources utilisent toujours l’espace disque sur l’ordinateur.

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.