L’installation de DPM échoue et génère l’erreur 4323 : Impossible d’ajouter un membre

Cet article vous aide à résoudre un problème dans lequel le programme d’installation de DPM n’a pas pu ajouter un utilisateur au groupe local message d’erreur lorsque vous installez System Center Data Protection Manager.

Version d’origine du produit : System Center Data Protection Manager
Numéro de la base de connaissances d’origine : 2930276

Symptômes

Lorsque vous essayez d’installer System Center Data Protection Manager, pour la première fois ou en tant que mise à niveau, l’installation échoue et vous recevez le message d’erreur suivant :

Erreur : Le programme d’installation de DPM n’a pas pu ajouter un utilisateur au groupe local. Passez en revue les détails de l’erreur, effectuez l’action appropriée, puis réexécutez le programme d’installation de DPM.
ID : 4323. Détails : un membre n’a pas pu être ajouté ou supprimé du groupe local, car le membre n’existe pas

Vous pouvez également voir des entrées qui ressemblent à ce qui suit dans le fichier Setup.log :

[23/10/2013 11 :07 :42 AM] Informations : Démarrer la configuration.
[23/10/2013 11 :07 :42 AM] Informations : Démarrage de la version> service :MSSQL$MSDPM<sur l’ordinateur :DPMServerName indicateur restart :False
[23/10/2013 11 :07 :42 AM] Informations : Démarrage de la version> service :SQLAgent$MSDPM<sur l’ordinateur :DPMServerName indicateur restart :False
[23/10/2013 11 :07 :42 AM] Informations : Démarrage de la version> service :ReportServer$MSDPM<sur l’ordinateur :DPMServerName indicateur restart :False
[23/10/2013 11 :07 :42 AM] Informations : Créer un registre contenant les informations de compte sql Agent
[23/10/2013 11 :07 :42 AM] Informations : Interrogation de l’espace de noms WMI : \\DPMServerName\root\cimv2 pour la requête : SELECT * FROM Win32_Service WHERE Name='SQLAgent$MSDPM<version>'
[23/10/2013 11 :07 :42 AM] Informations : Nom du compte Sql Agent = contoso-old\DPMServerName$
[23/10/2013 11 :07 :42 AM] Informations : Créez un registre contenant les informations de chemin d’accès au travail du déclencheur
[23/10/2013 11 :07 :42 AM] Données : TriggerJobPath = D :\Microsoft System Center <version>\DPM\DPM\bin\
[23/10/2013 11 :07 :42 AM] Informations : Ajouter l’utilisateur : contoso-old\DPMServerName$ au groupe local : Utilisateurs COM distribués sur le serveur : DPMServerName
[23/10/2013 11 :07 :42 AM] * Exception : => Le programme d’installation de DPM n’a pas pu ajouter un utilisateur au groupe local. Passez en revue les détails de l’erreur, effectuez l’action appropriée, puis réexécutez le programme d’installation de DPM. Microsoft.Internal.EnterpriseStorage.Dls.Setup.Exceptions.BackEndErrorException : une exception de type « Microsoft.Internal.EnterpriseStorage.Dls.Setup.Exceptions.BackEndErrorException » a été levée.
sur Microsoft.Internal.EnterpriseStorage.Dls.Setup.NativeConfigHelper.AddAccountToLocalGroup(String accountName, String localGroupName, String machineName)
sur Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.RemoteDatabaseConfiguration.AddSqlAgentAccountToLocalGroups(String sqlAgentAccountName)
sur Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.BackEnd.MachineSpecificConfiguration(Boolean existingDB, Boolean upgrading, Boolean isRemoteDb, String sqlServerMachineName, String sqlInstanceName, Boolean isRemoteReporting, String reportingMachineName, String reportingInstanceName)
sur Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.BackEnd.Configure(Boolean existingDB, Boolean upgrading, String databaseLocation, String sqlServerMachineName, String sqlInstanceName, String reportingMachineName, String reportingInstanceName, String reportingInstanceName, Boolean oemSetup)
sur Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.DpmInstaller.ConfigurePostMsiUpgrade() à l’adresse Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.ProgressPage.UpgradeDpm()
sur Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.ProgressPage.InstallerThreadEntry() *** L’erreur Mojito était : AddUserToLocalGroupFailed ; 1387; WindowsAPI
[23/10/2013 11 :07 :44 AM] *** Erreur : Le programme d’installation de DPM n’a pas pu ajouter un utilisateur au groupe local. Passez en revue les détails de l’erreur, effectuez l’action appropriée, puis réexécutez le programme d’installation de DPM.
ID : 4323. Détails : un membre n’a pas pu être ajouté ou supprimé du groupe local, car le membre n’existe pas
[23/10/2013 11 :07 :44 AM] Informations : La mise à niveau de DPM a échoué.
Pour plus d’informations, cliquez sur l’onglet Erreur.
Pour résoudre ce problème, consultez http://go.microsoft.com/fwlink/?LinkID=164487.

Cause

Ce problème peut se produire si l’environnement a un espace de noms disjoint (autrement dit, le domaine a des noms NetBIOS et DNS différents). Par exemple, supposons que le domaine a un nom NetBIOS de contoso.com et un nom DNS de contoso-old.com. Lorsque des utilisateurs sont ajoutés dans l’interface utilisateur Windows, ils sont affichés au format contoso\ComputerName. Toutefois, vous remarquez dans le journal des erreurs qu’il y a eu une tentative d’ajout d’un compte d’ordinateur au format contoso-old\ComputerName.

Solution de contournement : Mise à niveau

  1. Créez un compte d’utilisateur de domaine nommé MICROSOFT$DPM$Acct. Si vous ne pouvez pas créer de compte de domaine, vous pouvez utiliser un compte d’utilisateur standard.

  2. Recherchez les fichiers de base de données DPMDB et assurez-vous que le nouveau compte que vous avez identifié ou créé à l’étape 1 dispose des autorisations complètes sur ce répertoire.

  3. Modifiez la version> DE MSSQL$MSDPM< et les services de version> SQLAgent$MSDPM< de sorte qu’ils utilisent le nouveau compte d’utilisateur de domaine de l’étape 1.

Remarque

Nous vous recommandons d’utiliser Microsoft Gestionnaire de configuration SQL Server, car il offre le moyen le plus simple d’effectuer cette modification.

L’installation de la mise à niveau doit maintenant se terminer correctement.

Une fois la mise à niveau terminée, rétablissez les deux services mentionnés à l’étape 3 afin qu’ils commencent à utiliser la désignation de compte local (MICROSOFT$DPM$Acct).

Solution de contournement : Nouvelle installation

  1. Créez un compte d’utilisateur de domaine nommé MICROSOFT$DPM$Acct.

  2. Créez un compte d’utilisateur local sur le serveur DPM portant le même nom MICROSOFT$DPM$Acct. Les mots de passe n’ont pas besoin de correspondre entre les comptes.

  3. Modifiez la version> DE MSSQL$MSDPM< et les services de version> SQLAgent$MSDPM< de sorte qu’ils utilisent le nouveau compte d’utilisateur de domaine de l’étape 1.

L’installation doit maintenant se terminer correctement. Pour une nouvelle installation, vous n’avez pas besoin de restaurer les deux services comme indiqué dans la section Mise à niveau , car le Registre dispose déjà des informations correctes pour les services.

Vérifier les fonctionnalités après une mise à niveau

Remarque

Suivez ces étapes uniquement si vous avez effectué une mise à niveau. Une nouvelle installation n’en nécessite pas.

Pour vous assurer que les travaux continuent à s’exécuter comme prévu, procédez comme suit sur le serveur DPM :

  1. Dans l'éditeur du registre, recherchez la sous-clé de registre suivante :

    HKLM\Software\Microsoft\Microsoft Data Protection Manager\Setup

  2. Assurez-vous que les valeurs suivantes reflètent le %MachineName%\Microosft$DPM$Acct compte local :

    • SqlAgentAccountName
    • SchedulerJobOwnerName

    Remarque

    Ce compte doit également disposer d’autorisations complètes sur le dossier DPM\Bin sur le serveur DPM et sur le serveur exécutant Microsoft SQL Server, si SQL Server est hébergé à distance.

  3. Démarrez DCOMCNFG.exe, puis recherchez le dossier suivant :

    Component Services\Computers\My Computer\DCOM Config\Microsoft System Center Data Protection Manager <version> Service

  4. Cliquez avec le bouton droit sur le nom du service, puis sélectionnez Propriétés.

  5. Sélectionnez l’onglet Sécurité.

  6. Dans la zone Autorisations de lancement et d’activation , sélectionnez Modifier, puis vérifiez que le compte existe et que toutes les autorisations sont attribuées.

  7. Démarrez SQL Server Management Studio pour le instance DPM, puis vérifiez que le compte a le rôle Sysadmin.

Étapes supplémentaires en cas d’échec de l’installation de la mise à niveau

Si l’installation de la mise à niveau échoue et que le programme ne restaure pas, vous devez restaurer une version opérationnelle de DPM avant de pouvoir réessayer d’installer la mise à niveau. Pour cela, procédez comme suit :

  1. Recherchez la copie de sauvegarde de votre fichier DPMDB que vous avez créée avant de commencer le processus de mise à niveau.

  2. Si DPM est installé, désinstallez-le.

    Importante

    Veillez à conserver vos données. Pour ce faire, sélectionnez Conserver les points de récupération sur disque dans la page Options de désinstallation .

  3. Installez DPM. Si des mises à jour ont été installées, réinstallez-les dans la même séquence que vous les aviez installées précédemment.

    Remarque

    Nous vous recommandons de monter la base de données à partir de l’étape 1, puis d’exécuter la requête suivante sur la base de données DPM en mode Administrateur pour localiser la séquence dans laquelle les mises à jour ont été appliquées à l’origine :

    Select distinct MajorVersionNumber,MinorVersionNumber ,BuildNumber, FileName FROM [DPMDB].[dbo].[tbl_AM_AgentPatch] where MajorVersionNumber = 4 and MinorVersionNumber =1 order by BuildNumber desc
    
  4. Pour restaurer la copie de la base de données de sauvegarde, exécutez la commande suivante à partir d’une invite de commandes avec élévation de privilèges :

    dpmsync -restoredb (with appropriate switches)
    
  5. Pour synchroniser les bases de données, exécutez la commande suivante dans DPM Management Shell :

    dpmsync -sync
    
  6. Démarrez la console Administrateur DPM, puis vérifiez que tous les agents ont le même numéro de version que le serveur DPM.

Après avoir suivi ces étapes, le status de votre installation DPM doit être restauré à son état d’origine. À présent, réessayez pour effectuer les étapes de la solution de contournement et l’installation de la mise à niveau.