Код статьи: 293078 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

В Windows XP появляется одно из приведенных ниже сообщений о STOP-ошибке.
STOP 0x000000EA THREAD_STUCK_IN_DEVICE_DRIVER
STOP: 0x100000EA THREAD_STUCK_IN_DEVICE_DRIVER_M

Причина

Эта проблема возникает, если графический адаптер входит в бесконечный цикл при ожидании освобождения видеоустройства. Это может свидетельствовать о сбое видеоустройства или об ошибке графического адаптера при программировании устройства.

Эта STOP-ошибка может возникать в драйвере видеоадаптера, не представляющем физическое устройство. Примером может служить драйвер виртуального видеоадаптера, который используется программой Symantec PCAnywhere. Если ошибка возникает на компьютере, на котором установлена программа PCAnywhere, посетите веб-узел Symantec и проверьте наличие доступных исправлений для используемой версии программы.

Решение

Чтобы решить эту проблему, используйте описанные в этом разделе способы в порядке их перечисления.

Первые четыре описанных в этой статье способа предназначены для начинающих пользователей и пользователей среднего уровня. Последние два способа предполагают использование продвинутых методов устранения неполадок и разработаны для опытных пользователей.

Приведенные в статье указания будет проще выполнять, если предварительно распечатать статью.

Способ 1. Воспользуйтесь средством создания отчетов об ошибках Windows

Используйте средство создания отчетов об ошибках Windows, чтобы отправить отчет об ошибке в корпорацию Майкрософт и узнать, имеется ли исправление или временное решение проблемы. Для этого выполните действия, указанные ниже.
  1. При получении предложения отправить отчет об ошибке в корпорацию Майкрософт нажмите кнопку Отправить отчет.
  2. Если доступно исправление ошибки или обходной способ решения проблемы, выберите вариант Дополнительные сведения. Это поможет получить исправление или сведения об обходном способе решения проблемы.
Если с помощью этого способа проблему удалось устранить, дальнейших действий не требуется. Если сообщение о STOP-ошибке продолжает появляться, воспользуйтесь способом 2.

Способ 2. Установите последнюю версию драйвера видеоадаптера

Чтобы установить последнюю версию драйвера для видеоадаптера в Windows XP, посетите веб-узел корпорации Майкрософт по следующему адресу:
http://www.update.microsoft.com/windowsupdate/v6/vistadefault.aspx?ln=ru-ru
Если проблема устранена, выполнять другие действия не требуется. Если сообщение о STOP-ошибке продолжает появляться, воспользуйтесь способом 3.

Способ 3. Свяжитесь с изготовителем видеокарты для получения и установки последней версии драйвера

Драйвер — это программное обеспечение, которое позволяет воспроизводить видео на компьютере. Изготовитель видеокарты указан в документации, прилагаемой к компьютеру. Затем используйте ссылки из приведенного ниже списка, чтобы найти контактные данные изготовителя видеокарты для получения и установки последней версии драйвера. Контактные данные поставщиков оборудования и программного обеспечения см. на указанном ниже веб-сайте корпорации Майкрософт.
http://support.microsoft.com/gp/oemphone/ru
Контактные данные сторонних компаний предоставляются с целью помочь пользователям получить необходимую техническую поддержку. Эти данные могут быть изменены без предварительного уведомления. Корпорация Майкрософт не дает гарантий относительно правильности приведенных контактных сведений сторонних производителей.

Если с помощью этого способа проблему удалось устранить, дальнейших действий не требуется. Если сообщение о STOP-ошибке продолжает появляться, воспользуйтесь способом 4.

Способ 4. Замените видеокарту

Сведения о замене видеокарты см. в документации, прилагаемой к компьютеру.

Если с помощью этого способа проблему удалось устранить, дальнейших действий не требуется. Если сообщение о STOP-ошибке продолжает появляться и вы уверены, что сможете воспользоваться продвинутыми способами устранения неполадок, перейдите к разделу «Продвинутые способы устранения неполадок».

Если продвинутые способы устранения неполадок слишком сложны, можно обратиться к разделу «Дальнейшие действия» за информацией о дополнительных ресурсах, которые могут помочь в решении проблемы.

Продвинутые способы устранения неполадок

Эти способы рассчитаны на опытных пользователей. Если продвинутые способы устранения неполадок слишком сложны, обратитесь за помощью к специалисту или в службу поддержки. Сведения о том, как обратиться в службу поддержки, см. на следующем веб-сайте корпорации Майкрософт:
http://support.microsoft.com/contactus/?ln=ru#tab0

Способ 1: Отключение или обновление драйверов устройств

  1. Проверьте список совместимого оборудования корпорации Майкрософт и определите, совместимы ли установленные на компьютере PCI-устройства с Windows XP. Дополнительные сведения о списке совместимого оборудования см. на веб-узле корпорации Майкрософт по следующему адресу:
    http://www.microsoft.com/ru-ru/windows/compatibility/win8/CompatCenter/Home?Language=ru-ru
  2. Установите последние версии драйверов видеоадаптеров.
  3. Если в сообщении о неустранимой ошибке выводится имя драйвера, отключите или удалите его.
  4. Отключите или удалите все недавно добавленные драйверы или службы.
Примечание. Если ошибка возникает в процессе загрузки и в системном разделе используется файловая система NTFS, то можно попытаться перейти в безопасный режим и переименовать или удалить поврежденный драйвер. Если этот драйвер используется при загрузке системы в безопасном режиме, то для запуска компьютера необходимо использовать консоль восстановления. Дополнительные сведения о драйверах видеоадаптеров в безопасном режиме см. в следующей статье базы знаний Майкрософт:
292460 Устранение неполадок драйвера видеоадаптера в безопасном режиме Windows XP
Примечание. Если проблема связана с файлом Win32k.sys, возможно, она вызвана программой стороннего производителя, предназначенной для удаленного управления. Удалите службу, загрузив компьютер с использованием агента восстановления, а затем удалите указанный файл системной службы.

Если с помощью этого способа проблему удалось устранить, дальнейших действий не требуется. Если сообщение о STOP-ошибке продолжает появляться, воспользуйтесь способом 2.

Способ 2. Измените параметры аппаратного ускорения графики

  1. В меню Пуск выберите пункт Панель управления, а затем дважды щелкните значок Экран.
  2. Перейдите на вкладку Параметры, нажмите кнопку Дополнительно, а затем перейдите на вкладку Диагностика.
  3. Переместите ползунок Аппаратное ускорение до надписи Нет, а затем снимите флажок Включить совмещение записи.
  4. Нажмите кнопку ОК два раза.
Примечание. Эта операция позволит избежать ошибок при программировании устройства графическим адаптером, но может привести к снижению быстродействия и потере некоторых возможностей. Для увеличения быстродействия и восстановления возможностей можно включить аппаратное ускорение, переместив ползунок из положения Нет, но это также повысит вероятность повторного возникновения ошибок. Для наибольшей стабильности системы не включайте аппаратное ускорение.

ДАЛЬНЕЙШИЕ ДЕЙСТВИЯ

Если указанные способы не помогли устранить неполадки, можно воспользоваться веб-сайтом службы технической поддержки корпорации Майкрософт для поиска других решений. Ниже перечислены некоторые услуги, которые можно найти на веб-сайте службы технической поддержки Майкрософт.
  • База знаний с возможностью поиска. Поиск технических сведений и рекомендаций по использованию продуктов Майкрософт.
  • Центры решений. Список часто задаваемых вопросов и советов службы поддержки.
  • Прочие виды поддержки. Задайте вопрос в Интернете, обратитесь в службу технической поддержки Майкрософт или отправьте свой отзыв.
Если после посещения этих веб-сайтов корпорации Майкрософт остались вопросы или на веб-сайте службы поддержки Майкрософт отсутствуют необходимые решения, для обращения в службу поддержки перейдите по следующей ссылке:
http://support.microsoft.com/contactus?ln=ru#tab0
В этой статье упомянуты программные продукты независимых производителей. Корпорация Майкрософт не предоставляет никаких гарантий относительно производительности или надежности этих продуктов.

Свойства

Код статьи: 293078 - Последний отзыв: 6 июня 2013 г. - Revision: 10.1
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional x64 Edition
Ключевые слова: 
kbresolve kbtshoot kbenv kberrmsg kbhardware kbprb KB293078

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com