ข้อผิดพลาดใน Windows XP: "Stop รหัสข้อผิดพลาด 0x000000EA (THREAD_STUCK_IN_DEVICE_DRIVER)"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 293078 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

คุณได้รับข้อความแสดงข้อผิดพลาด Stop ต่อไปนี้ใน Windows XP:
STOP 0X000000EA THREAD_STUCK_IN_DEVICE_DRIVER
STOP: 0x100000EA THREAD_STUCK_IN_DEVICE_DRIVER_M

สาเหตุ

ปัญหานี้เกิดขึ้นถ้าการ์ดแสดงผลที่ติดอยู่ในการวนรอบไม่สิ้นสุดในขณะรอสำหรับฮาร์ดแวร์การแสดงผลจะกลายเป็นไม่ได้ใช้งาน ซึ่งสามารถบ่งชี้ว่า มีปัญหากับฮาร์ดแวร์การแสดงผล หรือว่า การ์ดแสดงผลไม่สามารถโปรแกรมฮาร์ดแวร์ได้อย่างถูกต้อง

นอกจากนี้ข้อความแสดงข้อผิดพลาด Stop อาจเกิดขึ้นในโปรแกรมควบคุมการ์ดแสดงผลที่ได้แสดงถึงอุปกรณ์ทางกายภาพ ตัวอย่างเช่น ข้อความแสดงข้อผิดพลาด Stop นี้อาจเกิดขึ้นในโปรแกรมควบคุมการ์ดแสดงผลเสมือนที่ใช้ โดย Symantec PCAnywhere ถ้ามีการติดตั้ง PCAnywhere บนคอมพิวเตอร์ซึ่งข้อความแสดงข้อผิดพลาดนี้เกิดขึ้น แวะไปเว็บไซต์ของ Symantec เมื่อต้องการตรวจสอบว่า มีแก้ไขปัญหาใด ๆ พร้อมใช้งานสำหรับรุ่นของ PCAnywhere

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ให้ทำตามวิธีการที่อธิบายไว้ในส่วนนี้ในใบสั่งที่ปรากฏจนกระทั่งปัญหาได้รับการแก้ไข

ตัวแรกสี่วิธีที่อธิบายไว้ในบทความนี้จะใช้สำหรับการเริ่มต้นจนถึงผู้ใช้ระดับกลาง วิธีการสองวิธีสุดท้ายกับการแก้ไขปัญหาขั้นสูง และถูกออกแบบมาสำหรับผู้ใช้ขั้นสูง

คุณอาจพบว่าจะง่ายต่อการทำตามขั้นตอนต่าง ๆ ถ้าคุณพิมพ์บทความนี้ก่อน

วิธีที่ 1: ใช้เครื่องมือรายงานข้อผิดพลาดของ Windows

ใช้ Windows ข้อผิดพลาดรายงานนั้นเพื่อส่งข้อผิดพลาดไปยัง Microsoft และตรวจสอบแก้ไขหรือแก้ปัญหาที่มีอยู่ ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. คลิก ส่งรายงานข้อผิดพลาด เมื่อได้รับพร้อมท์ให้ส่งรายงานข้อผิดพลาดไปยัง Microsoft
  2. หากวิธีการแก้ไขหรือวิธีแก้ปัญหา คลิก ข้อมูลเพิ่มเติม. ซึ่งช่วยให้คุณได้รับการแก้ไขปัญหาหรือข้อมูลเกี่ยวกับวิธีการรับมือกับปัญหา
ถ้าวิธีการนี้ทำงาน คุณจะเสร็จเรียบร้อยแล้ว ถ้าคุณยังคงได้รับข้อความแสดงข้อผิดพลาด stop ไปที่วิธีที่ 2

วิธีที่ 2: การติดตั้งโปรแกรมควบคุมล่าสุดสำหรับการ์ดแสดงผลของคุณ

เมื่อต้อง การตรวจหา และติดตั้งโปรแกรมควบคุมล่าสุดสำหรับการ์ดแสดงผลของคุณใน Windows XP แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://update.microsoft.com
ถ้าวิธีการนี้ทำงาน คุณจะเสร็จเรียบร้อยแล้ว ถ้าคุณยังคงได้รับข้อความแสดงข้อผิดพลาด stop ไปที่วิธีที่ 3

วิธีที่ 3: ติดต่อผู้ผลิตการ์ดแสดงผลเพื่อดาวน์โหลด และติดตั้งไดรเวอร์ล่าสุด

โปรแกรมควบคุมคือ ซอฟต์แวร์ที่ช่วยให้วิดีโอที่จะสามารถดูได้บนคอมพิวเตอร์ของคุณ ดูเอกสารประกอบที่มาพร้อมกับคอมพิวเตอร์ของคุณเพื่อตรวจสอบผู้ผลิตสำหรับการ์ดแสดงผล ใช้แล้ว การเชื่อมโยงการในรายการต่อไปนี้เพื่อค้นหาข้อมูลการติดต่อสำหรับผู้ผลิตการ์ดแสดงผลของคุณเพื่อขอรับ และติดตั้งไดรเวอร์ล่าสุด สำหรับข้อมูลเพิ่มเติมเกี่ยวกับผู้จัดจำหน่ายฮาร์ดแวร์และซอฟต์แวร์ข้อมูลติดต่อ แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/gp/vendors
Microsoft ให้ข้อมูลที่ติดต่อของบริษัทอื่นเพื่อช่วยให้คุณค้นหาฝ่ายสนับสนุนทางเทคนิค ข้อมูลการติดต่อนี้อาจจะเปลี่ยนแปลงโดยไม่ได้แจ้งให้ทราบ Microsoft ไม่รับประกันความถูกต้องของข้อมูลการติดต่อของบริษัทอื่นนี้

ถ้าวิธีการนี้ทำงาน คุณจะเสร็จเรียบร้อยแล้ว ถ้าคุณยังคงได้รับข้อความแสดงข้อผิดพลาด stop ไปที่วิธีที่ 4

วิธีที่ 4: แทนการ์ดแสดงผล

สำหรับข้อมูลเกี่ยวกับวิธีการแทนการ์ดแสดงผลของคุณ โปรดดูเอกสารประกอบที่มาพร้อมกับคอมพิวเตอร์ของคุณหรือไม่

ถ้าวิธีการนี้ทำงาน คุณจะเสร็จเรียบร้อยแล้ว แก้ไขถ้าคุณยังคงได้รับข้อความแสดงข้อผิดพลาด stop และคุณเข้าใจ พยายามปัญหาขั้นสูงขั้นตอนต่อไป ไปส่วน "ขั้นสูงการแก้ไขปัญหา"

หากคุณไม่สะดวกในการแก้ไขปัญหาขั้นสูง คุณอาจต้องการที่ไปส่วน "ขั้นตอนถัดไป" สำหรับทรัพยากรเพิ่มเติมที่อาจจะช่วย

การแก้ไขปัญหาขั้นสูง

วิธีการเหล่านี้จัดทำขึ้นสำหรับผู้ใช้คอมพิวเตอร์ขั้นสูง หากคุณไม่สะดวกในการแก้ไขปัญหาขั้นสูง คุณอาจต้องขอความช่วยเหลือจากบุคคลอื่น หรือติดต่อฝ่ายสนับสนุน สำหรับข้อมูลเกี่ยวกับวิธีการติดต่อฝ่ายสนับสนุน แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/

วิธีที่ 1: ปิดใช้งาน หรือปรับปรุงโปรแกรมควบคุมอุปกรณ์

  1. ดู Microsoft ฮาร์ดแวร์เข้ากันได้รายการ (HCL) เพื่อดูว่า อุปกรณ์ pci บนคอมพิวเตอร์ที่เข้ากันได้กับ Windows XP สำหรับข้อมูลเกี่ยวกับรายการความเข้ากันได้ของฮาร์ดแวร์ แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
    http://www.microsoft.com/whdc/hcl/default.mspx
  2. ปรับปรุงโปรแกรมควบคุมการ์ดแสดงผลให้เป็นรุ่นล่าสุด
  3. หากโปรแกรมควบคุมแสดงตามชื่อในข้อความแสดงข้อผิดพลาด Stop ให้ปิดใช้งาน หรือเอาโปรแกรมควบคุมนั้นออก
  4. ปิดใช้งานหรือเอาโปรแกรมควบคุมหรือบริการที่คุณเพิ่งเพิ่มเข้าไปออก
หมายเหตุ หากข้อผิดพลาดเกิดขึ้นในระหว่างลำดับการเริ่มต้น และพาร์ติชันระบบใช้ระบบแฟ้ม NTFS คุณอาจสามารถใช้ safe mode เพื่อเปลี่ยนชื่อ หรือลบไดรเวอร์ที่ผิดพลาด ถ้าโปรแกรมควบคุมที่ถูกใช้เป็นส่วนหนึ่งของกระบวนการเริ่มต้นระบบในเซฟโหมด คุณต้องเริ่มคอมพิวเตอร์ โดยใช้ Recovery Console เพื่อใช้แฟ้มสำหรับข้อมูลเพิ่มเติมเกี่ยวกับโปรแกรมควบคุมการ์ดแสดงผลในเซฟโหมด คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
292460วิธีการแก้ไขปัญหาโปรแกรมควบคุมการ์ดแสดงผลในเซฟโหมดใน Windows XP
หมายเหตุ หากปัญหาเกี่ยวข้องกับแฟ้ม Win32k.sys ปัญหาอาจเกิดจากโปรแกรมควบคุมระยะไกลของบริษัทอื่น เมื่อต้องการเอาบริการ ใช้ Recovery Console เพื่อเริ่มคอมพิวเตอร์ แล้ว ลบแฟ้มบริการระบบที่ระบุ

ถ้าวิธีการนี้ทำงาน คุณจะเสร็จเรียบร้อยแล้ว ถ้าคุณยังคงได้รับข้อความแสดงข้อผิดพลาด stop ไปที่วิธีที่ 2

วิธีที่ 2: การปรับปรุงการเร่งด้วยฮาร์ดแวร์

  1. คลิก เริ่มคลิก 'แผงควบคุม'แล้ว คลิกสองครั้ง จอแสดงผล.
  2. ในการ การตั้งค่า แท็บ คลิก ขั้นสูงแล้ว คลิก การแก้ไขปัญหา แท็บ
  3. ย้าย การเร่งด้วยฮาร์ดแวร์ แถบเลื่อนไปที่ ไม่มีและจากนั้น คลิกเพื่อยกเลิกการ เปิดใช้งานการรวมการเขียน เมื่อคุณเลือกกล่องกาเครื่องหมาย
  4. คลิก ตกลงแล้ว คลิก ตกลง.
หมายเหตุ ขั้นตอนนี้ป้องกันไม่ให้การ์ดแสดงผลจากการเขียนโปรแกรม ฮาร์ดแวร์ไม่ถูกต้อง แต่คุณอาจสูญเสียฟังก์ชันบางอย่างแสดงผล และ ประสิทธิภาพการทำงาน ถึงแม้ว่าคุณสามารถเพิ่มการตั้งค่าการเร่งด้วยฮาร์ดแวร์ สูงกว่าไม่มีงานและประสิทธิภาพการทำงาน การเพิ่มการตั้งค่าเหล่านี้ ความเป็นไปได้ว่า ปัญหาที่จะเกิดขึ้นอีกครั้ง สำหรับความเสถียรสูงสุด ลา การเร่งด้วยฮาร์ดแวร์ออก

ขั้นตอนถัดไป

ถ้าวิธีการเหล่านี้ไม่ช่วยให้คุณ คุณสามารถใช้ลูกค้าสนับสนุนบริการเว็บไซต์ของ Microsoft เพื่อค้นหาวิธีแก้ไขปัญหาอื่น ๆ บริการบางอย่างที่ให้ Microsoft ลูกค้าสนับสนุนบริการเว็บไซต์มีดังนี้: ถ้าคุณยังมีคำถามหลัง จากที่คุณใช้เว็บไซต์ของ Microsoft เหล่านี้ หรือ ถ้าคุณไม่สามารถค้นหาวิธีการแก้ไขปัญหาในการสนับสนุนบริการเว็บไซต์ของ Microsoft คลิกการเชื่อมโยงต่อไปนี้เพื่อติดต่อฝ่ายสนับสนุน:
http://support.microsoft.com/contactus/
ผลิตภัณฑ์ของบริษัทอื่นที่กล่าวถึงในบทความนี้ เป็นผลิตภัณฑ์ที่ผลิตโดยบริษัทอื่นๆ ที่ไม่เกี่ยวข้องกับ Microsoft Microsoft ไม่รับประกันไม่ว่าโดยนัยหรือรูปแบบอื่นใด เกี่ยวกับประสิทธิภาพหรือความน่าเชื่อถือของผลิตภัณฑ์เหล่านี้

คุณสมบัติ

หมายเลขบทความ (Article ID): 293078 - รีวิวครั้งสุดท้าย: 31 พฤษภาคม 2556 - Revision: 3.0
ใช้กับ
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional x64 Edition
Keywords: 
kbresolve kbtshoot kbenv kberrmsg kbhardware kbprb kbmt KB293078 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:293078

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com