Article ID: 293351 - Last Review: September 26, 2005 - Revision: 3.2

FIX: Documents Processed by BizTalk Server Are Stuck in the Work Items Queue

This article was previously published under Q293351
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SYMPTOMS

When BizTalk Server attempts to process a document that requires a Custom Parser Component, the document may never move from the Work Items queue.

CAUSE

Custom Parser Components that are registered with BizTalk Server use the BizTalk Transport Dictionary to persist information about the data that is being processed. Between the stages of document processing, BizTalk Server checks the work being performed and attempts to persist the Transport Dictionary. When BizTalk Server attempts to persist the Transport Dictionary that is used by a Custom Parser Component, it fails and the item remains in the Work Items queue.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft BizTalk Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
299664  (http://support.microsoft.com/kb/299664/EN-US/ ) INFO: How to Obtain the Latest BizTalk Server 2000 Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft BizTalk Server 2000 Service Pack 1.

APPLIES TO
  • Microsoft BizTalk Server 2000 Standard Edition
Keywords: 
kbhotfixserver kbqfe kbbiztalk2000sp1fix kbbug kbfix KB293351
 

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