Des messages d'erreur HTTP 401 ou 404 s'affichent quand vous accédez à Outlook Web Access de manière implicite ou explicite

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Sommaire

Symptômes

Lorsque vous essayez de vous connecter à Outlook Web Access (OWA) de manière implicite (autrement dit, vous n'ajoutez pas l'URL à votre alias), vous pouvez recevoir l'un des messages d'erreur suivants :

Message d'erreur 1

HTTP/1.0 401 Non autorisé

Message d'erreur 2

Erreur : Accès refusé.

Message d'erreur 3

Page non trouvée
Lorsque vous examinez les fichiers journaux de Microsoft Internet Information Services (IIS), vous constatez la présence d'un code d'erreur 401.5. Les fichiers journaux IIS se trouvent en général dans le répertoire Windows\System32\LogFiles\W3SVC1.

Lorsque vous essayez de vous connecter à OWA de manière explicite (autrement dit, vous ajoutez l'URL à votre alias), vous pouvez recevoir le message d'erreur suivant :
- HTTP 404 - Fichier introuvable
Lorsque ce problème se produit, vous pouvez toujours accéder à votre boîte aux lettres par le biais du client MAPI Microsoft Outlook.

Cause

Ce problème se produit si le compte d'utilisateur que vous avez utilisé pour vous connecter à OWA n'a pas d'adresse SMTP (Simple Mail Transfer Protocol) appropriée.

Ce problème se produit généralement lorsque vous déplacez des utilisateurs d'un ordinateur Microsoft Exchange Server 5.5 à un ordinateur Microsoft Exchange 2000 Server ou Microsoft Exchange Server 2003 ou lorsque vous mettez à niveau un ordinateur Exchange 5.5 vers Exchange 2000 ou Exchange 2003 et que la stratégie d'affectation de noms par défaut dans votre organisation Exchange 2000 ou Exchange 2003 est différente de celle du site Exchange 5.5.

Il s'agit d'un problème d'architecture DAV (Web Distributed Authoring Version) fondamental. Pour rechercher la boîte aux lettres associée à une URL, DAV utilise les valeurs de l'attribut proxyAddresses de l'objet utilisateur, puis il compare ces valeurs au domaine et au répertoire virtuel Exchange afin d'établir une correspondance avec un objet unique dans le répertoire.

Pour plus d'informations sur la façon de déterminer l'adresse SMTP appropriée et l'adresse proxy de messagerie électronique par défaut qui sont générées par Exchange 2000, reportez-vous à la section « Plus Informations ».

Remarque La vérification d'adresse Web DAV n'est pas présente dans Microsoft Exchange 2003 Service Pack 1.

Résolution

Exchange 2003

Pour résoudre ce problème, procurez-vous le dernier Service Pack pour Exchange Server 2003. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
836993 Comment faire pour obtenir les derniers Service Packs de Microsoft Exchange Server 2003
Remarque L'installation de Microsoft Exchange Server 2003 Service Pack 1 (SP1) résout ce problème uniquement si les utilisateurs se connectent à OWA de manière implicite. Si les utilisateurs se connectent à OWA de manière explicite, ils peuvent encore recevoir le message d'erreur suivant :
- HTTP 404 - Fichier introuvable

Exchange 2000

Pour résoudre ce problème, appliquez l'une des méthodes suivantes :
  • Modifiez l'adresse SMTP ou ajoutez une nouvelle adresse SMTP pour les utilisateurs qui rencontrent le problème mentionné dans la section « Symptômes ». Vous pouvez appliquer cette méthode si le problème est limité à certains utilisateurs ou aux utilisateurs qui ont des adresses SMTP incorrectes.
  • Modifiez le domaine SMTP servi par le répertoire virtuel Exchange. Vous pouvez appliquer cette méthode si la plupart ou tous les utilisateurs de votre organisation rencontrent le problème mentionné dans la section « Symptômes ».
  • Créez des répertoires virtuels supplémentaires pour les domaines SMTP supplémentaires. Vous pouvez appliquer cette méthode si votre organisation a plusieurs domaines SMTP ou si vous utilisez Exchange 2000 pour l'hébergement.

    Remarque Vous pouvez également créer des serveurs virtuels HTTP supplémentaires pour les domaines SMTP supplémentaires. La complexité de ce processus dépasse la portée de cet article. Pour plus d'informations sur la façon de configurer des serveurs virtuels HTTP supplémentaires, reportez-vous à l'aide en ligne d'Exchange 2000 sur le site Web de Microsoft à l'adresse suivante (en anglais) :
    http://www.microsoft.com/technet/prodtechnol/exchange/guides/E2k3FrontBack/3e9956fb-1ad0-4cfd-b7ad-661c3f1cf816.mspx

Méthode 1 : Modification ou ajout d'une adresse SMTP à un utilisateur

  1. Déterminez le domaine SMTP en examinant la valeur Boîtes aux lettres pour le domaine SMTP dans le répertoire virtuel Exchange qui sert le domaine SMTP. Pour cela, procédez comme suit :
    1. Démarrez le Gestionnaire système Exchange.
    2. Développez successivement Groupes d'administration, Serveurs, nom_serveur, Protocoles, HTTP, Serveur virtuel Exchange, puis Exchange.
    3. Cliquez avec le bouton droit sur le répertoire virtuel Exchange, puis cliquez sur Propriétés.
    4. Notez le domaine SMTP répertorié sous la zone Boîtes aux lettres pour le domaine SMTP.
  2. Démarrez le composant logiciel enfichable Utilisateurs et ordinateurs Active Directory.
  3. Recherchez le compte d'utilisateur dans l'arborescence de la console, cliquez dessus avec le bouton droit, puis cliquez sur Propriétés. Par défaut, un utilisateur est créé dans l'unité d'organisation de l'utilisateur, mais l'utilisateur peut exister dans plusieurs unités d'organisation.
  4. Cliquez sur l'onglet Adresses de messagerie.
  5. Pour ajouter une adresse SMTP pour cet utilisateur, cliquez sur Nouveau, double-cliquez sur Adresse SMTP, puis tapez une adresse qui correspond à la valeur Boîtes aux lettres pour le domaine SMTP répertoriée dans les propriétés du répertoire virtuel Exchange obtenues à l'étape 1.
  6. Pour modifier une adresse SMTP existante, cliquez sur l'adresse à modifier, cliquez sur Modifier, puis tapez une adresse qui correspond à la valeur Boîtes aux lettres pour domaine STMP répertoriée dans les propriétés du répertoire virtuel Exchange.
  7. Cliquez deux fois sur OK.
Il faudra peut-être un petit moment pour qu'Active Directory réplique la nouvelle adresse avant que cet utilisateur puisse se connecter à OWA.

Remarque Il n'est pas obligé que l'adresse SMTP par défaut (en gras) d'un utilisateur corresponde à la valeur Boîtes aux lettres pour. L'utilisateur doit être en mesure de se connecter si l'une des adresses SMTP correspond à la valeur.

Méthode 2 : Modification du domaine SMTP servi par le répertoire virtuel Exchange

Dans la boîte de dialogue Propriétés du répertoire virtuel Exchange, le bouton Modifier n'est pas disponible (il apparaît estompé). Ce problème se produit car le domaine SMTP utilisé par le répertoire virtuel Exchange est toujours le domaine SMTP par défaut qui est assigné par la stratégie de destinataire par défaut.

Pour modifier le domaine SMTP par défaut, procédez comme suit.

Remarque Ces étapes incluent le redémarrage de la banque d'informations Microsoft Exchange et de ses services dépendants. Pendant que la banque d'informations est arrêtée, aucun client ne peut accéder à la messagerie électronique.
  1. Démarrez le Gestionnaire système Exchange.
  2. Développez le conteneur Destinataires.
  3. Sélectionnez l'objet Stratégies de destinataire.
  4. Dans le volet droit, recherchez la Stratégie par défaut et affichez ses propriétés.
  5. Cliquez sur l'onglet Adresses de messagerie.
  6. Double-cliquez sur l'adresse SMTP. Si plusieurs adresses SMTP sont répertoriées, double-cliquez sur l'adresse SMTP affichée en gras.
  7. Laissez l'arobase (@) au début, puis tapez le domaine SMTP souhaité dans le champ Adresse.
  8. Cliquez deux fois sur OK.
  9. Démarrez le composant logiciel enfichable Services.
  10. Cliquez sur le service Microsoft Exchange - Banque d'informations.
  11. Cliquez sur Redémarrer le service dans la barre d'outils MMC (Microsoft Management Console). Lorsque vous êtes invité à redémarrer les services dépendants, cliquez sur Oui. La valeur Boîte aux lettres pour sera mise à jour de façon à utiliser votre nouveau domaine SMTP.

Méthode 3 : Création de répertoires virtuels supplémentaires pour les domaines SMTP supplémentaires

Remarque Si l'ordinateur utilise des serveurs frontaux et des serveurs principaux, vous devez créer les répertoires virtuels sur les serveurs frontaux et les serveurs principaux.
  1. Démarrez le Gestionnaire système Exchange.
  2. Développez successivement Serveurs, nom_serveur, Protocoles, HTTP et enfin Serveur virtuel Exchange.
  3. Cliquez avec le bouton droit sur le serveur virtuel Exchange, cliquez sur Nouveau, puis sur Répertoire virtuel.
  4. Tapez le nom du nouveau répertoire virtuel Exchange.

    Ce nom apparaîtra dans l'URL utilisée par les clients pour accéder au nouveau répertoire virtuel. Par exemple, si vous créez un répertoire virtuel nommé companybmail, les clients utiliseront une URL semblable à http://www.domain.com/companybmail/.
  5. Pour sélectionner un domaine SMTP, cliquez sur le bouton Modifier, puis sélectionnez un domaine SMTP dans la liste.

    Remarque Cette liste est générée à partir de toutes les valeurs d'adresses SMTP dans toutes les stratégies de destinataires définies dans votre organisation Exchange. Vous ne pouvez pas fournir un domaine SMTP qui n'apparaît pas dans cette liste.
Pour plus d'informations sur la gestion des stratégies de destinataires, reportez-vous à la rubrique d'aide « Managing Recipient Settings » dans la documentation en ligne d'Exchange 2000 sur le site Web de Microsoft à l'adresse suivante (en anglais) :
http://www.microsoft.com/technet/prodtechnol/exchange/2000/maintain/exrecip.mspx
Pour personnaliser des méthodes d'authentification, cliquez sur le bouton Authentification sous l'onglet Accès du Gestionnaire système Exchange.

Plus d'informations

Pour déterminer l'adresse SMTP appropriée, procédez comme suit :
  1. Démarrez le Gestionnaire système Exchange.
  2. Développez successivement Serveurs, nom_serveur, Protocoles, HTTP, Serveur virtuel Exchange, puis Exchange.
  3. Cliquez avec le bouton droit sur le répertoire virtuel Exchange, puis cliquez sur Propriétés pour afficher les propriétés du répertoire virtuel Exchange. Il s'agit du répertoire virtuel OWA par défaut créé pendant l'installation d'Exchange Server.
  4. Sous l'onglet Général, notez la valeur du champ libellé Chemin d'accès Exchange. Cette valeur peut être par exemple example.com (valeur par défaut). Dans cet exemple, seuls les utilisateurs ayant une adresse SMTP se terminant par @example.com peuvent utiliser le répertoire virtuel Exchange pour accéder à leurs boîtes aux lettres.
Pour déterminer l'adresse proxy de messagerie électronique par défaut générée par Exchange 2000
  1. Démarrez le composant logiciel enfichable Gestionnaire système Exchange.
  2. Développez Destinataires, puis cliquez sur Stratégies de destinataire.
  3. Dans le volet droit, double-cliquez sur Stratégie par défaut, puis cliquez sur l'onglet Adresses de messagerie (Stratégie).
  4. Sous Règles de génération, double-cliquez sur l'adresse SMTP répertoriée en gras.
  5. Dans la zone Adresse, notez les paramètres de configuration (le cas échéant) répertoriés avant l'arobase (@). Par exemple, ces paramètres peuvent inclure %s ou %g.
Ces paramètres sont utilisés pour générer l'adresse de messagerie de destinataire basée sur les informations du compte d'utilisateur. Par exemple, le paramètre %s.%g@example.com fait en sorte qu'Exchange 2000 génère l'adresse de messagerie suivante :

nom_de_famille.prénom@example.com

Propriétés

Numéro d'article: 293386 - Dernière mise à jour: lundi 26 novembre 2007 - Version: 9.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft BackOffice Small Business Server 2000 Service Pack 1
  • Microsoft Small Business Server 2000 Standard Edition
Mots-clés : 
kberrmsg kbprb KB293386
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