Messaggio di errore HTTP 401 o 404 quando si accede a OWA in modo implicito o esplicito

Traduzione articoli Traduzione articoli
Identificativo articolo: 293386 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di accedere a Outlook Web Access (OWA) in modo implicito, ovvero non si aggiunge l'alias all'URL, Ŕ possibile che venga visualizzato un messaggio di errore analogo a uno di quelli riportati di seguito:

Messaggio di errore 1

HTTP/1.0 401 Non autorizzato

Messaggio di errore 2

Errore: Accesso negato.

Messaggio di errore 3

Impossibile trovare la pagina.
Se si esaminano i file di registro di Microsoft Internet Information Services (IIS), si noterÓ un codice di errore 401.5. I file di registro di IIS si trovano solitamente nella directory Windows\System32\LogFiles\W3SVC1.

Quando si tenta di accedere a OWA in modo esplicito, ovvero si aggiunge l'alias all'URL, Ŕ possibile che venga visualizzato un messaggio di errore analogo al seguente:
- HTTP 404 - File non trovato
Se si verifica questo problema, Ŕ tuttavia possibile accedere alla cassetta postale utilizzando il client MAPI Microsoft Outlook.

Cause

Questo problema si verifica se per l'account utente utilizzato per l'accesso a OWA non Ŕ configurato un indirizzo SMTP (Simple Mail Transfer Protocol) appropriato.

In genere questo problema Ŕ dovuto allo spostamento di utenti da un computer che esegue Microsoft Exchange Server 5.5 a un computer che esegue Microsoft Exchange 2000 Server o Microsoft Exchange Server 2003 oppure all'aggiornamento di un computer che esegue Exchange 5.5 a Exchange 2000 o Exchange 2003 e al fatto che i criteri di denominazione predefiniti nell'organizzazione di Exchange 2000 o Exchange 2003 sono diversi da quelli nel sito di Exchange 5.5.

Si tratta di un problema dell'architettura di base di WebDav (Web Distributed Authoring and Versioning). Per individuare la cassetta postale associata a un URL, in WebDav vengono utilizzati i valori nell'attributo proxyAddresses dell'oggetto utente. Questi valori vengono quindi confrontati con il dominio e la directory virtuale di Exchange per trovare una corrispondenza con un oggetto univoco nella directory.

Per informazioni su come determinare l'indirizzo SMTP appropriato e l'indirizzo proxy di posta elettronica predefinito generato da Exchange 2000, vedere la sezione "Informazioni".

Nota La funzionalitÓ di controllo dell'indirizzo tramite WebDav non Ŕ presente in Microsoft Exchange 2003 Service Pack 1.

Risoluzione

Exchange 2003

Per risolvere questo problema, procurarsi l'ultimo service pack per Exchange Server 2003. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
836993 Come ottenere i service pack pi¨ recenti per Exchange Server 2003
Nota L'installazione di Microsoft Exchange Server 2003 Service Pack 1 (SP1) consente di risolvere questo problema solo se gli utenti effettuano l'accesso a OWA in modo implicito. Se l'accesso a OWA viene effettuato in modo esplicito, Ŕ possibile che venga visualizzato un messaggio di errore analogo al seguente:
- HTTP 404 - File non trovato

Exchange 2000

Per risolvere il problema, utilizzare uno dei metodi seguenti:
  • Modificare l'indirizzo SMTP o aggiungere un nuovo indirizzo SMTP per gli utenti che rilevano il problema descritto nella sezione "Sintomi". Si consiglia di utilizzare questo metodo se il problema Ŕ limitato ad alcuni utenti o a utenti con indirizzi SMTP non validi.
  • Modificare il dominio SMTP servito dalla directory virtuale di Exchange. Si consiglia di utilizzare questo metodo se il problema descritto nella sezione "Sintomi" viene rilevato dalla maggior parte o da tutti gli utenti nell'organizzazione.
  • Creare ulteriori directory virtuali per domini SMTP aggiuntivi. Si consiglia di utilizzare questo metodo se nell'organizzazione sono presenti pi¨ domini SMTP o se Exchange 2000 viene utilizzato in una configurazione di hosting.

    Nota ╚ inoltre possibile creare ulteriori server virtuali HTTP per domini SMTP aggiuntivi. Questo processo non rientra tuttavia nell'ambito dei problemi discussi in questo articolo. Per ulteriori informazioni sull'impostazione di ulteriori server virtuali HTTP, vedere la Guida in linea relativa a Exchange 2000 sul seguente sito Web Microsoft (informazioni in lingua inglese):
    http://www.microsoft.com/technet/prodtechnol/exchange/guides/E2k3FrontBack/3e9956fb-1ad0-4cfd-b7ad-661c3f1cf816.mspx

Metodo 1: Modificare o aggiungere un indirizzo SMTP per un utente

  1. Determinare il dominio SMTP mediante l'analisi del valore Cassette postali per dominio SMTP nella directory virtuale di Exchange che serve il dominio SMTP. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Avviare il Gestore di sistema di Exchange.
    2. Espandere Gruppi amministrativi, espandere Server, espandere NomeServer, espandere Protocolli, HTTP, Server virtuale di Exchange e quindi Exchange.
    3. Fare clic con il pulsante destro del mouse sulla directory virtuale di Exchange, quindi scegliere ProprietÓ.
    4. Annotare il dominio SMTP indicato sotto la casella Cassette postali per dominio SMTP.
  2. Avviare lo snap-in Utenti e computer di Active Directory.
  3. Individuare l'account utente nella struttura della console, fare clic con il pulsante destro del mouse sull'account utente, quindi scegliere ProprietÓ. Per impostazione predefinita, l'utente viene creato nella relativa unitÓ organizzativa, tuttavia pu˛ essere presente in pi¨ unitÓ organizzative.
  4. Fare clic sulla scheda Indirizzi di posta elettronica.
  5. Per aggiungere un indirizzo SMTP per l'utente, scegliere Nuovo, fare doppio clic su Indirizzo SMTP, quindi digitare un indirizzo corrispondente al valore di Cassette postali per dominio SMTP nelle proprietÓ della directory virtuale di Exchange annotato nel passaggio 1.
  6. Per modificare un indirizzo SMTP esistente, fare clic sull'indirizzo desiderato, scegliere Modifica, quindi digitare un indirizzo che corrisponda al valore di Cassette postali per dominio SMTP nelle proprietÓ della directory virtuale di Exchange.
  7. Scegliere OK due volte.
Per poter accedere a OWA, l'utente dovrÓ attendere che il nuovo indirizzo venga replicato da Active Directory. Questa operazione potrebbe richiedere del tempo.

Nota Non Ŕ necessario che l'indirizzo SMTP predefinito (in grassetto) di un utente corrisponda al valore di Cassette postali per. L'utente dovrebbe essere in grado di effettuare l'accesso se uno qualsiasi degli indirizzi SMTP corrisponde al valore specificato.

Metodo 2: Modificare il dominio SMTP servito dalla directory virtuale di Exchange

Nella finestra di dialogo delle proprietÓ della directory virtuale di Exchange il pulsante Modifica non Ŕ disponibile (Ŕ visualizzato in grigio). Questo comportamento Ŕ dovuto al fatto che il dominio SMTP utilizzato dalla directory virtuale di Exchange Ŕ sempre il dominio SMTP predefinito assegnato dal criterio destinatario predefinito.

Per modificare il dominio SMTP predefinito, attenersi alla seguente procedura:

Nota Questa procedura prevede il riavvio dell'archivio informazioni di Microsoft Exchange e dei servizi dipendenti. Durante l'arresto dell'archivio informazioni nessun client potrÓ accedere alla posta elettronica.
  1. Avviare il Gestore di sistema di Exchange.
  2. Espandere il contenitore Destinatari.
  3. Selezionare l'oggetto Criteri destinatari.
  4. Nel riquadro destro individuare il criterio predefinito e visualizzarne le proprietÓ.
  5. Fare clic sulla scheda Indirizzi di posta elettronica.
  6. Fare doppio clic sull'indirizzo SMTP. Se sono elencati pi¨ indirizzi SMTP, fare doppio clic su quello formattato in grassetto.
  7. Lasciare la chiocciola (@) iniziale e digitare il dominio SMTP desiderato nel campo Indirizzo.
  8. Scegliere OK due volte.
  9. Avviare lo snap-in Servizi.
  10. Fare clic sul servizio Archivio informazioni di Microsoft Exchange.
  11. Fare clic sul pulsante relativo al riavvio del servizio sulla barra degli strumenti di Microsoft Management Console (MMC). Quando viene chiesto di riavviare i servizi dipendenti, scegliere . Il valore di Cassette postali per verrÓ aggiornato con il nuovo dominio SMTP.

Metodo 3: Creare ulteriori directory virtuali per domini SMTP aggiuntivi

Nota Se nel computer vengono utilizzati server front-end e back-end, sarÓ necessario creare le directory virtuali su entrambi i tipi di server.
  1. Avviare il Gestore di sistema di Exchange.
  2. Espandere Server, espandere NomeServer, Protocolli, HTTP e quindi espandere Server virtuale di Exchange.
  3. Fare clic con il pulsante destro del mouse sul server virtuale di Exchange, scegliere Nuovo, quindi fare clic su Directory virtuale.
  4. Digitare il nome della nuova directory virtuale.

    Questo nome verrÓ visualizzato nell'URL utilizzato dai client per accedere alla nuova directory virtuale. Ad esempio, se si crea una nuova directory virtuale denominata aziendabposta, i client utilizzeranno un URL analogo a http://www.dominio.it/aziendabposta/.
  5. Per selezionare un dominio SMTP, scegliere il pulsante Modifica e quindi selezionare un dominio SMTP dall'elenco.

    Nota Questo elenco viene generato da tutti i valori relativi agli indirizzi SMTP in tutti i criteri destinatari definiti nell'organizzazione di Exchange. Non Ŕ possibile specificare un dominio SMTP non presente in questo elenco.
Per ulteriori informazioni sulla gestione dei criteri destinatari, vedere l'argomento relativo alla gestione delle impostazioni per i destinatari nell'argomento della Guida in linea di Exchange 2000 disponibile sul seguente sito Web Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/technet/prodtechnol/exchange/2000/maintain/exrecip.mspx
Per personalizzare i metodi di autenticazione, scegliere il pulsante Autenticazione nella scheda Accesso del Gestore di sistema di Exchange.

Informazioni

Per determinare l'indirizzo SMTP appropriato, attenersi alla seguente procedura:
  1. Avviare il Gestore di sistema di Exchange.
  2. Espandere Server, espandere NomeServer, espandere Protocolli, HTTP, Server virtuale di Exchange e quindi Exchange.
  3. Fare clic con il pulsante destro del mouse sulla directory virtuale di Exchange, quindi scegliere ProprietÓ per visualizzare le relative proprietÓ. Questa Ŕ la directory virtuale OWA predefinita creata durante l'installazione di Exchange Server.
  4. Nella scheda Generale osservare il valore riportato nel campo Percorso di Exchange. Questo valore potrebbe essere, ad esempio, example.com (predefinito). In questo esempio solo gli utenti con un indirizzo SMTP che termina con @example.com potranno utilizzare la directory virtuale di Exchange per accedere alle cassette postali.
Per determinare l'indirizzo proxy di posta elettronica predefinito generato da Exchange 2000:
  1. Avviare lo snap-in Gestore di sistema di Exchange.
  2. Espandere Destinatari, quindi fare clic su Criteri destinatari.
  3. Nel riquadro destro fare doppio clic sul criterio predefinito, quindi fare clic sulla scheda Indirizzi di posta elettronica (Criterio).
  4. In Regole di generazione fare doppio clic sull'indirizzo SMTP visualizzato in grassetto.
  5. Nella casella Indirizzo osservare i parametri di configurazione, se presenti, visualizzati prima della chiocciola (@). Questi parametri possono includere, ad esempio, %s o %g.
Tali parametri vengono utilizzati per generare l'indirizzo di posta elettronica del destinatario in base alle informazioni sull'account utente. Ad esempio, l'impostazione del parametro %s.%g@example.com comporterÓ la generazione del seguente indirizzo di posta elettronica da parte di Exchange 2000:

cognome.nome@example.com

ProprietÓ

Identificativo articolo: 293386 - Ultima modifica: lunedý 26 novembre 2007 - Revisione: 9.2
Le informazioni in questo articolo si applicano a
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft BackOffice Small Business Server 2000 Service Pack 1
  • Microsoft Small Business Server 2000 Standard Edition
Chiavi:á
kberrmsg kbprb KB293386
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com