O software de caminho vários poderá provocar a assinatura de disco alterar

Traduções de Artigos Traduções de Artigos
Artigo: 293778 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

A assinatura de disco e o identificador exclusivo global (GUID) para um disco podem ser alteradas inesperadamente em computadores que tenham redundante Host Bus placas (HBA) num disco externo comuns. Neste caso, os programas que dependem destas assinaturas de disco no registo de arranque principal (MBR, Master Boot Record) poderão falhar.

Clustering do Windows utiliza as assinaturas do disco e respectivos GUIDs montar discos e colocar online os discos. Se a assinatura do disco for alterado, os discos poderão falhar e poderá ser registada a seguinte mensagem de erro no Visualizador de eventos:
ID do evento: 1034
Origem: ClusDisk
Descrição: Não foi possível encontrar o disco associado ao cluster disco recurso DriveLetter. A assinatura esperada do disco foi DiskSignature.
Outra sintoma de GUID de volume alterado ou a assinatura do disco pode ser que letras de unidade podem ser reatribuídas (reordenados) após um reinício.

Causa

Este problema pode ocorrer se tiver configurado o software de múltiplos caminho incorrectamente ou se este software não funcionar correctamente. Para redundância adicional, pode adicionar vários controladores para aceder a um disco externo. Software de múltiplos caminho controla estes dois controladores e torna-as parece ser um único controlador para o sistema operativo. Caminho vários software também torna o disco parecer uma única unidade do sistema operativo. Se este software apresenta o mesmo disco para o Windows 2000 duas vezes (uma representação de cada controlador), podem ocorrer problemas. Se Ftdisk detecta um 0 (zero) ou assinatura de disco duplicados, em seguida, escreve uma nova assinatura sem pedir confirmação ou notificar o utilizador.

Tem de alterar a assinatura imediatamente porque Ftdisk não pode comunicar o mesmo exclusivo ID (que é composto pelo desvio de assinatura e a partição) para o Mount Manager (Mountmgr). Quando Mountmgr vê um novo ID exclusivo, cria um novo volume GUID e uma unidade nova letra atribuição para esse novo volume.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentada, submeta um pedido para o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.
Pré-requisitos
Não pré-requisitos são necessários.
Informações sobre substituição de correcções
Esta correcção não substitui quaisquer outras correcções.
Informações do ficheiro
A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
Date         Time  Version        Size     File name 
-----------------------------------------------------
10-May-2004  17:44 5.0.2195.6920  116,400  Ftdisk.sys

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Esta correcção é incluída na lista de correcções recomendadas proactivamente sejam aplicadas a clusters de servidor do Windows 2000. Clique no número de artigo que se segue para visualizar o artigo que contém esta lista na base de dados de conhecimento da Microsoft:

895090Correcções recomendadas para clusters de servidor baseado no Windows 2000 Service Pack 4
Esta correcção deve ser avaliada e proactivamente aplicada a todos os clusters de servidor que estão a ser afectado negativamente pelo problema descrito neste artigo.

Para obter mais informações sobre a nomes a pacotes de correcções, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
816915Novo esquema de atribuição de nomes de ficheiros para pacotes de correcção do Microsoft Windows

Propriedades

Artigo: 293778 - Última revisão: 31 de outubro de 2006 - Revisão: 4.8
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbenv kbprb KB293778 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 293778

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com