FIX: Unable to Drop a Catalog When Disk is Full

Article translations Article translations
Article ID: 293784 - View products that this article applies to.
This article was previously published under Q293784
BUG #: 236752 (SHILOH_BUGS)
Expand all | Collapse all

SYMPTOMS

An attempt to drop a full-text catalog may fail if the disk where the catalog resides is full when you execute this code:
sp_fulltext_catalog 'catalogname', 'drop'
				

CAUSE

To drop a full-text catalog you must stop the merge process for the catalog. When the disk where the catalog resides is full the merge process cannot complete and cannot be stopped. Note that the merge process begins automatically each time MSSearch is started.

RESOLUTION

To resolve this problem, obtain the latest service pack for SQL Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
290211 INF: How to Obtain the Latest SQL Server 2000 Service Pack

WORKAROUND

Free enough drive space for the merge to complete.

STATUS

Microsoft has confirmed that this is a problem in SQL Server 2000. This problem was first corrected in SQL Server 2000 Service Pack 1.

Properties

Article ID: 293784 - Last Review: November 6, 2003 - Revision: 3.2
APPLIES TO
  • Microsoft SQL Server 2000 Standard Edition
Keywords: 
kbbug kbfix kbsqlserv2000sp1fix KB293784

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com