Artikel-ID: 293826 - Geändert am: Freitag, 13. Oktober 2006 - Version: 4.2

Funktion für Mustervergleich bewirkt Zugriffsverletzung auf FTP-Server

Dieser Artikel wurde zuvor veröffentlicht unter D45074
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
293826  (http://support.microsoft.com/kb/293826/EN-US/ ) Pattern-Matching Function Causes Access Violation on FTP Server
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Problembeschreibung

Bei Microsoft Internet Information Services (IIS) 5.0 und Microsoft Internet Information Server (IIS) 4.0 besteht eine Denial of Service (DoS)-Anfälligkeit ("Dienstverweigerung"), da die Funktion, die Platzhalterfolgen in FTP-Befehlen verarbeitet, beim Mustervergleich nicht immer genügend Speicher zuweist. Unter selten auftretenden Bedingungen kann ein Angreifer dadurch einen FTP-Befehl mit einer Platzhalterfolge absetzen, die bei Auflösung den zugewiesenen Speicher überschreitet und eine Zugriffsverletzung bewirkt.

Dieses Szenario kann dazu führen, dass der IIS-Dienst (der sowohl die Web- als auch die FTP-Funktionalität bietet) nicht mehr funktioniert. Dadurch werden alle zu diesem Zeitpunkt laufenden Web- oder FTP-Sitzungen abgebrochen, und neue Sitzungen können erst nach dem Neustart des IIS-Dienstes wieder aufgebaut werden. In IIS 5.0 wird der Dienst automatisch neu gestartet. Bei IIS 4.0 muss ein Operator den Dienst neu starten.

Diese Anfälligkeit ermöglicht es dem Angreifer nicht, Daten auf dem Server hinzuzufügen, zu ändern oder zu löschen. Auch kann er sich keine Administratorberechtigungen verschaffen.

Schadensbegrenzender Faktor
Der Angreifer muss eine FTP-Sitzung starten können, um die Anfälligkeit nutzen zu können.

Ursache

Dieses Problem tritt aufgrund eines Fehlers in einer Mustervergleichsfunktion auf, die von mindestens einem FTP-Befehl genutzt wird. Abhängig von der angegebenen Platzhalterfolge und der speziellen Dateisystemkonfiguration des Servers kann das resultierende Muster den verfügbaren Speicher überschreiten und eine Zugriffsverletzung auslösen. Dadurch wiederum funktioniert der IIS-Dienst nicht mehr.

Lösung

Weitere Informationen zu den Problemen, die durch diese Patches behoben werden, finden Sie in folgendem Artikel der Microsoft Knowledge Base:
D45076  (http://support.microsoft.com/kb/D45076/DE/ ) Patch-Rollup IIS 5.0 (Sicherheit) und IIS 4.0 (Patches ab Windows NT 4.0 SP5)

Internet Information Services 5.0
Ein Update zur Behebung dieses Problems ist inzwischen von Microsoft erhältlich. Dieses Update dient nur zur Behebung des in diesem Artikel beschriebenen Problems und sollte daher nur bei tatsächlich gefährdeten Systemen angewendet werden. Bitte überprüfen Sie die physische Zugänglichkeit, die Netzwerk- und Internet-Konnektivität Ihres Systems sowie weitere Faktoren, um den Risikograd für Ihr System zu bestimmen. Hilfestellung dafür finden Sie in dem entsprechenden Microsoft-Sicherheitsbulletin (http://www.microsoft.com/technet/security/bulletin/ms01-026.mspx). Dieses Update wird möglicherweise zu einem späteren Zeitpunkt weiteren Tests unterzogen, um die Produktqualität zusätzlich zu gewährleisten. Wenn ein entsprechender Risikograd für Ihr System besteht, empfiehlt Microsoft, dieses Update anzuwenden. Andernfalls sollten Sie auf das nächste Windows 2000-Service Pack warten, das dieses Update enthält.

Wenn Sie das Problem sofort beheben wollen, laden Sie das Update wie im folgenden beschrieben herunter oder wenden Sie sich an den Microsoft-Produktsupport, um das Update zu erhalten.

Folgende Datei steht Ihnen im Microsoft Download Center zum Download zur Verfügung:
   q293826_w2k_sp3_x86_de.exe
   http://www.microsoft.com/Downloads/details.aspx?displaylang=en&FamilyID=00E2349B-A200-4DCF-A78E-5532BC225AFD
Hinweis: Dieser Patch kann auf Systemen mit Windows 2000 Gold, Windows 2000 Service Pack 1 oder Windows 2000 Service Pack 2 installiert werden.

Internet Information Server 4.0
Ein Update zur Behebung dieses Problems ist inzwischen von Microsoft erhältlich. Dieses Update dient nur zur Behebung des in diesem Artikel beschriebenen Problems und sollte daher nur bei tatsächlich gefährdeten Systemen angewendet werden. Bitte überprüfen Sie die physische Zugänglichkeit, die Netzwerk- und Internet-Konnektivität Ihres Systems sowie weitere Faktoren, um den Risikograd für Ihr System zu bestimmen. Hilfestellung dafür finden Sie in dem entsprechenden Microsoft-Sicherheitsbulletin (http://www.microsoft.com/technet/security/bulletin/ms01-026.mspx). Dieses Update wird möglicherweise zu einem späteren Zeitpunkt weiteren Tests unterzogen, um die Produktqualität zusätzlich zu gewährleisten. Wenn ein entsprechender Risikograd für Ihr System besteht, empfiehlt Microsoft, dieses Update anzuwenden. Andernfalls sollten Sie auf das nächste Windows 2000-Service Pack warten, das dieses Update enthält.

Wenn Sie das Problem sofort beheben wollen, laden Sie das Update wie im folgenden beschrieben herunter oder wenden Sie sich an den Microsoft-Produktsupport, um das Update zu erhalten.

Folgende Datei steht Ihnen im Microsoft Download Center zum Download zur Verfügung:
   q295534i.exe
   http://www.microsoft.com/Downloads/details.aspx?displaylang=en&FamilyID=8A13DE26-62A1-4306-9C99-C5EB6938A5A0
Hinweis: Q295534is.exe enthält die Symboldateien.

Hinweis: Dieser Patch kann auf Systemen mit Windows NT 4.0 Service Pack 5 oder Windows NT 4.0 Service Pack 6a installiert werden.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den oben genannten Microsoft-Produkten handelt.

Weitere Informationen

Weitere Informationen zu diesem Sicherheitsproblem finden Sie auf folgender Microsoft-Website:
   http://www.microsoft.com/technet/security/Bulletin/MS01-026.mspx
Die Telefonnummern des Technischen Supports lauten:
   Deutschland: 0180 567 23 30
   Österreich : 01 50222 23 30 
   Schweiz    : 0848 80 23 30
Alternativ erhalten Sie auch eine vollständige Liste mit Telefonnummern des Microsoft Software Service unter der folgenden Adresse im World Wide Web:
   http://support.microsoft.com/default.aspx?scid=fh;DE;PHONENUMBERS
Hinweis: In besonderen Fällen können die üblichen Gebühren für Supportanrufe entfallen, wenn der Microsoft-Support feststellt, dass ein bestimmtes Update Ihr Problem beheben kann. Die normalen Supportgebühren gelten für zusätzliche Supportfragen und Probleme, die durch das jeweilige Update nicht abgedeckt werden.

Weitere Informationen zum Herunterladen von Microsoft-Support-Dateien finden Sie in folgenden Artikel der Microsoft Knowledge Base:
D36154  (http://support.microsoft.com/kb/D36154/DE/ ) Wie erhalte ich Dateien vom Microsoft Support im Internet?

Weitere Informationen zur gleichzeitigen Installation von Windows 2000 und Windows 2000-Hotfixes finden Sie in folgendem Artikel der Microsoft Knowledge Base:
D42122  (http://support.microsoft.com/kb/D42122/DE/ ) Installation von Microsoft Windows 2000 und Windows 2000-Hotfixes

Weitere Suchbegriffe: security_patch hack DoS ftp nuke

Microsoft hat die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war, um diese Datei auf Viren zu prüfen. Nach der Bereitstellung befindet sich die Datei auf sicheren Servern, wodurch nicht autorisierte Änderungen an der Datei verhindert werden.

Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.


Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Internet Information Services 5.0
  • Microsoft Internet Information Server 4.0
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kbqfe kbhotfixserver kbwinnt400presp7fix KB293826
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