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現象

Microsoft Windows 95、Microsoft Windows 98、または Microsoft Windows 98 Second Edition を実行しているクライアントコンピューターを使用して、Microsoft cluster またはスタンドアロンサーバーの一部としてインストールされたネットワークプリンターに印刷すると、次のエラーメッセージが表示されることがあります。

テストページが印刷されません。 問題解決のためのシューティングを参照してください。 アクセスが拒否されました。

原因

この問題は、McAfee ウイルス対策ソフトウェアが、windows 95、Windows 98、または Windows 98 Second Edition を実行しているクライアント、または Windows NT Server 4.0 を実行しているサーバー上でファイルのリアルタイムスキャンを実行するように設定されている場合に発生することがあります。 McAfee アンチウイルスは、印刷ジョブの処理中にスプールファイルをスキャンします。 McAfee のウイルス対策ソフトウェアによってファイルが開かれているため、Windows はファイルを閉じることができません。 これらのファイルは、 Systemroot\System32\Spool\Printers フォルダーに残ります。 Shd ファイルと spl ファイルは、印刷ジョブが完了として表示された後もフォルダーに残ります。

解決方法

この問題を解決するには、このセクションで説明するいずれかの方法を使用します。

プリントサーバーでエラーメッセージが表示される

Windows NT Server 4.0 を実行しているプリントサーバーでエラーメッセージが表示された場合は、次の操作を行います。

  1. スプールフォルダー内の破損したファイルを削除します。

    1. [スタート] ボタンをクリックし、[設定] をポイントし、[コントロール パネル] をクリックします。

    2. [ サービス] をダブルクリックし、[ スプーラー] をクリックして、[ 停止] をクリックします。

    3. 次のメッセージが表示されたら、[はい] をクリックします。

      スプーラーサービスを停止してもよろしいですか?

    4. [ スタート] をクリックし、[ プログラム] をポイントして、[ Windows NT エクスプローラー] をクリックします。

    5. Winntフォルダーを展開し、[ System32 ] フォルダーを展開して、[スプール] フォルダーを展開します。

    6. [ プリンター ] フォルダーをクリックし、右側のウィンドウに表示されているすべてのファイルをクリックして、[ 削除] をクリックします。

    7. 次のメッセージが表示されたら、[はい] をクリックします。

      これらの x 項目をごみ箱に送信してもよろしいですか?

    8. 手順 A と B を繰り返してスプーラーサービスを再起動し、[ 開始] をクリックします。

  2. 最後のページがスプールされた後に、問題が発生して印刷を開始するようにプリンターを設定します。

    1. [スタート] ボタンをクリックし、[設定] をポイントし、[プリンター] をクリックします。

    2. 問題が発生しているプリンターを右クリックし、[ プロパティ] をクリックします。

    3. [ スケジュール ] タブをクリックし、[ドキュメントのスプール] をクリックすると、 プログラムの印刷が速く終了します。

    4. [ 最後のページをスプールした後に印刷を開始する] をクリックし、[ OK] をクリックします。

  3. プリンターに直接印刷するときに問題が発生するプリンターを設定します。

    1. [スタート] ボタンをクリックし、[設定] をポイントし、[プリンター] をクリックします。

    2. 問題が発生しているプリンターを右クリックし、[ プロパティ] をクリックします。

    3. [ スケジュール ] タブをクリックし、[ プリンターに直接印刷] をクリックして、[ OK]をクリックします。

  4. McAfee アンチウイルスプログラムをバージョン4.5 以降にアップグレードします。

  5. スプールフォルダーに適切な権限があることを確認します。スプールフォルダーの適切なアクセス許可の詳細については、以下の記事の番号をクリックして、Microsoft サポート技術情報の記事を参照してください。

    137503 既定の Windows スプールディレクトリと権限

クライアントでエラーメッセージが表示される

Windows 95、Windows 98、または Windows 98 Second Edition のいずれかを実行しているクライアントでエラーメッセージが表示される場合は、次の操作を行います。

  1. スプールフォルダー内の破損したファイルを削除します。

    1. [スタート] をクリックし、[すべてのプログラム] をポイントして、[エクスプローラー] をクリックします。

    2. [ Windows ] フォルダーを展開し、[ スプール ] フォルダーを展開して、[ プリンター ] フォルダーをクリックします。

    3. 右側のウィンドウに表示されているすべてのファイルをクリックし、[ 削除] をクリックします。

    4. 次のメッセージが表示されたら、[はい] をクリックします。

      これらの x 項目をごみ箱に送信してもよろしいですか?

  2. 最後のページがスプールされた後に、問題が発生して印刷を開始するようにプリンターを設定します。

    1. [スタート] ボタンをクリックし、[設定] をポイントし、[プリンター] をクリックします。

    2. 問題が発生しているプリンターを右クリックし、[ プロパティ] をクリックします。

    3. [ 詳細 ] タブをクリックし、[ スプールの設定] をクリックし、[印刷ドキュメントのスプール] をクリックして、プログラムの 印刷が速く完了するようにします。

    4. [ 最後のページをスプールした後に印刷を開始する] をクリックし、[ OK] をクリックします。

  3. プリンターに直接印刷するときに問題が発生するプリンターを設定します。

    1. [スタート] ボタンをクリックし、[設定] をポイントし、[プリンター] をクリックします。

    2. 問題が発生しているプリンターを右クリックし、[ プロパティ] をクリックします。

    3. [ 詳細 ] タブをクリックし、[ スプールの設定] をクリックし、[ プリンターに直接印刷を行う] をクリックして、[ OK]をクリックします。

  4. McAfee アンチウイルスプログラムをバージョン4.5 以降にアップグレードします。

詳細情報

デバッグプログラムを使ってスプーラーサービスをデバッグしている場合、次のデータがデバッグログに記録されることがあります。

LSPL: ERROR_INSUFFICIENT_BUFFER cbBuf でのエラー出力と、pcbNeeded には78が必要です。

参照情報

関連する印刷の問題の詳細については、以下の記事の番号をクリックして、Microsoft サポート技術情報の記事を参照してください。

180892 エラーメッセージ: LPT1 への書き込みエラー: アクセスが拒否されました

142370 イベント2004の HP Laserjet プリンターへの印刷結果

179156 Windows NT 4.0 SP3 以降の更新された TCP/IP 印刷オプション

188878 ローカルポートへの印刷がアクセス拒否エラーで失敗することがあるこの記事で説明されているサードパーティ製品は、Microsoft と関連のない他社の製品です。このような製品のパフォーマンスや信頼性については、Microsoft は一切の責任を負わないものとします。

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