Jak navrhnout a sestavit seznam adres hromadné korespondence v aplikaci Word

Překlady článku Překlady článku
ID článku: 294688 - Produkty, které se vztahují k tomuto článku.
Pro aplikaci Microsoft Word 2000 verzi tohoto článku, Viz 212322.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek popisuje formáty přijatelné pro Hromadná korespondence seznam adres a zahrnuje návrhy a otázky, které jsou užitečné promyslete, jak vytvořit seznam adres.

Navrhování zdroj dat.

V aplikaci Microsoft Word, můžete vytvořit nový seznam adres v rámci Průvodce hromadnou korespondencí. Pokud zvolíte "Krok 3: Vybrat příjemce" v Průvodci na Vytvořit nový seznam možnost je k dispozici. Tato možnost vytvoří svou adresu seznam.

Jiný způsob, jak vytvořit seznam adres je z tabulky aplikace Word. Je Můžete také použít jakékoli databáze formátu, jako je například textový soubor, ve kterém jsou pole oddělených čárkami nebo tabulátory a záznamy jsou odděleny odstavce značky.

V seznamu adres každá kategorie informací, například Příjmení, se nazývá pole. Sada polí, které tvoří informace o jedné osobě se nazývá záznam.

Co je třeba vzít v úvahu při návrhu zdroje dat.

Před vytvořením seznamu adres, rozhodnout, jaké informace jste Chcete zahrnout, a jak chcete tyto informace použít a pak navrhnout databáze. Ušetříte si čas a práci později.

Některé záznamy mají více informací než jiné?

Některé datové záznamy může obsahovat více informací než ostatní záznamy. Některé položky může mít například název společnosti, oddělení Nadpis a až tři řádky adresy. Ostatní položky pravděpodobně pouze jméno, jednořádkový ulice a třetí řádek s Město, stát, a poštovní směrovací číslo.

V seznamu adres každého datového záznamu musí mít stejný počet datových polí. Návrh seznamu adres tak, aby byl dostatek dat pole, která odpovídají záznam s největší pole. Není třeba Vyplňte všechna pole v záznamu dat; Některá pole lze ponechat prázdné. Aplikace Word automaticky potlačí prázdné záznamy.

Chcete seřadit data?

Pokud chcete řadit data, musíte uspořádat tak, můžete řadit data na základě některých kritérií. Například město, stát, a poštovní směrovací číslo se obvykle tisknou na stejném řádku adresní štítek, takže můžete také chtít zahrnout všechny tyto informace ve stejném poli. Pokud zahrnete všechny tyto informace ve stejném poli nelze seřadit záznamy na základě stav nebo PSČ. V takovém případě je vhodné oddělit každý kus informace do samostatných polí.

Totéž platí, pokud chcete seřadíte data podle příjmení adresátům. V tomto případě musí rozdělte na samostatné příjmení a křestní jména pole.

Použijete informace v určitém poli různými způsoby?

Ve formulářovém dopisu první řádek vnitřní adresy obvykle obsahuje Zdvořilostní oslovení a úplné jméno adresáta. Oslovení může obsahovat pouze Zdvořilostní oslovení a příjmení a křestní jméno. Pokud jste Umístěte titul, křestní jméno a příjmení do samostatných polí, můžete použít stejné pole Tisknout příjmení, adresu a oslovení. Alternativně můžete použít jedno pole pro úplný název a jméno uvnitř adresu a druhé pole pro titul a příjmení v oslovení.

Bude používat seznam adres pro několik dokumentů hromadné korespondence?

Jedinou adresu seznamu můžete sloučit libovolný typ a počet hlavní dokumenty. Při vytváření seznamu adres pro tisk formulářových dopisů, plánování Adresát informace tak, aby stejný zdroj dat můžete použít k tisku adresy na adresní štítky nebo obálky.

Kolik polí (položek informací) máte k dispozici pro každý záznam (kolekce položek informací)?

Máte-li několik kousků pro jednotlivé záznamy, je možné pomocí Průvodce hromadnou korespondencí (na Nástroje nabídka) v aplikaci Word. To vám umožní přístup k Příjemci hromadné korespondence Dialogové okno nastavení seznamu adres.

Není k dispozici omezení 255 polí v Příjemci hromadné korespondence Dialogové okno. Pokud váš Počet polí, která překračuje tuto hodnotu, nikoli Používejte Pomocníka hromadné korespondence. Použijte jednu z následujících:
  • Jako zdroj dat v aplikaci Microsoft Excel. Maximální počet datových polí v aplikaci Excel list je 256.
  • Použití databáze aplikace Microsoft Access jako data zdroj.
  • Použití souboru text oddělený tabulátory nebo čárkami oddělený textový soubor jako zdroj dat.
To snižuje výkon hromadné korespondence jako počet polí v zvyšuje se řádek záhlaví. Konfigurace počítače a k dispozici paměti může také omezit počet polí, které lze vložit do data dokument.

Záhlaví záznam (řádek) nesmí obsahovat žádné mezery. Každý pole hlavičky je omezena na 40 znaků a musí začínat písmenem. Každý Další znak musí být písmeno, číslo nebo znak podtržení. Všechna záhlaví musí být vyplněna. Všimněte si, že omezení popsaná zde se liší v některých jazykových verzích aplikace Word.

Uspořádání dat v tabulkách nebo odstavců

Při uspořádávání dat v tabulce tabulka by měla obsahovat sloupec pro každý název pole, které chcete použít. První řádek tabulky je řádek záhlaví; Každý následující řádek obsahuje informace o jedné datové záznam.

Ačkoli může být v každé buňce obtékání textu, bude vytištěn správně. Následuje seznam položek, které je třeba zvážit při použití existující seznam adres jako zdroj dat:
  • Pokud použijete samostatný zdroj záhlaví, ujistěte se, že záhlaví je první záznam (řádek buněk) v seznamu adres. Ujistěte se, že že nejsou žádné mezery, text nebo prázdné řádky před záznam záhlaví. Na záznam záhlaví nesmí obsahovat žádné mezery. Každé pole záhlaví je omezena na 40 znaků a musí začínat písmenem. Každý další znak musí být písmeno, číslo nebo znak podtržení. Musí být vyplněna všechna pole záhlaví v.
  • Ujistěte se, že počet datových polí ve všech dat záznam se rovná počtu názvy polí v záznamu záhlaví. Pokud je záznam není nutné informace pro určité pole, nechat buňku pro dané pole prázdné.
  • Uspořádání informací v záznamech dat ve stejném pořadí zleva doprava, jako odpovídající názvy polí v záznamu záhlaví. Pořadí sloupců v seznamu adres není důležité, protože je bude určovat umístění dat v hlavním hromadné korespondence dokument.

Vytváření seznamu adres, který obsahuje mnoho polí

Na Příjemce hromadné korespondence Dialogové okno vytvoří seznam adres (MDB) pro datový soubor. V Maximální počet polí pro aplikaci Microsoft Word Příjemce hromadné korespondence Dialogové okno je 255. k vytvoření nové databáze z Příjemce hromadné korespondence Dialogové okno pole, postupujte takto:
  1. Aplikace Microsoft Word 2002

    V Nástroje nabídky, klepněte na tlačítko Dopisy a korespondencea potom klepněte na tlačítko Průvodce hromadnou korespondencí.

    Aplikace Microsoft Office Word 2003

    V Nástroje nabídky, klepněte na tlačítko Dopisy a korespondencea potom klepněte na tlačítko Hromadná korespondence.

    Aplikace Microsoft Office Word 2007 a Word 2010

    V Hromadná korespondence karta, klepněte na tlačítko Spustit hromadnou korespondencia potom klepněte na tlačítko Průvodce hromadnou korespondencí krok za krokem.

    Postupujte podle pokynů v Průvodci hromadnou korespondencí "krok 3: výběr Příjemci." To je, kde můžete nastavit seznam adres.
  2. Klepněte Vytvořit nový seznam.
  3. Klepněte Vytvořit. Na Nový seznam adres Zobrazí se dialogové okno. V tomto dialogovém okně zadejte adresu informace pro každý záznam. Pokud není k dispozici žádné informace pro určité pole, ponechejte pole prázdné. Ve výchozím nastavení, aplikace Word prázdná pole přeskočí, proto není pro hromadnou korespondenci vliv, pokud jsou prázdné položky v datovém formuláři. Sada informací v každém Formulář tvoří jeden datový záznam.
  4. Po zadání informace o záznamu klepněte na tlačítko Nová položka Chcete-li přesunout na další záznam. Chcete-li odstranit záznam, klepněte na tlačítko Odstranit položku. Chcete-li vyhledat konkrétní záznam, klepněte na tlačítko Vyhledejte položku. Chcete-li filtrovat nebo seřadit záznamy, klepněte na tlačítko Filtrování a řazení.

    Poznámka: Pokud chcete upravit seznam adres, klepněte na tlačítko Vlastní nastavení. V Vlastní seznam adres Dialogové okno, můžete přidat, odstranit, přejmenovat a změnit pořadí slučování pole.
  5. V Nový seznam adres Dialogové okno, klepněte na tlačítko Zavřít.
  6. V Uložit seznam adres Dialogové okno pole v Název souboru Zadejte název, který chcete přidělit zdroj dat a Klepněte na tlačítko Uložit.
  7. V Příjemci hromadné korespondence Dialogové okno, jakékoli změny, že chcete vytvořit a potom klepněte na tlačítko OK.
Nyní jste vytvořili novou adresu a jsou připraveny k přesunutí Další krok průvodce hromadnou korespondencí. Tento krok je k zápisu do písmeno.

Další informace o tom, jak vytvořit formulářový dopis, článek znalostní báze Microsoft Knowledge Base:
294683Jak používat hromadnou korespondenci k vytváření formulářových dopisů v aplikaci Word 2002 a novějších verzích aplikace Word
Pokud potřebujete více než 255 polí v aplikace seznam adres aplikace Word nelze uspořádat data z Příjemce hromadné korespondence Dialogové okno. Místo toho můžete nastavit vaše informace jako samostatné odstavce v textovém dokumentu. Záznam záhlaví a jednotlivé záznamy dat musí být ukončen znak konce odstavce, což je oddělovač záznamů dat. Každý název pole v záznam záhlaví a každé pole záznamu dat musí být odděleny tabulátorem znak nebo čárka, což je oddělovač data. Pokud tato data pole je prázdné, je nutné zahrnout pole oddělovač k určení prázdné pole.

Pokud používáte seznam adres z databáze nebo tabulkového procesoru, tato data můžete exportovat do formátu textu ASCII, oddělených čárkami nebo tabulátory. Nebo je možné připojit databázi tak, že pomocí rozhraní ODBC, DDE nebo převaděče. Je-li exportovat data do formátu ASCII a Aplikace Word nerozpozná automaticky pole a oddělovače záznamů, aplikace Word vás vyzve k výběru oddělovače při prvním použití seznamu adres. Při můžete nastavit seznam adres v tomto formátu v aplikaci Word, měli byste použít odstavec Označit jako oddělovač záznamů dat a znak tabulátoru nebo čárkami jako data oddělovač polí.

Kromě obecných pravidel pro uspořádání seznam adres následující pravidla platí i pro seznamy adres, které jsou nastaveny jako běžný text:
  • Stisknutím klávesy ENTER ukončíte každého datového záznamu s znak konce odstavce. Ujistěte se, že neexistují žádné nadbytečné znaky konce odstavce mezi nebo po data záznamy. Aplikace Word interpretuje všechny prázdné odstavce (prázdné řádky) jako prázdné záznamy.
  • Použít stejný oddělovač polí v záznamu záhlaví a datový záznam. Například nelze použít znaky tabulátoru v záhlaví záznam a čárky v datové záznamy. Protože mohou obsahovat text v datových polích čárky, je výhodnější používat znaky tabulátoru.
  • Je-li datový záznam neobsahuje informace konkrétním datovým polem, vložit dva znaky tabulátoru nebo dvě čárky k označení prázdné pole. Nevkládejte druhý oddělovač polí, pokud je pole dat poslední jednoho datového záznamu.
  • Pole data uzavřete do uvozovek, pokud datové pole obsahuje některý z následujících znaků:
    • Znak tabulátoru nebo čárkami, používáte-li tato stejná znak oddělující pole
    • Konec řádku nebo znak konce odstavce
    • Znak, který jste určili jako oddělovač seznamu znak v části mezinárodní v Ovládacích panelech systému Microsoft Windows
  • Je-li informace v datových polích obsahuje uvozovky (" "), dvakrát zadejte znaky (" "" "). Pokud je informace z datového pole sloučení bude vytištěno pouze jeden pár uvozovek.

Rozhodování o tom, kdy použít samostatný zdroj záhlaví

Ve většině případů je vhodné uvést název pole pro každou datové pole v prvním řádku nebo záznam v seznamu adres. Však může vhodné uvést názvy polí v samostatný zdroj záhlaví pro následující důvody:
  • Chcete-li sloučit můžete použít stejné názvy řádků a pole záhlaví data z různých zdrojů, aniž by bylo nutné opakovat nebo změnit řádek záhlaví v Každý seznam adres nebo změnit názvy slučovací pole v hlavním dokument.
  • Někdy není seznam adres z jiného programu zahrnout záhlaví záznamu nebo neodpovídají názvům polí v záznamu záhlaví názvy slučovacích polí do hlavního dokumentu. Pokud nelze upravit nebo přidat hlavičku zaznamenat do seznamu adres (například, protože seznam adres je určen jen pro čtení) můžete použít samostatný zdroj záhlaví, která obsahuje pole názvů, které Určete.

Přidání tlačítka "Otevřít zdroj záhlaví hromadné korespondence"

Pokud použijete samostatný zdroj záhlaví, je nutné zadat obě zdroj záhlaví a seznam adres před sloučením hlavního dokumentu seznam adres.

Chcete-li použít zdroj záhlaví hromadné korespondence aplikace Word, můžete musíte přidat Otevřít zdroj záhlaví hromadné korespondence tlačítko na vašem Hromadná korespondence na panelu nástrojů. Chcete-li to provést, postupujte podle kroků, podle používané verze aplikace Word, který používáte.
Aplikace Word 2002 nebo Word 2003
  1. V Zobrazení nabídky, přejděte na příkaz Panely nástrojůa potom klepněte na tlačítko Hromadná korespondence. Na Hromadná korespondence Zobrazí se panel nástrojů.
  2. V Nástroje nabídky, klepněte na tlačítko Vlastní nastavení.
  3. V Příkazy karta, vyberte Všechny příkazy v Kategorie seznam.
  4. V Příkazy seznam, vyberte a přetáhněte MailMergeOpenHeaderSource Chcete-li vaše Hromadná korespondence na panelu nástrojů.
  5. Klepněte Zavřít Chcete-li zavřít Vlastní nastavení Dialogové okno.
Word 2007
Chcete-li použít zdroj záhlaví hromadné korespondence aplikace Word v aplikaci Word 2007, je nutné přidat Otevřít zdroj záhlaví hromadné korespondence tlačítko na panel nástrojů Rychlý přístup.
  1. V aplikaci Word, klepněte Tlačítko Microsoft Office.
  2. Klepněte Možnosti aplikace Word.
  3. Klepněte Vlastní nastavení.
  4. V Zvolte příkazy z Dialogové okno, klepněte na tlačítko Všechny příkazy.
  5. Klepněte Otevřít zdroj záhlaví hromadné korespondencea potom klepněte na tlačítko Přidat.
  6. Klepněte OK.
Aplikace Word 2010


Použití zdroje záhlaví ve slově hromadné korespondence v aplikaci Word 2007 přidat tlačítko Otevřít zdroj záhlaví hromadné korespondence na panelu nástrojů Rychlý přístup.

  1. Zvolte Možnosti na kartě soubor .
  2. Zvolte Vlastní nastavení pásu karet.
  3. Ve skupinovém rámečku Zvolit příkazy znahraďte Všechny příkazyOblíbené příkazy .
  4. Klepněte na tlačítko Otevřít zdroj záhlaví hromadné korespondencea potom klepněte na tlačítko Přidat.
    Poznámka: budete muset přidat novou kartu před přidáním příkaz na pásu karet.
  5. Klepněte na tlačítko OK.


Navrhování zdroj záhlaví

Zadáte-li zdroj záhlaví, mějte na paměti následující pravidla:
  • Se musí rovnat počtu názvy polí ve zdroji záhlaví počet datových polí v seznamu adres.
  • Názvy polí ve zdroji záhlaví musí být uvedena ve stejném pořadí jako odpovídající informace v seznamu adres.
  • Použít stejný oddělovač (znak tabulátoru nebo čárka) pro zdroj záhlaví a v seznamu adres.
  • Pokud hlavní dokument již obsahuje pole hromadné korespondence, použijte stejné slučovacích polí ve zdroji záhlaví. Pokud to neuděláte, musíte nahraďte slučovací pole v hlavním dokumentu tak, aby odpovídaly názvům polí v zdroj záhlaví. Poté, co zadáte zdroj záhlaví, můžete je upravit stejně jako Upravte seznam adres.

Pomocí záznamu záhlaví z jiného seznamu adres

Máte-li seznam adres, který obsahuje záznam záhlaví, můžete můžete použít jako zdroj záhlaví. Například, pokud došlo k poškození nahoru seznamu adres do několika dokumentů můžete zadat názvy polí v záznamu záhlaví první seznam adres. Při slučování z jiné seznamy adres, které nejsou k dispozici máte záznam záhlaví, zadejte první seznam adres jako zdroj záhlaví. Potom zase určete všechna zbývající seznamy adres.

Ignoruje aplikace Word datové záznamy z první seznam adres a používá pouze záhlaví záznam.

Typy dat, které lze použít v hromadné korespondenci

Můžete sloučit prakticky libovolný typ informace z hromadné korespondence zdroj dat, včetně následujících:
  • Jakýkoli text nebo čísla
  • Grafiky, pro kterou máte grafický filtr nainstalován


    Poznámka: Je-li grafiku, které jsou obsaženy v seznamu adres z programu Kromě aplikace Word musíte převést soubor ve formátu souboru převaděč.
  • Objekty vytvořené v aplikacích, které podporují propojování objektů a vložení (OLE), jako je Editor rovnic
  • Pole aplikace Word, které se zobrazí výsledek, jako je například pole {=} (vzorec)
Chcete-li přidat informace jiné než text nebo čísla na adresu seznam vytvořený v aplikaci Word, je nutné zobrazit seznam adres v dokumentu pomocí okna Otevřít příkaz v Soubor nabídka. Nebo otevřít seznam adres v původním programu, který byl dokument vytvořen. Vložte informace v odpovídajícím sloupci a řádek v tabulce seznam adres.

Typy dat, které nelze použít

Nelze sloučit text nebo grafiku, které jsou obsaženy v rámečku v seznamu adres. Však můžete umístit slučovací pole uvnitř rámečků. Při sloučit dokumenty, textu a grafiky ze seznamu adres umístí do rámečku.

Vlastnosti

ID článku: 294688 - Poslední aktualizace: 7. ledna 2013 - Revize: 4.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Word 2010
  • Microsoft Office Word 2007
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
Klíčová slova: 
kbhowtomaster kbmerge kbmt KB294688 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku: 294688

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com