Jak projektować i tworzyć listy adresów korespondencji seryjnej w programie Word

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 294688 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł został opublikowany wcześniej pod numerem PL294688
Wersja dla programu Microsoft Word 2000 niniejszego artykułu, Zobacz 212322.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

W tym artykule opisano formatów akceptowalne dla Lista adresów korespondencji seryjnej i zawiera sugestie i pytania, które są pomocne należy zadać sobie pytanie, jak utworzyć listę adresów.

Projektowanie źródła danych

W programie Microsoft Word, można utworzyć nowej listy adresów w obrębie Kreator korespondencji seryjnej. Po wybraniu "Krok 3: Wybierz adresatów" w Kreatorze na Wpisz nową listę opcja jest dostępna. Ta opcja tworzy swój adres Lista.

Innym sposobem tworzenia listy adresów jest z tabeli programu Word. Użytkownik Umożliwia także dowolnym formacie przypominającym bazy danych, takiego jak plik tekstowy, w którym są pola oddzielone przecinkami lub tabulatorami, a rekordy są oddzielane akapitu znaki.

Na liście adresów każdej kategorii informacji, takie jak nazwisko, jest nazywana polem. Zestaw pól, które tworzą informacji jedna osoba jest nazywany rekordem.

Jakie czynniki należy rozważyć podczas tworzenia źródła danych

Aby utworzyć listę adresową, wybrać, jakie dane użytkownik chcesz dołączyć i jak chcesz wykorzystać informacji tego typu, a następnie projektowania Baza danych. To oszczędzi Ci czasu i pracy później.

Czy niektóre rekordy mają więcej informacji niż inne?

Niektóre Twoje rekordy danych może mieć więcej informacji niż inne rekordy. Na przykład niektóre wpisy może być nazwą firmy, dział Tytuł i maksymalnie trzech wierszy adresu. Inne wpisy mogą mieć tylko Nazwa, adres zamieszkania jednego wiersza i wartości w trzecim wierszu o Miasto, stan, i Kod pocztowy.

Na liście adresowej każdego rekordu danych muszą mieć taką samą Liczba pól danych. Projektowanie listy adresowej, aby miała ona wystarczającej ilości danych pól dla rekordu o najbardziej pól. Nie trzeba wypełniać wszystkich pól w rekordzie danych; Niektóre pola można pozostawić puste. Program Word automatycznie pomija puste rekordy.

Czy zamierzasz posortować dane?

Jeśli planowane jest sortowanie danych, musisz rozmieścić go tak że można sortować dane na podstawie niektórych kryteriów. Na przykład, miejscowość, Województwo, i Kod pocztowy są zwykle drukowane na tej samej linii etykietę adresową, więc możesz chcieć uwzględnić wszystkie te informacje w tym samym polu. Jeśli dołączysz wszystkie z tych informacji w tym samym polu nie można posortować rekordy oparte na stan lub kod pocztowy. W takim przypadku należy oddzielić każdy kawałek informacji do oddzielnych pól.

Ta zasada obowiązuje, jeśli chcesz Sortowanie danych według nazwisk adresatów. W takim przypadku musi oddzielenia nazwiska i imiona w oddzielne pola.

Będzie korzystać z informacji w określonym polu w różny sposób?

W liście seryjnym pierwszy wiersz wewnątrz zwykle adres zawiera Tytuł grzecznościowy i pełną nazwę adresata. Może powitania zawierać tylko Tytuł grzecznościowy oraz nazwisko lub tylko imienia. Jeśli użytkownik Umieść tytuł, imię i nazwisko w oddzielne pola, można użyć tym samym polu, aby wydrukować ostatnia nazwa adresu i zwrot grzecznościowy. Alternatywnie, można użyć jednego pola dla tytułu pełną i imię i nazwisko wewnątrz adres i drugiego pola dla tytułu i nazwiska w zwrot grzecznościowy.

Na liście adres będzie używany dla kilku dokumentów korespondencji seryjnej?

Można łączyć listy pojedynczy adres z dowolnego typu i liczby głównych dokumentów. W procesie konfigurowania listy adresów, aby wydrukować listy seryjne, plan Adresat informacji tak, że to samo źródło danych można użyć do drukowania adresy na etykiet adresowych lub kopert.

Ile pól (rodzajów informacji) czy dla każdego rekordu (zbiór informacji)?

Jeśli masz kilka rodzajów informacji dla każdego rekordu, możesz za pomocą Kreatora korespondencji seryjnej (na Narzędzia menu) w programie Word. Dzięki temu można uzyskać dostęp do Kreator korespondencji seryjnej okno dialogowe, aby skonfigurować listy adresowej.

Istnieje ograniczenie 255 pól w Kreator korespondencji seryjnej okno dialogowe. Jeśli numer pola przekracza tę wartość, nie użyć pomocnika korespondencji seryjnej. Zamiast tego należy użyć jednej z następujących czynności:
  • Użyj programu Microsoft Excel jako źródła danych. Maksymalna liczba pól danych w programie Excel arkusz jest 256.
  • Używanie bazy danych programu Microsoft Access jako zwrócone dane źródło.
  • Użyj pliku tekstowego rozdzielanego tabulatorami lub tekst rozdzielany przecinkami plik jako źródła danych.
Obniża wydajność korespondencji seryjnej jako liczba pól w wiersz nagłówka wzrasta. Konfiguracja komputera i dostępne pamięci mogą również ograniczyć liczbę pól, które można wstawiać w danych dokument.

Nagłówek rekordu (wiersza) nie może zawierać żadnych spacji. Każdy pole nagłówka jest ograniczony do 40 znaków i musi zaczynać się od litery. Każdy kolejny znak musi być literą, liczbę lub znaku podkreślenia. Należy wypełnić wszystkie pola nagłówka. Należy zauważyć, że ograniczenia podane w tym miejscu są różne w niektórych wersjach językowych w programie Word.

Organizowanie danych w tabelach lub akapitów

Podczas organizowania danych w tabeli, tabela powinna zawierać kolumna dla każdej nazwy pola, które chcesz użyć. Pierwszy wiersz tabeli jest Twój wiersz nagłówka; Każdy kolejny wiersz zawiera informacje o jednym danych rekord.

Mimo, że tekst może być zawijany w każdej komórce, zostanie on wydrukowany poprawnie. Poniżej znajduje się lista elementów, które należy rozważyć użycie istniejącą listę adresów jako źródła danych:
  • O ile nie użyto oddzielnego źródła nagłówka, upewnij się, że rekord nagłówka jest pierwszy rekord (wiersz komórek) na liście adresów. Upewnij się to nie spacje, tekst lub puste wiersze przed rekord nagłówka. Na rekord nagłówka nie może zawierać żadnych spacji. Każde pole nagłówka jest ograniczony do 40 znaków i musi zaczynać się od litery. Każdy kolejny znak musi być literę, liczbę lub znaku podkreślenia. Wszystkie pola nagłówka muszą być wypełnione w programie.
  • Upewnij się, że ilość danych pola w każdym danych rekord jest równa liczbie nazwy pól w rekordzie nagłówka. Jeśli rekord nie nie ma informacji dla danego pola, pozostaw komórce dla danego pola puste.
  • Umieść informacje w rekordach w tym samym kolejność od lewej do prawej, jak odpowiadające im pola w rekordzie nagłówka. Kolejność kolumn na liście adresowej nie jest ważne, ponieważ użytkownik będzie kontrolować rozmieszczenie danych w głównym korespondencji seryjnej dokument.

Projektowanie listy adresowej, która zawiera wiele pól

Na Adresat korespondencji seryjnej okno dialogowe tworzy listę adresów (.mdb) dla pliku danych. W Program Microsoft Word, maksymalną liczbę pól dla Adresat korespondencji seryjnej okno dialogowe jest 255., aby utworzyć nową bazę danych z Adresat korespondencji seryjnej okno dialogowe należy wykonać następujące kroki:
  1. Program Microsoft Word 2002

    Na Narzędzia menu, kliknij przycisk Listy i dokumenty wysyłkowe, a następnie kliknij przycisk Kreator korespondencji seryjnej.

    Program Microsoft Office Word 2003

    Na Narzędzia menu, kliknij przycisk Listy i dokumenty wysyłkowe, a następnie kliknij przycisk Korespondencja seryjna.

    Program Microsoft Office Word 2007 i Word 2010

    Na Dokumenty wysyłkowe Kliknij pozycję Uruchomienie korespondencji seryjnej, a następnie kliknij przycisk Kreator korespondencji seryjnej krok po kroku.

    Postępuj zgodnie z instrukcjami Kreatora korespondencji seryjnej do "krok 3: Wybierz Adresaci." Jest to, skonfigurowanie listy adresowej.
  2. Kliknij przycisk Wpisz nową listę.
  3. Kliknij przycisk Tworzenie. Na Nowa lista adresów zostanie wyświetlone okno dialogowe. W tym oknie dialogowym wpisz adres informacje dla każdego rekordu. Jeśli nie ma żadnych informacji w danej dziedzinie, Pozostaw pole puste. Domyślnie program Word pomija puste pola, więc nie jest scalanie wpływ, jeśli są puste wpisy w formularzu danych. Zestaw informacji w każdym Formularz sprawia, że jeden rekord danych.
  4. Po wpisaniu informacje o rekordzie kliknij przycisk Nowy wpis Aby przejść do następnego rekordu. Aby usunąć rekord, kliknij przycisk Usuń wpis. Aby wyszukać określony rekord, kliknij przycisk Znajdź pozycję. Aby filtrować lub sortować rekordy, kliknij przycisk Filtrowanie i sortowanie.

    Uwaga Jeśli chcesz dostosować listy adresowej, kliknij przycisk Dostosowywanie. W Dostosowywanie listy adresów okno dialogowe, można dodawać, usuwać, Zmień nazwę i zmienić kolejność scalania pola.
  5. W Nowa lista adresów okno dialogowe, kliknij przycisk Zamknij.
  6. W Zapisywanie listy adresów okno dialogowe w Nazwa pliku Wpisz nazwę, którą chcesz nadać źródłu danych i następnie kliknij przycisk Zapisz.
  7. W Kreator korespondencji seryjnej okno dialogowe, wszelkie zmiany, że należy zrobić, a następnie kliknij OK.
Utworzyłeś nowego adresu i rozpocząć przenoszenie do następnego kroku Kreatora korespondencji seryjnej. Ten krok polega na napisaniu sieci litera.

Aby uzyskać więcej informacji na temat tworzenia listu seryjnego kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
294683Jak używać korespondencji seryjnej do tworzenia listów seryjnych w programie Word 2002 i jego nowszych wersjach programu Word
Jeśli potrzebujesz więcej niż 255 pól danych w sieci listy adresów, program Word nie może zorganizować dane z Adresat korespondencji seryjnej okno dialogowe. Zamiast tego należy zdefiniować informacje jako oddzielne ustępy w wyrazie dokumentu. Rekord nagłówka i każdego rekordu danych musi być zakończona znacznik akapitu, który jest ogranicznik rekordu danych. Poszczególne nazwy pól w rekord nagłówka i każdego pola w rekordzie danych musi być rozdzielane tabulatorami znak lub przecinek, który jest ogranicznik pola danych. Jeśli jakiekolwiek dane pola są puste, musi zawierać ogranicznik pola, aby zidentyfikować wszystkie puste pole.

Jeśli korzystasz z listy adresowej, z bazy danych lub arkusza kalkulacyjnego, dane te można wyeksportować do formatu tekstowego ASCII, oddzielone przecinkami lub tabulatorami. Lub można dołączyć bazy danych przez za pomocą ODBC, DDE lub konwertera. Podczas eksportowania danych na ASCII format i Program Word nie rozpoznaje automatycznie pola i separatory rekordów, program Word wyświetlany jest monit o wybranie ograniczniki, przy pierwszym użyciu lista adresów. Kiedy Możesz tworzyć listy adresów w tym formacie w programie Word, należy użyć akapitu Oznacz jako ogranicznik rekordu danych oraz znak tabulacji lub przecinkami, jak dane Ogranicznik pola.

Poza ogólnymi zasadami organizowania listy adresów, obowiązują następujące reguły również listy adresów, które są skonfigurowane jako zwykły tekst:
  • Naciśnij klawisz ENTER, aby zakończyć każdego rekordu danych z znacznik akapitu. Upewnij się, że nie istnieją żadne zbędne znaki końca akapitu między rekordami ani po danych rekordy. Jest ono traktowane wszystkie puste akapity (puste wiersze) jako puste rekordy.
  • Użyj tego samego ogranicznika pola w rekordzie nagłówka i rekord danych. Na przykład nie można używać znaków tabulacji w nagłówku rekord i przecinków w rekordach danych. Ponieważ tekst w polach danych może zawierać przecinki, to zaleca się stosowanie znaków tabulacji.
  • Jeśli rekord danych nie zawiera informacji dla pole danych, Wstaw dwa znaki tabulacji lub dwa przecinki puste pole. Nie wstawiaj drugiego ogranicznik pola, jeśli pole danych jest Ostatnia z nich z rekordu.
  • Należy ująć w cudzysłów pole danych, jeśli pole danych zawiera jeden z następujących znaków:
    • Znak tabulacji lub przecinek, jeśli używasz tego SA znak, aby rozdzielić pola
    • Podział wiersza lub znak końca akapitu
    • Znak, który został określony jako separator listy znak w sekcji międzynarodowymPanelu sterowania w systemie Microsoft Windows
  • Jeśli informacje w polu danych zawierają znaki cudzysłowu (" "), dwa razy wpisać znaki (" "" "). Kiedy informacje z pola data jest scalane, zostaną wydrukowane tylko jedną parę cudzysłowów.

Kiedy należy użyć oddzielnego źródła nagłówka

W większości przypadków jest to wygodne wpisać nazwę pola, dla każdego pole danych w pierwszym wierszu lub rekordu listy adresów. Jednakże może Aby wyświetlić listę nazw pól w osobne źródło nagłówka dla następujących powody:
  • Ten sam nagłówek wiersza pola nazwy i umożliwia scalanie danych z różnych źródeł, bez konieczności Powtórz lub zmieniać wiersza nagłówka w Każda lista adresów lub zmiana nazwy pola korespondencji seryjnej w głównym dokument.
  • Raz nie zawiera listy adresowej z innego programu umieszczony rekord nagłówka lub nazwy pól w rekordzie nagłówka nie pasują. nazwy pól korespondencji seryjnej w dokumencie głównym. Jeśli nie można modyfikować ani dodać nagłówek nagrać na liście adresowej (na przykład, ponieważ lista adresów jest tylko do odczytu) można użyć odrębne źródło nagłówka, w którym znajduje się pole nazwy, które Określ.

Dodawanie przycisku "Korespondencji seryjnej Otwórz źródło nagłówka"

Jeśli używasz oddzielnego źródła nagłówka, należy określić obie źródło nagłówka i listy adresowej, można scalić dokument główny z na liście adresów.

Aby użyć źródła nagłówka w korespondencji seryjnej programu Word, możesz należy dodać Otwórz źródło nagłówka korespondencji seryjnej przycisk, aby Twoje Korespondencja seryjna pasek narzędzi. Aby to zrobić, wykonaj kroki odpowiednie dla wersji programu Word, czy jest uruchomiona.
Program Word 2002 lub Word 2003
  1. Na Widok wskaż polecenie Paski narzędzi, a następnie kliknij przycisk Korespondencja seryjna. Na Korespondencja seryjna pojawi się pasek narzędzi.
  2. Na Narzędzia menu, kliknij przycisk Dostosowywanie.
  3. Na Polecenia Karta, wybierz Wszystkie polecenia w Kategoria Lista.
  4. W Polecenia listy, zaznacz i przeciągnij MailMergeOpenHeaderSource do sieci Korespondencja seryjna pasek narzędzi.
  5. Kliknij przycisk Zamknij Aby zamknąć Dostosowywanie okno dialogowe.
Program Word 2007
Aby użyć źródła nagłówka w korespondencji seryjnej programu Word w programie Word 2007, należy dodać Otwórz źródło nagłówka korespondencji seryjnej przycisk do paska narzędzi Szybki dostęp.
  1. W programie Word, kliknij przycisk Przycisk Microsoft Office.
  2. Kliknij przycisk Opcje programu Word.
  3. Kliknij przycisk Dostosowywanie.
  4. W Wybierz polecenia z okno dialogowe, kliknij przycisk Wszystkie polecenia.
  5. Kliknij przycisk Otwórz źródło nagłówka korespondencji seryjnej, a następnie kliknij przycisk Dodawanie.
  6. Kliknij przycisk OK.
Word 2010


Aby użyć źródła nagłówka w wyrazie korespondencji seryjnej w programie Word 2007, dodać przycisk Otwórz źródło nagłówka korespondencji seryjnej do paska narzędzi Szybki dostęp.

  1. Na karcie plik wybierz polecenie Opcje .
  2. Wybierz polecenie Dostosowywanie Wstążki.
  3. W obszarze Wybierz polecenia zPopularnych poleceń należy zastąpić Wszystkie polecenia.
  4. Kliknij przycisk Otwórz źródło nagłówka korespondencji seryjnej, a następnie kliknij przycisk Dodaj.
    Uwaga: może być konieczne dodać nową kartę przed dodaniem polecenie do wstążki.
  5. Kliknij przycisk OK.


Projektowanie źródło nagłówka

Po określeniu źródło nagłówka, należy pamiętać o następujące zasady:
  • Musi być równa Liczba nazw pól w źródle nagłówka Liczba pól danych na liście adresów.
  • Nazwy pól w źródle nagłówka muszą być wymienione w tym samym kolejność jako odpowiednie informacje na liście adresów.
  • Używać ten sam separator (znak tabulacji lub przecinek) zarówno źródło nagłówka, jak i na liście adresów.
  • Jeśli dokument główny zawiera już pola korespondencji seryjnej, należy użyć te same pola korespondencji seryjnej w źródle nagłówka. Jeśli nie należy tego robić, musisz najpierw zamieniając pola korespondencji seryjnej w dokumencie głównym, aby odpowiadać nazwom pól w źródło nagłówka. Po określeniu źródło nagłówka, można go edytować, tak jak Ty Edytuj listę adresów.

Za pomocą rekordu nagłówka z innej listy adresów

Jeśli masz listy adresów, który zawiera rekord nagłówka możesz może służyć jako źródło nagłówka. Na przykład, jeśli złamał listy adresowej na kilka mniejszych można określić nazwy pól w rekordzie nagłówkowym Pierwsza lista adresów. Kiedy scalić z innych list adresów, które nie mieć rekord nagłówka, określić pierwszej listy adresowej jako źródło nagłówka. Następnie określić każdy z pozostałych list adresowych z kolei.

Ignorowane są danych rekordy z pierwszej listy adresów i używa tylko nagłówek rekord.

Typy danych, które można używać z korespondencji seryjnej

Można scalać praktycznie dowolnego typu informacji z korespondencji seryjnej źródło danych, w tym następujące:
  • Dowolny tekst lub liczby
  • Grafika, dla którego zainstalowano filtru graficznego zainstalowane


    Uwaga Jeśli grafika zawarte są w listy adresów z programu innych niż Word należy przekonwertować plik za pomocą formatu pliku konwerter.
  • Obiekty utworzone w programach obsługujących łączenie i osadzanie obiektów (OLE), takie jak Edytor równań
  • Pola programu Word, które wyświetlają wynik w postaci, pola {=} (Formuła)
Aby dodać informacje o innych niż tekstu lub liczb na adres Lista, że utworzone w programie Word, należy wyświetlić listę adresów w dokumencie za pomocą okna Otwarte polecenie na Plik menu. Lub Otwórz listę adresową w oryginalny program uruchamiany utworzony dokument. Następnie wstaw informacje we właściwej kolumnie i wiersz tabeli listy adresowej.

Typy danych, którego nie można używać

Nie można scalać tekst lub grafikę, które są zawarte w ramce na liście adresów. Jednak można umieszczać pola korespondencji seryjnej wewnątrz ramek. Kiedy scalania dokumentów, tekst i grafikę z listy adresów są umieszczony w ramce.

Właściwości

Numer ID artykułu: 294688 - Ostatnia weryfikacja: 7 stycznia 2013 - Weryfikacja: 1.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Word 2010
  • Microsoft Office Word 2007
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
Słowa kluczowe: 
kbhowtomaster kbmerge kbmt KB294688 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to: 294688

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com