文書番号: 294916 - 最終更新日: 2006年8月7日 - リビジョン: 6.0

Office XP プログラムで文書のスクロールやウィンドウのサイズ変更を行うと、グラフィックスまたはテキストの表示が乱れる

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現象

この資料の冒頭に記載した Office XP プログラムで、文書のスクロールやプログラム ウィンドウのサイズ変更を行うと、次のいずれかの現象が発生することがあります。
  • グラフィックスまたはテキスト、あるいはその両方の位置がずれる。
  • グラフィックスまたはテキスト、あるいはその両方に白い帯が表示される。
  • グラフィックスまたはテキスト、あるいはその両方の一部が消える。
  • グラフィックスまたはテキスト、あるいはその両方がまったく表示されない。
  • グラフィックスまたはテキスト、あるいはその両方が損傷を受ける (壊れる)。

原因

Microsoft Office XP には、次世代の GDI である GDI+ をサポートするための、描画コードの変更が含まれています。Office XP は、これまでの Office とは異なる方法でビデオ ドライバを使用しています。このため、以前のバージョンの Office では問題のなかったドライバで問題が発生することがあります。

解決方法

この現象を解決するには、コンピュータの製造元に問い合わせ、最新版のビデオ ドライバを入手してください。既にビデオ カードを最新版にアップグレードしている場合は、ビデオ カードの製造元に問い合わせてください。

ビデオ カードの製造元の問い合わせ先を参照するには、以下のうち該当する「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
65416? (http://support.microsoft.com/kb/65416/ ) ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (A 〜 K)

60781? (http://support.microsoft.com/kb/60781/ ) ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (L 〜 P)

60782? (http://support.microsoft.com/kb/60782/ ) ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (Q 〜 Z)

他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、将来予告なしに変更されることがあります。マイクロソフトは、掲載している情報に対して、いかなる責任も負わないものとします。

回避策

この現象を回避するには、問題が発生しなくなるまでハードウェア アクセラレータの設定を低くします。これを行うには、次の手順を実行します。

Microsoft Windows XP、Microsoft Windows 2000、Microsoft Windows NT 4.0 の場合

  1. [スタート] ボタンをクリックし、[設定] をポイントし、[コントロールパネル] をクリックします (Windows XP の場合は、[スタート] ボタンをクリックし、[コントロールパネル] をクリックします)。次に、[画面] をダブルクリックします。
  2. [設定] タブの [詳細] (または [詳細設定]) をクリックします。
  3. [トラブルシューティング] タブで、ハードウェア アクセラレータのスライダを [なし] の方向にドラッグし、[OK] を 2 回クリックします。
  4. 問題が発生しなくなるまで、手順 1. 〜 3. を繰り返します。

Microsoft Windows 98 と Microsoft Windows Millennium Edition (Me) の場合

  1. [スタート] ボタンをクリックし、[設定] をポイントし、[コントロールパネル] をクリックします。次に、[画面] をダブルクリックします。
  2. [設定] タブの [詳細] をクリックします。
  3. [パフォーマンス] タブで、ハードウェア アクセラレータのスライダを [なし] の方向にドラッグし、[OK] を 2 回クリックします。
  4. 問題が発生しなくなるまで、手順 1. 〜 3. を繰り返します。

詳細

問題がドライバに関連するかどうかを判断するには、ビデオ アクセラレータを使用不可にして、問題を再現させてみてください。ビデオ アクセラレータの設定を変更してもアプリケーションのコードは一切変更されません。問題を含む可能性のあるドライバ ルーチンでのアクセラレータの使用が不可になります。これにより問題がなくなった場合は、問題はドライバに関連すると特定されます。

関連情報

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
127139? (http://support.microsoft.com/kb/127139/ ) Windows でのディスプレイに関する問題のトラブルシューティング
155681? (http://support.microsoft.com/kb/155681/ ) Windows NT 4.0 のディスプレイに関するトラブルシューティングについて
"GDI+: 次世代グラフィックス デバイス インターフェイス" の詳細については、次のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/whdc/archive/GDInext.mspx (http://www.microsoft.com/whdc/archive/GDInext.mspx)

この資料は以下の製品について記述したものです。
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Publisher 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
キーワード:?
kbcorrupt kbtshoot kbprb KB294916
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"