Průvodce přenesením selže přenesení dat v rozsáhlých tabulek

Překlady článku Překlady článku
ID článku: 295231 - Produkty, které se vztahují k tomuto článku.
Střední: Vyžaduje základní dovednosti v oblasti maker, kódování a práce v různých prostředích.

Tento článek se týká pouze databáze aplikace Microsoft Access (MDB).

Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastane problém. Informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při pokusu přenést databázi Microsoft Access (.mdb) k Microsoft SQL Server, Průvodce přenesením neexportuje data rozsáhlých tabulek.

Příčina

Předávací dotaz ODBC, který se použije k exportu dat je vypršení časového limitu.

Řešení

Následující část popisuje řešení problému a zahrnuje změnu registru. Pokud chcete provést změny v registru, je také řešení tohoto problému je popsán po rozlišení.

Chcete-li tento problém vyřešit, nastavte hodnotu QueryTimeout v registru na 0. To ponechá z časový limit dotazu. Hodnota QueryTimeout nastavena na 0, postupujte takto:
  1. Ukončete všechny spuštěné instance aplikace.
  2. Klepněte na tlačítko Start a potom klepněte na příkaz Spustit.
  3. V dialogovém okně Spustit zadejte regedit.exe a potom klepněte na tlačítko OK. Tím spustíte Editor registru.
  4. Klepněte na hodnotu QueryTimeout následujícím podklíči registru:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\4.0\Engines\ODBC
  5. V nabídce Úpravy klepněte na tlačítko změnit.
  6. V dialogovém okně Upravit hodnotu DWORD klepněte ve skupinovém rámečku BaseDesítková.
  7. V poli Údaj hodnoty zadejte hodnotu 0 a klepněte na tlačítko OK.
  8. Ukončete program Editor registru.
  9. Spusťte aplikaci Microsoft Access otevřete databázi a potom zkuste k přenesení jej.

Možné řešení

Problém vyřešíte následujícím způsobem:
  1. Přenesení pouze strukturu tabulky.
  2. Importovat data z tabulky aplikace Access a pak připojit struktury přenesené pomocí Data Transformation Services (DTS).
To bude umožňují přenesení strukturu databáze a proto vytvořit požadované vztahy a aktivační události/DRI bez nutnosti měnit nastavení registru.

Další informace o použití DTS klepněte na následující číslo článku databáze Microsoft Knowledge Base:
285829Použití Data Transformation Services (DTS) k exportu dat z databáze bude databázi SQL Server

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku.

Další informace

Když jej přenese databáze Jet k Microsoft SQL Server používá Průvodce přenesením předávací dotazy SQL ODBC provedeny prostřednictvím Jet databáze stroj. Hodnota QueryTimeout v registru určuje ODBC jak dlouho (v sekundách) před vypršením časového limitu může spustit dotazy. Ve výchozím nastavení je hodnota QueryTimeout nastavena 60 sekund. Proto jakékoli předávací dotaz ODBC, který zabírá více než 60 sekund vyprší a Průvodce přenesením přeskočí operace.

Kroky pro reprodukci chování v aplikaci Access 2003

Poznámka: Následující kroky simulovat chování přenesení Northwind ukázkové databáze nastavením QueryTimeout na 1 sekundu. To způsobí jakýkoli předávacích dotazů ODBC vypršení časového limitu po 1 sekunda.
  1. Ukončete všechny spuštěné instance aplikace.
  2. Klepněte na tlačítko Start a potom klepněte na příkaz Spustit.
  3. V dialogovém okně Spustit zadejte regedit.exe a potom klepněte na tlačítko OK. Tím spustíte Editor registru.
  4. Klepněte na hodnotu QueryTimeout následujícím podklíči registru:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\4.0\Engines\ODBC
  5. V nabídce Úpravy klepněte na tlačítko změnit.
  6. V dialogovém okně Upravit hodnotu DWORD klepněte ve skupinovém rámečku BaseDesítková.
  7. V poli Údaj hodnoty zadejte 1 a klepněte na tlačítko OK.
  8. Ukončete program Editor registru.
  9. Spusťte aplikaci Microsoft Access.
  10. Otevřete ukázkovou databázi Northwind.mdb.
  11. V nabídce Nástroje přejděte na položku Správa databáze a potom klepněte na položku Průvodce přenesením.
  12. Klepněte na tlačítko vytvořit novou databázi a potom klepněte na tlačítko Další.
  13. SQL Server, které chcete přenést do vyberte a zadejte ověřovací informace pro přihlášení k serveru SQL.
  14. Zadejte název nové databáze SQL Server a potom klepněte na tlačítko Další.
  15. Vyberte všechny tabulky k přenesení a potom klepněte na tlačítko Další.
  16. Zachovat všechny výchozí hodnoty na další stránce a potom klepněte na tlačítko Další.
  17. Vyberte možnost vytvořit nový bude aplikace klient server.
  18. Zadejte cestu a název v poli Název ADP a potom klepněte na tlačítko Dokončit.
  19. Přenesením sestavy mohou zobrazit všechny tabulky byly úspěšně přenesena nebo se může zobrazit následující zpráva pod některé tabulky:
    Tabulka byla přeskočena.
  20. Zavřete zprávu přenesením. Otevře automaticky nové (ADP) soubor projektu připojen nová databáze SQL Server.
  21. Otevřete tabulku Rozpis.
Poznámka: strukturu tabulky byla přenesena, ale tabulka neobsahuje žádná data.

Vlastnosti

ID článku: 295231 - Poslední aktualizace: 29. března 2007 - Revize: 5.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
Klíčová slova: 
kbmt kbexport kbbug kbclientserver kbnofix KB295231 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:295231

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com