ACC2002: Znamená Průvodce přenesením není přenesení vnořený dotazy, pokud jsou základní dotazy přeneseno jako funkce

Překlady článku Překlady článku
ID článku: 295235 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Střední: Vyžaduje základní dovednosti v oblasti maker, kódování a práce v různých prostředích.

Tento článek se týká databází aplikace Microsoft Access (MDB) a projektů aplikace Microsoft Access (ADP).

Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Průvodce aplikace Access přenesením nepřenáší vnořený dotaz Pokud jsou splněny obě následující podmínky:
  • Dotaz obsahuje dotaz nižší úrovně, který obsahuje klauzuli ORDER v jeho příkazu SQL.

    - a -

  • Dotaz nižší úrovně se zabývá více než jedno spojení.

Příčina

Průvodce přenesením převede dotazy s klauzulí ORDER funkcí. Proto dotaz nižší úrovně převedeny na funkci. Když je funkce účastní více než jedno spojení v dotazu, Průvodce přenesením nepřenáší dotazu.

Řešení

Pro řešení tohoto problému, použijte jednu z následujících metod.

Metoda 1

Zkopírujte a vložte příkaz SQL z vnořený dotaz databáze Microsoft Access nového dotazu v projektu Microsoft Access přenesena. Použijte uvedený postup:
  1. Otevřete databázi obsahující vnořený dotaz.
  2. Otevřete vnořený dotaz v návrhovém zobrazení.
  3. V nabídce Zobrazit klepněte na příkaz Zobrazení SQL.
  4. Vyberte celý příkaz SQL, takže můžete kopírovat.
  5. V nabídce Úpravy klepněte na tlačítko Kopírovat.
  6. Zavřete dotaz. Nelze uložit změny.
  7. Otevřete projekt aplikace Microsoft Access přenesena.
  8. V okně databáze v oblasti objekty klepněte na položku dotazy a poklepejte na položku vytvořit zobrazení v Návrháři.
  9. V dialogovém okně Zobrazit tabulku klepněte na tlačítko Zavřít.
  10. Na panelu nástrojů Zobrazení Návrh klepněte na příkaz SQL otevřete okno SQL v dolní části obrazovky.
  11. V okně SQL vyberte tak, aby přes text můžete vložit text "SELECT FROM".
  12. V nabídce Úpravy klepněte na tlačítko Vložit. V případě potřeby upravte dotaz tak, aby odpovídá správné syntaxe T-SQL.
  13. Uložení zobrazení a dát stejný název jako název dotazu v souboru databáze (MDB) aplikace Access.
  14. Spusťte dotaz.
  15. Vrátit do návrhového zobrazení.
  16. Ve sloupci Typ řazení vyberte pořadí řazení pro pole, které chcete řadit.
  17. Spusťte dotaz znovu.
  18. Zavřete a uložte dotaz.

Metoda 2

Před přenesením databáze, otevřít nižší úrovně dotaz v návrhovém zobrazení pořadí řazení odebrat a potom znovu vložte pořadí řazení v dotazu přenesena.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku.

Další informace

Kroky pro reprodukci tohoto chování

Upozornění: Pokud postupujte podle kroků v tomto příkladu, změníte ukázkovou databázi Northwind.mdb. Můžete chtít zálohovat soubor Northwind.mdb a postupujte podle těchto kroků na kopii databáze.

  1. Otevřete ukázkovou databázi Northwind.mdb.
  2. Vytvořit nový dotaz v návrhovém zobrazení.
  3. V dialogovém okně Zobrazit tabulku klepněte na tlačítko Zavřít.
  4. V nabídce Zobrazit klepněte na příkaz Zobrazení SQL.
  5. Zadejte nebo vložte následující text do okna SQL:
       SELECT Employees.LastName, 
            Orders.OrderDate, 
            Orders.ShipCountry, 
            [Order Details Extended].ExtendedPrice, 
            Products.ProductName, 
            Categories.CategoryName
       FROM Employees  
         INNER JOIN (Categories 
            INNER JOIN ((Orders 
               INNER JOIN [Order Details Extended] 
         ON Orders.OrderID = [Order Details Extended].OrderID) 
            INNER JOIN Products 
              ON [Order Details Extended].ProductID = Products.ProductID) 
                ON Categories.CategoryID = Products.CategoryID) 
                  ON Employees.EmployeeID = Orders.EmployeeID;
    					
  6. Jako qryNested dotaz uložte a zavřete jej.
  7. Přenesení databáze.
  8. Po dokončení Průvodce přenesením Všimněte si, že dotaz qryNested nebyl přenesena nový projekt Microsoft Access.

Vlastnosti

ID článku: 295235 - Poslední aktualizace: 1. února 2014 - Revize: 3.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Access 2002 Standard Edition
Klíčová slova: 
kbnosurvey kbarchive kbmt kbbug KB295235 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:295235

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com