ACC2002: Yükseltme Sihirbazı başlamıyor temel sorgu yükseltildi işlevler mı, iç içe yükseltme sorgular

Makale çevirileri Makale çevirileri
Makale numarası: 295235 - Bu makalenin geçerli olduğu ürünleri görün.
Bu makale arşivlenmiştir. "Olduğu gibi" sunulmaktadır ve bundan sonra güncelleştirilmeyecektir.
Orta: temel makro, kodlama ve birlikte çalışabilirlik becerileri gerektirir.

Bu makale, Microsoft Access veritabanı (.mdb) ve Microsoft Access projesi (.adp) için geçerlidir.

Hepsini aç | Hepsini kapa

Bu Sayfada

Belirtiler

Aşağıdaki koşulların her ikisi de doğruysa, Microsoft Access Yükseltme Sihirbazı'nı bir iç içe sorgu yükseltmez:
  • Sorgu, SQL deyiminin ORDER BY yan tümcesi içeren bir alt sorgu içerir.

    -ve-

  • Alt sorgu, birden fazla birleştirme katıldı.

Neden

Yükseltme Sihirbazı, ORDER BY yan sorgularla işlevlerine dönüştürür. Bu nedenle, alt düzey sorgu için bir işlev dönüştürülür. Sorguda birden fazla birleştirme işlevi söz konusu olduğunda, Yükseltme Sihirbazı sorgu yükseltmez.

Çözüm

Bu soruna geçici bir çözüm için aşağıdaki yöntemlerden birini kullanın.

Yöntem 1

Kopyalayıp iç içe geçmiş sorgunun SQL deyimini yükseltilen Microsoft Access projesi içinde yeni bir sorgu için Microsoft Access veritabanında. Bunu yapmak için şu adımları izleyin:
  1. Iç içe sorgu içeren bir veritabanı açın.
  2. Iç içe sorgu Tasarım görünümünde açın.
  3. Görünüm menüsünden SQL Göster ' i tıklatın.
  4. SQL deyiminin tamamını seçin, böylece bu kopyalayabilirsiniz.
  5. Düzen menüsünden Kopyala ' yı tıklatın.
  6. Sorguyu kapatın. Değişiklikleri kaydedin.
  7. Yükseltilen Microsoft Access projesini açın.
  8. Veritabanı penceresinde, nesneleri altında sorgular ' ı tıklatın ve Tasarımcısı görünümünde oluştur</a5>'ni çift tıklatın.
  9. Tablo Göster iletişim kutusunda Kapat ' ı tıklatın.
  10. Görünüm Tasarla araç çubuğunda, ekranın altındaki SQL penceresini açmak için SQL ' i tıklatın.
  11. SQL penceresinde "SELECT FROM" metni seçin, böylece metnin üzerine yapıştırabilirsiniz.
  12. Düzen menüsünden Yapıştır ' ı tıklatın. Bunu uygun T-SQL sözdizimine uyan gerekirse, sorguyu değiştirin.
  13. Görünümü kaydetmek ve bu Access veritabanı (.mdb) dosyasında <a1>sorgu</a1> adıyla aynı adı verin.
  14. Sorguyu çalıştırın.
  15. Tasarım görünümüne dönün.
  16. Sıralama türü</a0> sütununda, sıralama ölçütü olarak kullanmak istediğiniz alan için sıralama düzenini seçin.
  17. Sorguyu yeniden çalıştırın.
  18. Kapatın ve sorguyu kaydedin.

Yöntem 2

Yükseltme önce veritabanınıza, sorgu Tasarım görünümünde, <a1>Açık</a1> alt düzey sıralama düzenini kaldırmak ve sonra yükseltilen sorgunun sıralama düzenini yeniden takın.

Durum

Microsoft, bu makalenin başında listelenen Microsoft ürünlerinde bir sorun olduğunu onaylamıştır.

Daha fazla bilgi

Davranışı Yeniden Oluşturma Adımları

DIKKAT: Bu örnekteki adımları, Northwind.mdb adlı örnek veritabanını değiştirme. Northwind.mdb dosyasını yedekleyin ve bu adımları veritabanının bir kopyasında isteyebilirsiniz.

  1. Northwind.mdb örnek veritabanını açın.
  2. Yeni bir sorgu Tasarım görünümünde oluşturun.
  3. Tablo Göster iletişim kutusunda Kapat ' ı tıklatın.
  4. Görünüm menüsünden SQL Göster ' i tıklatın.
  5. Aşağıdaki metni, SQL penceresine yapıştırın veya yazın:
       SELECT Employees.LastName, 
            Orders.OrderDate, 
            Orders.ShipCountry, 
            [Order Details Extended].ExtendedPrice, 
            Products.ProductName, 
            Categories.CategoryName
       FROM Employees  
         INNER JOIN (Categories 
            INNER JOIN ((Orders 
               INNER JOIN [Order Details Extended] 
         ON Orders.OrderID = [Order Details Extended].OrderID) 
            INNER JOIN Products 
              ON [Order Details Extended].ProductID = Products.ProductID) 
                ON Categories.CategoryID = Products.CategoryID) 
                  ON Employees.EmployeeID = Orders.EmployeeID;
    					
  6. Sorgu qryNested kaydedin ve sonra kapatın.
  7. Veritabanı Yükseltme.
  8. Yükseltme Sihirbazı'nı tamamladıktan sonra qryNested sorgu yükseltilen yeni Microsoft Access projesinin olmadığını unutmayın.

Özellikler

Makale numarası: 295235 - Last Review: 29 Ocak 2014 Çarşamba - Gözden geçirme: 3.0
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Access 2002 Standard Edition
Anahtar Kelimeler: 
kbnosurvey kbarchive kbmt kbbug KB295235 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:295235

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com