Programs That Use the InstallShield Program May Not Start

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Article ID: 295278 - View products that this article applies to.
This article was previously published under Q295278
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SYMPTOMS

Programs that use the InstallShield program may not start, and you may receive one of the following error messages:
Setup failed to launch installation engine: Access is denied.
or
Error installing Ikernel.exe, access is denied.

CAUSE

This behavior can occur if there are insufficient Component Object Model (COM) permissions.

RESOLUTION

To resolve this behavior, set the necessary permissions that are needed to successfully complete the installation:
  1. At a command prompt, type: dcomcnfg.exe. The Distributed COM Configuration Properties dialog box is displayed.
  2. Click the Default Security tab.
  3. In the Default Access Permissions section, click Edit.
  4. Ensure that you have "Allow Access" beside your name.
  5. If you do not have "Allow Access" next to your name, either modify an existing profile or create a new profile that has the necessary permissions.
  6. Apply all the changes and attempt to run Setup.

MORE INFORMATION

If installation or initialization errors, or denial of access errors occur, you may not have sufficient COM permissions on the workstation or server to successfully complete the installation.

This behavior can also be caused by a logon script, domain policies, or file system permissions. If this behavior persists, contact InstallShield Technical Support at either of the following InstallShield Web sites:
http://www.installshield.com/
http://support.installshield.com/
InstallShield Technical Support: (847) 240-9111

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 295278 - Last Review: March 1, 2007 - Revision: 2.3
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kb3rdparty kberrmsg kbprb kbsetup KB295278

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