Article ID: 295297 - Last Review: December 3, 2007 - Revision: 4.5

PRB: Error Message: 0x80004005: General Error Unable to Open Registry Key

This article was previously published under Q295297
Expand all | Collapse all

SYMPTOMS

When you access a page that connects to an Access database, you may receive the following error message in the browser:
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x614 Thread 0x6c0 DBC 0x21dd07c Jet'.
(FileName), (LineNumber)

CAUSE

The account that is being used to access the page does not have access to the HKEY_LOCAL_MACHINE\SOFTWARE\ODBC registry key.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

  1. Start Registry Editor (Regedt32.exe).
  2. Select the following key in the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC
  3. On the Security menu, click Permissions.
  4. Type the required permissions for the account that is accessing the Web page.
  5. Quit Registry Editor.

STATUS

This behavior is by design.

APPLIES TO
  • Microsoft Internet Information Services 5.0
  • Microsoft Internet Information Services 6.0
Keywords: 
kbprb KB295297
 

Article Translations

 

Related Support Centers