PRB: エラー メッセージ: 0x80004005: レジストリ キーを開くことができない一般的なエラー

現象

Access データベースに接続するページにアクセスすると、ブラウザーで次のエラー メッセージが表示される場合があります。

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x614 Thread 0x6c0 DBC 0x21dd07c Jet'.
(FileName), (LineNumber)

原因

ページへのアクセスに使用されているアカウントは、HKEY_LOCAL_MACHINE\SOFTWARE\ODBC レジストリ キーにアクセスできません。

解決方法

重要

このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 保護を強化するため、レジストリを変更する前にレジストリをバックアップします。 こうしておけば、問題が発生した場合にレジストリを復元できます。 レジストリをバックアップおよび復元する方法の詳細については、次の記事番号をクリックして、「Microsoft サポート技術情報: Windows でレジストリをバックアップおよび復元する方法 」322756 の記事を参照してください

  1. レジストリ エディター (Regedt32.exe) を起動します。

  2. レジストリで次のキーを選択します。

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC

  3. [セキュリティ] メニューの [アクセス許可] をクリックします。

  4. Web ページにアクセスするアカウントに必要なアクセス許可を入力します。

  5. レジストリ エディターを終了します。

状態

この動作は仕様です。