PRB: 오류 메시지: 0x80004005: General Error Unable to Open Registry Key

기술 자료 번역 기술 자료 번역
기술 자료: 295297 - 이 문서가 적용되는 제품 보기.
이 문서는 이전에 다음 ID로 출판되었음: KR295297
모두 확대 | 모두 축소

현상

Access 데이터베이스에 연결하는 페이지에 액세스하면 브라우저에 다음과 같은 오류 메시지가 나타날 수 있습니다.
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x614 Thread 0x6c0 DBC 0x21dd07c Jet'.
(FileName), (LineNumber)

원인

페이지에 액세스하는 데 사용되는 계정이 HKEY_LOCAL_MACHINE\SOFTWARE\ODBC 레지스트리 키에 대한 액세스 권한을 가지고 있지 않습니다.

해결 방법

중요: 이 문서에서는 레지스트리 수정 방법을 설명합니다. 레지스트리를 수정하기 전에 해당 레지스트리를 백업하고 문제 발생 시 이를 복원하는 방법을 알고 있어야 합니다. 레지스트리 백업, 복원 및 편집 방법은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
256986 Microsoft Windows 레지스트리 설명

경고: 레지스트리 편집기를 잘못 사용하면 심각한 문제가 발생할 수 있으며 문제를 해결하기 위해 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft는 레지스트리 편집기를 잘못 사용함으로써 발생하는 문제에 대해 해결을 보증하지 않습니다. 레지스트리 편집기의 사용에 따른 모든 책임은 사용자에게 있습니다.

  1. 레지스트리 편집기(Regedt32.exe)를 시작합니다.
  2. 다음 레지스트리 키를 선택합니다.
    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC
  3. 보안 메뉴에서 사용 권한을 누릅니다.
  4. 웹 페이지에 액세스하는 계정에 필요한 사용 권한을 입력합니다.
  5. 레지스트리 편집기를 종료합니다.

현재 상태

이것은 의도적으로 설계된 동작입니다.



Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 295297 - 마지막 검토: 2007년 12월 4일 화요일 - 수정: 4.1
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Internet Information Services 5.0
  • Microsoft Internet Information Services 6.0
키워드:?
kbprb KB295297

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com