PRB:错误信息:0x80004005:General Error Unable to Open Registry Key(出现常规错误,无法打开注册表项)

文章翻译 文章翻译
文章编号: 295297 - 查看本文应用于的产品
展开全部 | 关闭全部

症状

当访问连接到 Access 数据库的页面时,可能会在浏览器中收到以下错误信息:
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x614 Thread 0x6c0 DBC 0x21dd07c Jet'.
(FileName), (LineNumber)

原因

用于访问页面的帐户无法访问 HKEY_LOCAL_MACHINE\SOFTWARE\ODBC 注册表项。

解决方案

重要说明:本文包含有关修改注册表的信息。修改注册表之前,一定要先进行备份,并且一定要知道在发生问题时如何还原注册表。有关如何备份、还原和编辑注册表的信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
256986 Microsoft Windows 注册表说明

警告:注册表编辑器使用不当可导致严重问题,可能需要重新安装操作系统。Microsoft 不能保证您可以解决因注册表编辑器使用不当而导致的问题。使用注册表编辑器需要您自担风险。

  1. 启动注册表编辑器 (Regedt32.exe)。
  2. 在注册表中选择下面的项:
    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC
  3. 安全菜单上,单击权限
  4. 为访问网页的帐户键入所需的权限。
  5. 退出注册表编辑器。

状态

这种现象是设计导致的。

属性

文章编号: 295297 - 最后修改: 2007年12月4日 - 修订: 4.1
这篇文章中的信息适用于:
  • Microsoft Internet Information Services 5.0
  • Microsoft Internet Information Services 6.0
关键字:?
kbprb KB295297
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com