FIX: Profiler Fails To Start New Trace When User Environment Variable Has Been Changed

Article translations Article translations
Article ID: 295461 - View products that this article applies to.
This article was previously published under Q295461
BUG #: 235412 (SHILOH_BUGS)
Expand all | Collapse all

SYMPTOMS

If the TMP environment variable is changed to a nonexisting directory, SQL Server Profiler may fail to run a new trace, and will result in the following message:
Failed to start a new trace

CAUSE

SQL Server Profiler allocates temporary storage files into the directory specified in the TMP environment variable. However, SQL Server Profiler does not validate whether the directory exists.

RESOLUTION

To resolve this problem, obtain the latest service pack for SQL Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
290211 INF: How to Obtain the Latest SQL Server 2000 Service Pack

WORKAROUND

Make sure that the directory exists when changing the TMP environment variable.

STATUS

Microsoft has confirmed that this is a problem in SQL Server 2000. This problem was first corrected in SQL Server 2000 Service Pack 1.

MORE INFORMATION

In Microsoft Windows NT and Microsoft Windows 2000, environment variables are strings that contain information such as drive, path, or file name. Environment variables control the behavior of various programs. For example, the TMP environment variable specifies the location where programs place temporary files.

To add or change the values of environment variables, right-click My Computer and then click Properties. On the Advanced tab, click Environment Variables. Select a user in User Variables for a list of environment variables.

Properties

Article ID: 295461 - Last Review: November 5, 2003 - Revision: 3.2
APPLIES TO
  • Microsoft SQL Server 2000 Standard Edition
Keywords: 
kbbug kbfix kbsqlserv2000sp1fix KB295461

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com