Article ID: 295739 - Last Review: November 14, 2003 - Revision: 3.2 BUG: DTS Designer May Stop Responding When You Use Microsoft Jet 4.0 OLE DB Provider
This article was previously published under Q295739
BUG #: 209139 (SHILOH)
SYMPTOMS
When you import to or export data from a Microsoft Access database, the SQL Server Data Transformation Services (DTS) Designer or the Import/Export wizard may seem to stop responding (hang), and then exit prematurely. When you are working in the DTS Designer, you may encounter this problem when you retrieve properties by right-clicking the Transform Data Task arrow. The Import/Export wizard just disappears from the monitor.
CAUSE
The symptoms exposed by this problem are caused by an unhandled access violation that occurs when information is retrieved from the IDBSchemaRowset object of the Microsoft Jet 4.0 OLE DB Provider.
WORKAROUND
As a workaround, change the values set to (NULL) in the SELECT list to a another value such as EMPTY, depending on the requirements of your application.
STATUS
Microsoft has confirmed this to be a problem in SQL Server 2000.
MORE INFORMATION
This behavior may occur when the Microsoft Access database contains a UNION query similar to the following:
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