Le message d'erreur " Un problème est survenu durant la communication entre Microsoft Access et le serveur OLE " s'affiche lorsque vous insérez ou liez un document Word dans Access

Numéro d'article: 295824 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F295824
Important Cet article contient des informations vous indiquant comment définir des paramètres de sécurité moins élevés ou désactiver les fonctionnalités de sécurité sur un ordinateur. Vous pouvez effectuer ces modifications pour contourner un problème spécifique. Avant de procéder à ces modifications, nous vous recommandons d'évaluer les risques liés à la mise en oeuvre de cette solution de contournement dans votre environnement particulier. Si vous mettez en oeuvre cette solution de contournement, effectuez toutes les étapes supplémentaires adéquates pour mieux protéger votre système.
Utilisateur débutant : requiert la connaissance de l'interface utilisateur sur les ordinateurs mono-utilisateur.

Cet article s'applique à un fichier de base de données Microsoft Access (.mdb) ou à un fichier de base de données Microsoft Access (.accdb).
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous essayez de lier ou d'incorporer un document Microsoft Word dans Microsoft Access, il se peut que vous receviez un message d'erreur semblable au message d'erreur suivant :
Un problème est survenu durant la communication entre Microsoft Access et le serveur OLE. Essayez d'effectuer l'une des opérations suivantes :
  1. Assurez-vous que vous êtes connecté au serveur réseau sur lequel se trouve le serveur OLE.
  2. Fermez le serveur OLE et redémarrez-le en dehors de Microsoft Access.
  3. Réinstallez le serveur OLE pour vous assurer qu'il est enregistré.
Remarque à l'attention des utilisateurs de Microsoft Office Access 2007
Pour déterminer le numéro unique qui est associé au message qui s'affiche, appuyez sur Ctrl+Maj+I. Le numéro suivant apparaît dans l'angle inférieur droit de ce message :
1200553

Cause

Ce problème peut se produire si Norton AntiVirus 2000, Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003 ou Norton AntiVirus 2004 est installé sur votre ordinateur. Ce problème peut également se produire si vous avez exécuté LiveUpdate de Norton et vous avez installé la mise à jour du blocage de scripts pour Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003 ou Norton AntiVirus 2004.

Résolution

Important Ces étapes peuvent accroître les risques pour la sécurité. Cette procédure peut aussi rendre votre ordinateur ou votre réseau plus vulnérable aux attaques d'utilisateurs malveillants ou de logiciels malveillants comme les virus. Nous recommandons le processus décrit par cet article pour permettre à des programmes de fonctionner comme prévu, ou pour implémenter des capacités de programme spécifiques. Avant de procéder à ces modifications, nous vous recommandons d'évaluer les risques liés à la mise en oeuvre de ce processus dans votre environnement particulier. Si vous choisissez de mettre en oeuvre ce processus, effectuez toutes les étapes supplémentaires adéquates pour mieux protéger votre système. Nous vous recommandons de n'utiliser ce processus que si vous en avez vraiment besoin. Pour plus d'informations à propos des virus informatiques, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
129972 Virus informatiques : description, prévention et récupération
Pour résoudre ce problème, appliquez l'une des méthodes ci-dessous.

Méthode 1

Désactiver le blocage de scripts de Norton AntiVirus

Avertissement Cette solution de contournement peut rendre votre ordinateur ou votre réseau plus vulnérable aux attaques d'utilisateurs malveillants ou de logiciels malveillants comme les virus. Nous ne recommandons pas cette solution de contournement mais nous fournissons ces informations de façon à ce que vous puissiez appliquer cette solution de contournement si vous en décidez ainsi. Vous assumez l'ensemble des risques liés à l'utilisation de cette solution de contournement.

Remarque Un programme antivirus est conçu pour protéger votre ordinateur des virus. Ne téléchargez ni n'ouvrez pas de fichiers provenant de sources en lesquelles vous n'avez pas confiance, ne visitez pas de sites Web en lesquels vous n'avez pas confiance, ou n'ouvrez pas de pièces jointes à un message électronique alors que votre programme antivirus est désactivé.

Remarque Norton AntiVirus 2000 ne prend pas en charge la fonctionnalité de blocage de scripts. Si vous utilisez Norton AntiVirus 2000, reportez-vous à la Méthode 2.

Pour Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003 ou Norton AntiVirus 2004, procédez comme suit :
  1. Démarrez Norton AntiVirus.
  2. Cliquez sur Options.
  3. Cliquez sur Norton AntiVirus si un menu apparaît lorsque vous cliquez sur Options.

    La boîte de dialogue Options de Norton AntiVirus s'affiche.
  4. Cliquez sur Blockage de script.
  5. Désactivez la case à cocher Activer le blocage de script (recommandé).
  6. Cliquez sur OK.
Remarque Vous pouvez réactiver le Blocage de script après avoir fini d'utiliser Access.

Pour plus d'informations, reportez-vous à la documentation de votre produit Norton, ou consultez le site Web de Symantec à l'adresse suivante (en anglais) :
http://service4.symantec.com/SUPPORT/nav.nsf/b69c799adfa31ecc85256aa30052f4d0/259a4b15fa285bfb85256a2b007f29c2?OpenDocument
Si ce lien ne fonctionne pas, consultez la Base de connaissances pour Symantec sur le site Web de Symantec à l'adresse suivante, puis recherchez le Document référencé sous le numéro 2001041119095106 (en anglais) :
http://www.symantec.com/search/search.html

Méthode 2

Désactiver le plug-in Norton AntiVirus pour Office pour Microsoft Office

Avertissement Cette solution de contournement peut rendre votre ordinateur ou votre réseau plus vulnérable aux attaques d'utilisateurs malveillants ou de logiciels malveillants comme les virus. Nous ne recommandons pas cette solution de contournement mais nous fournissons ces informations de façon à ce que vous puissiez appliquer cette solution de contournement si vous en décidez ainsi. Vous assumez l'ensemble des risques liés à l'utilisation de cette solution de contournement.

Remarque
Un programme antivirus est conçu pour protéger votre ordinateur des virus. Ne téléchargez ni n'ouvrez pas de fichiers provenant de sources en lesquelles vous n'avez pas confiance, ne visitez pas de sites Web en lesquels vous n'avez pas confiance, ou n'ouvrez pas de pièces jointes à un message électronique alors que votre programme antivirus est désactivé.

Remarque Cette méthode désactive le plug-in d'analyse des virus installé pendant l'installation de Norton AntiVirus. Ce plug-in analyse les documents à la recherche d'infections par virus dans les programmes Office. Lorsque ce plug-in est désactivé, Norton AntiVirus n'analyse pas les documents ouverts. La fonctionnalité de protection automatique de Norton AntiVirus devrait cependant continuer d'assurer une protection en analysant tout fichier exécuté, téléchargé, ouvert, créé ou supprimé. Pour plus d'informations sur Norton AntiVirus, reportez-vous à la documentation de votre produit.

Pour Norton AntiVirus 2002, Norton AntiVirus 2003 et Norton AntiVirus 2004, procédez comme suit :
  1. Démarrez Norton AntiVirus.

    Remarque Si Norton AntiVirus fait partie de Norton SystemWorks (NSW) ou Norton Internet Security (NIS), lancez NSW ou NIS, puis cliquez sur Norton AntiVirus.
  2. Cliquez sur Options, puis sur Divers.
  3. Dans la section Maintenir la protection des documents Microsoft Office, cliquez sur le plug-in Activer Office.

    Cela désactive le plug-in Activer Office.
  4. Cliquez sur OK, puis quittez Norton Antivirus.
Pour Norton AntiVirus 2001, procédez comme suit :
  1. Démarrez Norton AntiVirus 2001.

    Remarque Si Norton AntiVirus fait partie de Norton SystemWorks (NSW) ou Norton Internet Security (NIS), lancez NSW ou NIS, puis cliquez sur Norton AntiVirus.
  2. Cliquez sur Options, puis sur Général.
  3. Dans la section Plug-in Microsoft Office 2000, cliquez sur le plug-in Activer.

    Cela désactive le plug-in Activer.
  4. Cliquez sur OK, puis quittez Norton Antivirus.
Pour Norton AntiVirus 2000, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la zone Ouvrir, tapez les commandes suivantes, puis appuyez sur ENTRÉE :

    La commande que vous tapez dépend de votre système d'exploitation et du logiciel que vous exécutez. Veillez à inclure les guillemets lorsque vous tapez les commandes.
    • Pour Windows 95 ou Windows 98 avec Norton AntiVirus installé, tapez la commande suivante :
      "C:\Windows\System\Regsvr32" -U "C:\Program Files\Norton AntiVirus\OfficeAV.dll"
    • Pour Windows 95 ou Windows 98 avec SystemWorks installé, tapez la commande suivante :
      "C:\Windows\System\Regsvr32" -U "C:\Program Files\Norton SystemWorks\Norton AntiVirus\OfficeAV.dll"
    • Pour Windows NT ou Windows 2000 avec Norton AntiVirus installé, tapez la commande suivante :
      "C:\Winnt\System32\Regsvr32" -U "C:\Program Files\Navnt\OfficeAV.dll"
Si la commande est correcte, le message suivant s'affiche :

DllUnregisterServer dans C:\Program Files\Norton AntiVirus\OfficeAV.dll a réussi.


Si la commande n'a pas réussi, recherchez le fichier OfficeAV.dll dans votre disque dur. Le chemin d'accès du fichier OfficeAV.dll sur votre ordinateur peut être différent du chemin d'accès dans le message. Une fois que vous avez localisé le fichier OfficeAV.dll, mémorisez l'emplacement du fichier OfficeAV.dll, puis procédez à nouveau comme suit. Toutefois, cette fois, changez la partie « C:\Program Files\Norton AntiVirus\OfficeAV.dll » de la commande de l'étape 2 par le chemin d'accès du fichier OfficeAV.dll sur votre ordinateur.

Pour plus d'informations, reportez-vous à la documentation de votre produit Norton, ou consultez le site Web de Symantec à l'adresse suivante (en anglais) :

http://service4.symantec.com/SUPPORT/nav.nsf/df0a595864594c86852567ac0063608c/2efb6ccf3c61c14c852567ee0058f96a?OpenDocument
Si ce lien ne fonctionne pas, consultez la Base de connaissances pour Symantec sur le site Web de Symantec à l'adresse suivante, puis recherchez le document référencé sous le numéro 1999091612160606 (en anglais) :
http://www.symantec.com/search/search.html

Méthode 3

Réinstaller Norton AntiVirus

Pour toutes les versions de Norton AntiVirus, procédez comme suit :
  1. Supprimez Norton AntiVirus, puis redémarrez votre ordinateur.
  2. Démarrez Word.
  3. Dans le menu Aide, cliquez sur Détecter et réparer.
  4. Réinstallez Norton AntiVirus, puis redémarrez votre ordinateur.

Plus d'informations

Etapes pour reproduire le problème

  1. Installez Norton AntiVirus 2000.
  2. Créez une nouvelle base de données Access 2000.
  3. Créez la table suivante, puis enregistrez-la sous le nom Table1 :
       Table : Table1
       ----------------------------
       Nom du champ : Réf
       Type de données : NuméroAuto
       Indexé : Oui (pas de doublons)
    
       Nom du champ : Test
       Type de données : Objet OLE
    
       Propriétés de la table : Table1
       ------------------------
       CléPrimaire : Réf
    					
  4. Créez un formulaire d'après la table Table1. Enregistrez ce formulaire sous le nom de TestOLE.
  5. Ouvrez le formulaire TestOLE en mode Formulaire.
  6. Cliquez avec le bouton droit sur le champ Test, puis cliquez sur Insérer un objet.
  7. Dans la boîte de dialogue Insertion d'un objet, cliquez sur Créer à partir d'un fichier.
  8. Tapez le chemin d'accès d'un document Word ou cliquez sur Parcourir pour en sélectionner un.
  9. Dans la boîte de dialogue Insertion d'un objet, cliquez sur OK pour la fermer.

    L'un des messages mentionnés dans la section « Symptômes » de cet article s'affiche.

Références

Pour plus d'informations sur le plug-in Norton AntiVirus pour Office, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
329820 Comment faire pour utiliser des programmes Office avec le plug-in Norton AntiVirus pour Office
Microsoft fournit les coordonnées de sociétés tierces afin de vous aider à trouver un support technique. Ces informations peuvent être modifiées sans préavis. Microsoft ne garantit en aucun cas l'exactitude des informations concernant les sociétés tierces.
Pour plus d'informations sur la façon de contacter Symantec Corporation, cliquez sur le numéro approprié ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
65416 Liste des fournisseurs tiers de matériels et de logiciels, A-K

60781 Liste des fournisseurs tiers de matériels et de logiciels, L-P

60782 Liste des fournisseurs tiers de matériels et de logiciels, Q-Z

Les produits tiers mentionnés dans le présent article proviennent de sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.

Propriétés

Numéro d'article: 295824 - Dernière mise à jour: mardi 22 mai 2007 - Version: 6.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 97 Standard
Mots-clés : 
kbofficealertid kberrmsg kbprb KB295824
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires