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Symptoms

Microsoft Exchange Server 2013 setup process freezes during installation in the following scenarios:

  • You perform a fresh installation of Exchange Server 2013 Cumulative Update 2 (KB2859928) or Exchange Server 2013 Service Pack 1 (KB2926248) on Windows Server 2008 R2 SP1.

  • You upgrade the Exchange Server 2013 to CU2 or SP1 on Windows Server 2008 R2 SP1.

When this issue occurs, you may see the following information in the Exchange setup log:

Processing file: E:\ExChSRVR\Setup\Perf\FrontendProxyAgentPerfCounters.xml
[04/01/2014 14:46:56.0251] [2] Performance counter name is MessagesSuccessfullyRouted, type is NumberOfItems64.

[04/01/2014 14:46:56.0251] [2] Performance counter name is MessagesFailedToRoute, type is NumberOfItems64. ------------>(Almost 30 minutes of delay)

[04/01/2014 15:14:57.0992] [2] Performance counter category name is 'MSExchangeFrontendTransport Proxy Routing Agent'.
[04/01/2014 15:14:59.0256] [2] Ending processing new-PerfCounters
[04/01/2014 15:14:59.0256] [1] Executing (non-critical):
new-PerfCounters -DefinitionFileName TenantInboundConnectorAgentPerfCounters.x

[04/01/2014 13:56:13.0071] [2] Performance counter name is Number of active WLM LogicalIndex maintenance table maintenances, type is NumberOfItems32.
[04/01/2014 13:56:13.0071] [2] Performance counter category name is 'MSExchangeIS Store'.
[04/01/2014 13:56:13.0196] [2] Performance counter category name is 'MSExchangeIS Store'.

[04/01/2014 14:26:16.0064] [2] Ending processing new-PerfCounters -------------->(Almost 45 minutes of delay)
[04/01/2014 15:14:59.0256] [1] Executing (non-critical):

[04/01/2014 14:32:28.0666] [2] Performance counter name is Routing Tables Calculated Total, type is NumberOfItems32.

[04/01/2014 14:32:28.0666] [2] Performance counter name is Routing Tables Changed Total, type is NumberOfItems32. ----->(Almost 10 minutes of delay)

[04/01/2014 14:43:29.0894] [2] Performance counter category name is 'MSExchange Submission Routing'.
[04/01/2014 14:43:31.0189] [2] Ending processing new-PerfCounters
[04/01/2014 14:43:31.0189] [1] Executing (non-critical)


[04/01/2014 14:27:18.0514] [2] Processing file: E:\ExChSRVR\Setup\Perf\MSExchangeTransportDelivery_EndToEndLatencyTracker.xml
[04/01/2014 14:27:18.0514] [2] Performance counter name is Percentile50, type is NumberOfItems64.
[04/01/2014 14:27:18.0514] [2] Performance counter name is Percentile80, type is NumberOfItems64.
[04/01/2014 14:27:18.0514] [2] Performance counter name is Percentile90, type is NumberOfItems64.
[04/01/2014 14:27:18.0514] [2] Performance counter name is Percentile95, type is NumberOfItems64.
[04/01/2014 14:27:18.0514] [2] Performance counter name is Percentile99, type is NumberOfItems64.
[04/01/2014 14:27:18.0514] [2] Performance counter name is Percentile50Samples, type is NumberOfItems64.
[04/01/2014 14:27:18.0514] [2] Performance counter name is Percentile80Samples, type is NumberOfItems64.
[04/01/2014 14:27:18.0514] [2] Performance counter name is Percentile90Samples, type is NumberOfItems64.
[04/01/2014 14:27:18.0514] [2] Performance counter name is Percentile95Samples, type is NumberOfItems64.
[04/01/2014 14:27:18.0514] [2] Performance counter name is Percentile99Samples, type is NumberOfItems64 .----->(Almost 10 minutes of delay)
[04/01/2014 14:32:19.0710] [2] Performance counter category name is 'MSExchange Delivery End To End Latency'.
[04/01/2014 14:32:21.0146] [2] Ending processing new-PerfCounters
[04/01/2014 14:32:21.0146] [1] Executing (non-critical):


Cause

The delay is at processing the performance counters. This issue is caused by Advapi32.dll file.

Resolution

To resolve this issue, install hotfix 2878378 that includes the updated version of Advapi32.dll:

2878378 OpsMgr 2012 or OpsMgr 2007 R2 generates a "Heartbeat Failure" message and then goes into a greyed out state in Windows Server 2008 R2 SP1

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