Jak rozwiązywać problemy z rozpoznawaniem mowy w programie Word 2002

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 295947 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł został opublikowany wcześniej pod numerem PL295947
Wersja tego artykułu dla programu Microsoft Office 2003:826323.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

Program Microsoft Word 2002 zawiera dwie nowe metody wprowadzania danych: rozpoznawanie mowy i rozpoznawanie pisma ręcznego.

Funkcja rozpoznawania mowy pozwala użytkownikowi po prostu mówić do komputera przez mikrofon. Jeśli system spełnia wymagania, to można dyktować tekst do programu Word. Można też podawać polecenia słowne, co na przykład umożliwia przełączenie trybu wprowadzania na polecenia głosowe. Pozwala to na sterowanie programem Word bez potrzeby klikania poleceń menu.

W artykule podano wykaz wymagań systemowych dla rozpoznawania mowy. W artykule opisano także najczęstsze czynności przy rozwiązywaniu problemów, które można spróbować wykonać, jeśli funkcja rozpoznawania mowy nie działa poprawnie.

Wymagania systemowe

Minimalne wymagania systemowe dla rozpoznawania mowy są następujące:
  • Procesor Pentium 400 MHz lub lepszy
  • 128 megabajtów (MB) pamięci RAM. Więcej pamięci poprawia wydajność.
  • System Microsoft Windows 98 lub nowszy albo system Microsoft Windows NT 4.0 lub nowszy.
  • Program Microsoft Internet Explorer 5 lub nowszy.
  • Wysokiej klasy mikrofon przyustny (zestaw słuchawkowy) z obsługą regulacji poziomu.
Jeśli komputer nie spełnia podanych wymagań minimalnych, to funkcja rozpoznawania mowy może nie zostać zainstalowana prawidłowo albo czas reakcji rozpoznawania może być długi. W celu zapewnienia optymalnego działania funkcji rozpoznawania mowy bez obniżenia wydajności może zajść konieczność zwiększenia ilości pamięci RAM, zwiększenia szybkości procesora lub uaktualnienia systemu operacyjnego.

ROZWIĄZYWANIE PROBLEMÓW

Jeśli rozpoznawanie mowy nie działa w żadnym programie pakietu Microsoft Office, to może zajść potrzeba naprawy instalacji pakietu Office (lub programu Word) przez uruchomienie Kreatora konserwacji pakietu Office.

Sprawdzanie, czy dokument nie jest uszkodzony

Jeśli rozpoznawanie mowy nie działa w określonym dokumencie, to należy utworzyć nowy dokument programu Word i sprawdzić działanie rozpoznawania mowy. Jeśli rozpoznawanie mowy działa w nowym dokumencie, to dokument może być uszkodzony.

Jeśli rozpoznawanie mowy nie działa w nowym dokumencie programu Word, to należy sprawdzić, czy problem nie jest wywołany przez jedną z następujących przyczyn:
  • Dodatek innej firmy
  • Uszkodzony szablon Normal.
  • Ustawienie rejestru
Aby określić, czy przyczyną problemów może być jedna z tych okoliczności, należy przywrócić domyślne ustawienia programu Word.

Przywracanie domyślnych ustawień programu Word

Przy uruchamianiu programu Microsoft Word standardowo ładowane są następujące składniki:
  • Klucz rejestru Data
  • Szablon globalny Normal.dot
  • Szablony i dodatki
  • Dodatki COM
  • Klucz rejestru Options
Jeśli jeden z tych składników jest uszkodzony lub niezgodny, to może wystąpić problem z dostępem lub z wykorzystaniem funkcji rozpoznawania mowy w programie Word. Ładowanie tych elementów można tymczasowo pominąć, uruchamiając program Word z przełącznikiem /a.

Aby uruchomić program Word z przełącznikiem /a, wykonaj następujące kroki:
  1. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  2. W oknie dialogowym Uruchom wykonaj jedną z następujących czynności:
    • W polu Otwórz wpisz polecenie Winword.exe /a.

      -lub-
    • Kliknij przycisk Przeglądaj. Odszukaj i zaznacz plik Winword.exe. Aby to zrobić, wykonaj następujące kroki:
      1. W polu Szukaj w kliknij folder zawierający pliki programu Word. Wybierz plik Winword.exe, a następnie kliknij przycisk Otwórz. Ten krok powoduje wypełnienie pola Otwórz w oknie dialogowym Uruchamianie.
      2. W polu Otwórz przenieś punkt wstawiania poza napis Winword.exe.

        UWAGA: Ścieżka do pliku Winword.exe w oknie dialogowym Uruchamianie jest ujęta w znaki cudzysłowu. Upewnij się, że punkt wstawiania zostanie przeniesiony na prawo od zamykającego znaku cudzysłowu.
      3. Wpisz spację, a następnie wpisz przełącznik /a.

        Instrukcja w polu Otwórz powinna być podobna do następującej:
        "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
  3. W oknie dialogowym Uruchamianie kliknij przycisk OK.
Jeśli program Word został uruchomiony i funkcja rozpoznawania mowy działa prawidłowo po użyciu przełącznika /a, to występuje problem z jednym ze składników wymienionych na początku tej sekcji. Aby określić, który składnik powoduje problem, skorzystaj z narzędzia do rozwiązywania problemów. W celu użycia narzędzia do rozwiązywania problemów może zajść potrzeba zainstalowania szablonu Support.dot.

Aby uzyskać więcej informacji dotyczących narzędzia do rozwiązywania problemów, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
289506 JAK: Instalowanie i korzystanie z szablonu Support.dot w programie Microsoft Word 2002
UWAGA: Jeśli po uruchomieniu programu Word z przełącznikiem /a problem nadal występuje, to nie trzeba korzystać z narzędzia do rozwiązywania problemów.

Sprawdzanie, czy ustawienia rejestru nie są uszkodzone, i zmiana nazwy folderów mowy

Ostrzeżenie Niepoprawne zmodyfikowanie rejestru za pomocą Edytora rejestru lub innej metody może stać się przyczyną poważnych problemów. Mogą one wymagać ponownego zainstalowania systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie problemów spowodowanych niepoprawnym zmodyfikowaniem rejestru będzie możliwe. Możesz modyfikować rejestr na własną odpowiedzialność.

Aby najpierw wykonać kopię zapasową, a następnie usunąć klucz rejestru Speech, wykonaj następujące kroki:
  1. Zamknij wszystkie programy pakietu Office.
  2. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  3. W polu Otwórz wpisz polecenie regedit i kliknij przycisk OK.
  4. Rozwiń Edytor rejestru na następującym kluczu rejestru:
    HKEY_CURRENT_USER\Software\Microsoft\Speech
  5. Po zaznaczeniu folderu Speech kliknij polecenie Eksportuj plik rejestru w menu Rejestr. Zapisz ten folder jako kopię zapasową, aby można było przywrócić oryginalne ustawienia, jeśli klucz rejestru nie jest przyczyną problemu.

    UWAGA: W systemie Windows XP kliknij polecenie Eksportuj w menu Plik.
  6. Po wyeksportowaniu klucza Speech w menu Edycja kliknij polecenie Usuń. Kliknij przycisk Tak po pojawieniu się następującego komunikatu:
    Czy na pewno chcesz usunąć ten klucz i wszystkie jego podklucze?
  7. W menu Rejestr kliknij polecenie Zakończ.

    UWAGA: W systemie Windows XP kliknij polecenie Zakończ w menu Plik.
Po wyeksportowaniu i usunięciu klucza Speech z rejestru systemu Windows zmień nazwę folderów mowy. W tym celu wykonaj następujące kroki:
  1. Kliknij prawym przyciskiem myszy przycisk Start, a następnie kliknij polecenie Eksploruj.
  2. W Eksploratorze Windows zlokalizuj następujący folder:
    C:\Program files\Common Files\Microsoft Shared\Speech
  3. Kliknij prawym przyciskiem myszy folder Speech, a następnie kliknij polecenie Zmień nazwę.
  4. Nadaj folderowi nazwę OldSpeech.
  5. W Eksploratorze Windows zlokalizuj następujący folder:
    C:\Program files\Common Files\SpeechEngines
  6. Kliknij prawym przyciskiem myszy ten folder mowy, a następnie kliknij polecenie Zmień nazwę.
  7. Nadaj folderowi nazwę OldSpeechEngines.
Po wyeksportowaniu i usunięciu klucza Speech z rejestru systemu Windows i zmianie nazwy folderów mowy napraw instalację pakietu Office. Więcej informacji można znaleźć w sekcji „Naprawa pakietu Office” tego artykułu. Po naprawie instalacji pakietu Office uruchom program Word i ustal, czy funkcja rozpoznawania mowy działa poprawnie.

Jeśli napotkasz te same problemy, to można przywrócić oryginalne ustawienia rejestru dla rozpoznawania mowy. W tym celu zamknij wszystkie programy pakietu Office i kliknij dwukrotnie ikonę pliku zapisanego w kroku 5.

Sprawdzanie, czy nie występują konflikty z produktami innych firm

Zainstalowany na komputerze program innej firmy może powodować konflikt z funkcją rozpoznawania mowy w programie Word. Aby określić, czy program innej firmy nie spowodował instalacji lub aktualizacji pewnych składników wykorzystywanych przez rozpoznawanie mowy, należy sprawdzić numery wersji składników rozpoznawania mowy.

Wersja pliku interfejsu SAPI zawarta w pakiecie Office XP to 5.0.2602.00. Jeśli wersja interfejsu SAPI na komputerze jest starsza od 5.0.2602.00, to spróbuj naprawić instalację pakietu Office. Więcej informacji można znaleźć w sekcji „Naprawa pakietu Office” tego artykułu.

Pliki interfejsu programowania aplikacji mowy SAPI (Speech Application Programming Interface)

Aby sprawdzić numery wersji plików interfejsu SAPI, zastosuj metodę odpowiednią dla danego komputera:

Metoda 1: Sprawdzenie karty Informacje:
  1. Kliknij przycisk Start, wskaż polecenie Ustawienia, a następnie kliknij polecenie Panel sterowania. (W systemie Windows XP kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania).
  2. Kliknij dwukrotnie ikonę Mowa.
  3. Kliknij kartę Informacje.
Metoda 2: Sprawdzenie ustawień:
  1. Kliknij przycisk Start, wskaż polecenie Ustawienia, a następnie kliknij polecenie Panel sterowania. (W systemie Windows XP kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania).
  2. Kliknij dwukrotnie ikonę Mowa.
  3. Na karcie Rozpoznawanie mowy kliknij przycisk Ustawienia (w obszarze Język).
Metoda 3: Sprawdzenie wersji plików interfejsu SAPI:

Aby sprawdzić, która wersja interfejsu SAPI jest zainstalowana na komputerze, wykonaj następujące kroki.:
  1. Kliknij prawym przyciskiem myszy przycisk Start, a następnie kliknij polecenie Eksploruj w menu skrótów.
  2. W Eksploratorze Windows zlokalizuj następujący folder:
    C:\Program Files\Common Files\SpeechEngines\Microsoft\SR
  3. Kliknij prawym przyciskiem myszy plik Spsreng.dll lub Spsrx.dll, a następnie w menu skrótów kliknij polecenie Właściwości.
  4. Sprawdź wersję pliku na karcie Wersja.

Pliki pokrewne funkcji rozpoznawania mowy

Aby sprawdzić wersje innych plików pokrewnych funkcji rozpoznawania mowy, wykonaj następujące kroki:
  1. Kliknij przycisk Start, wskaż polecenie Znajdź, a następnie kliknij polecenie Pliki lub foldery.
  2. W polu Nazwa wpisz nazwę Msctf.dll, a następnie kliknij przycisk Znajdź teraz.
  3. Kliknij prawym przyciskiem myszy plik Msctf.dll, a następnie w menu skrótów kliknij polecenie Właściwości.
  4. Kliknij kartę Wersja i zanotuj numer wersji.
  5. Powtórz kroki od 2 do 4, aby sprawdzić plik Ctfmon.exe.
Numer wersji plików Msctf.dll i Ctfmon.exe zawartych w pakiecie Office XP to 5.1.2409.7. Jeśli numer wersji tych plików na komputerze jest wcześniejszy niż 5.1.2409.7, to spróbuj naprawić instalację pakietu Office. Więcej informacji można znaleźć w sekcji „Naprawa pakietu Office” tego artykułu.

Aby uzyskać dodatkowe informacje dotyczące znanych konfliktów programów innych producentów z funkcją Text Bridge i funkcją rozpoznawania mowy w programie Word 2002, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
302598 Dictation mode does not start when you start speech recognition

Naprawa pakietu Office

  1. Zamknij wszystkie programy systemu Windows.
  2. Kliknij przycisk Start, wskaż polecenie Ustawienia, a następnie kliknij polecenie Panel sterowania. (W systemie Windows XP kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania).
  3. Kliknij dwukrotnie ikonę Dodaj/Usuń programy, a następnie wykonaj kroki odpowiednie dla systemu operacyjnego komputera.
    • W systemach Microsoft Windows 98 lub Microsoft Windows NT 4.0:
      • Jeśli program Word został zainstalowany jako część pakietu Office, to kliknij pozycję Microsoft Office na karcie Instaluj/Odinstaluj, a następnie kliknij przycisk Dodaj/Usuń.

        -lub-
      • Jeśli program Word został zainstalowany jako autonomiczny program, to kliknij pozycję Microsoft Word na karcie Instaluj/Odinstaluj, a następnie kliknij przycisk Dodaj/Usuń.
    • W systemach Microsoft Windows 98, Microsoft Windows Millennium Edition (Me) lub Microsoft Windows 2000:
      • Jeśli program Word został zainstalowany jako część pakietu Office, to kliknij pozycję Microsoft Office w polu Aktualnie zainstalowane programy, a następnie kliknij przycisk Zmień.

        -lub-
      • Jeśli program Word został zainstalowany jako program autonomiczny, to kliknij pozycję Microsoft Word w polu Aktualnie zainstalowane programy, a następnie kliknij przycisk Zmień.
  4. W Kreatorze konserwacji pakietu Office kliknij przycisk Napraw pakiet Office.
  5. Kliknij przycisk Wykryj i napraw błędy instalacji produktu Office, a następnie kliknij przycisk OK.
WAŻNE: Jako dodatkowy krok procesu usuwania problemów można przed naprawą pakietu Office uruchomić systemowe narzędzie dyskowe, takie jak program ScanDisk lub Defragmentator dysków. Aby zlokalizować te narzędzia systemu Windows, kliknij przycisk Start, wybierz polecenie Programy (w systemie Windows XP — Wszystkie programy), wskaż Akcesoria i wybierz polecenie Narzędzia systemowe.

Ustalanie, czy problem jest związany ze sprzętem

Jeśli funkcja rozpoznawania mowy nie działa na komputerze, lecz wydaje się, że jest ona zainstalowana i uaktywniona, to może występować problem z mikrofonem lub innym urządzeniem sprzętowym. Aby ustalić, czy jest to problem z mikrofonem, wykonaj następujące kroki:
  1. Kliknij przycisk Start, wskaż polecenie Ustawienia, a następnie kliknij polecenie Panel sterowania. (W systemie Windows XP kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania).
  2. Kliknij dwukrotnie ikonę Usługi tekstowe. (W systemie Windows XP kliknij ikonę Inne opcje panelu sterowania w sekcji Zobacz też, a następnie kliknij ikonę Usługi tekstowe).
  3. Kliknij przycisk Konfiguruj mikrofon. (W systemie Windows XP wybierz pozycję Rozpoznawanie mowy z listy Zainstalowane usługi i kliknij przycisk Właściwości. Na karcie Rozpoznawanie mowy kliknij przycisk Konfiguruj mikrofon).
Aktywność na ekranie głośności mikrofonu wskazuje, że mikrofon działa poprawnie.

Jeśli nie widać aktywności na ekranie głośności mikrofonu, to komputer może nie nagrywać żadnych dźwięków. Aby sprawdzić działanie dźwięku w systemie, skorzystaj z programu Rejestrator dźwięku. Aby to zrobić, wykonaj następujące kroki:
  1. Kliknij przycisk Start, wskaż polecenie Programy (w systemie Windows XP wskaż polecenie Wszystkie programy), wskaż polecenie Akcesoria, wskaż polecenie Rozrywka, a następnie kliknij polecenie Rejestrator dźwięku.
  2. Kliknij przycisk Nagraj i mów do mikrofonu.
Jeśli nie widać żadnej aktywności podczas mówienia do mikrofonu, to może występować problem z kartą dźwiękową lub innym sterownikiem sprzętowym.

Aby uzyskać więcej informacji dotyczących rozwiązywania problemów z mikrofonem w systemie Windows 98, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
266677 How to troubleshoot microphone issues

Ustalanie, czy występuje problem z procesorem wprowadzania tekstu TIP (Text Input Processor)

Jeśli funkcja rozpoznawania pisma ręcznego w programie Word działa poprawnie, a funkcja rozpoznawania tekstu — nie, to może być uszkodzony procesor wprowadzania tekstu (TIP).

Aby rozwiązać ten problem, usuń i zainstaluj ponownie funkcję rozpoznawania mowy, korzystając z programu instalacyjnego pakietu Office.

Sprawdzanie ustawień języka i klawiatury

Procesory wprowadzania tekstu są specyficzne dla języka. Aby sprawdzić, czy ustawiony jest język angielski (USA), wykonaj poniższe kroki:
  1. Kliknij przycisk Start, wskaż polecenie Ustawienia, a następnie kliknij polecenie Panel sterowania. (W systemie Windows XP kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania).
  2. Kliknij dwukrotnie ikonę Usługi tekstowe. (W systemie Windows XP kliknij ikonę Inne opcje panelu sterowania w sekcji Zobacz też, a następnie kliknij ikonę Usługi tekstowe).
  3. Kliknij kartę Ustawienie. Upewnij się, że ustawienie Język domyślny ma wartość Angielski (Stany Zjednoczone).
  4. Sprawdź na liście Zainstalowane usługi, czy klawiatura USA jest wymieniona jako zainstalowana. Jeśli klawiatura USA nie jest wymieniona, wykonaj następujące kroki:
    1. Kliknij przycisk Dodaj.
    2. W oknie dialogowym Dodawanie języka zmień wartość pola Język na wartość Angielski (Stany Zjednoczone).
    3. Kliknij przycisk OK.

Sprawdzanie problemów z wielojęzycznością

Przy korzystaniu z pakietu Office w wersji dla języka chińskiego uproszczonego lub języka japońskiego w systemie Windows NT 4.0, w programie Word 2002 dostępny jest tylko tryb poleceń głosowych. Rozpoznawanie mowy jest niedostępne dla autonomicznych wersji programów Microsoft Access 2002, Microsoft Excel 2002, Microsoft FrontPage 2002, Microsoft Outlook 2002, Microsoft PowerPoint 2002 oraz Microsoft Publisher 2002.

Jeśli tryb Dyktowanie ani tryb Polecenie głosowe nie ukazuje się na pasku pakietu Office Język, to prawdopodobnie używany jest edytor IME (Input Method Editor) ze starszej wersji pakietu Microsoft Office.

Aby korzystać z rozpoznawania mowy, należy stosować edytor IME zawarty w pakiecie Office XP lub w dodatku MUI Pack dla pakietu Microsoft Office XP.

Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
293624 Global IME does not work after you install Office XP


Materiały referencyjne

Aby uzyskać więcej informacji na temat rozpoznawania mowy, kliknij polecenie Microsoft Word — Pomoc w menu Pomoc, wpisz mowa w Asystencie pakietu Office lub Kreatorze odpowiedzi i kliknij przycisk Wyszukaj w celu wyświetlenia znalezionego tematu.
Aby uzyskać najnowsze informacje o pracach nad rozwojem funkcji rozpoznawania mowy, prowadzonych w firmie Microsoft, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://www.microsoft.com/speech/
Aby uzyskać więcej informacji dotyczących rozpoznawania mowy w programie Word 2002, kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
278927 WD2002: Część 1: Rozpoznawanie mowy i pisma ręcznego — często zadawane pytania
283160 Część 3: Rozpoznawanie mowy i pisma ręcznego — często zadawane pytania
304861 „Handwriting Recognition in Office XP” white paper available for download
304860 Description of the „Speech Recognition in Office XP” white paper


Właściwości

Numer ID artykułu: 295947 - Ostatnia weryfikacja: 16 lutego 2006 - Weryfikacja: 4.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Word 2002 Standard Edition
Słowa kluczowe: 
kbspeech kbtshoot kbhowtomaster KB295947

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com