Com solucionar problemas de reconhecimento de fala no Word 2002

Traduções deste artigo Traduções deste artigo
ID do artigo: 295947 - Exibir os produtos aos quais esse artigo se aplica.
Para obter a versão deste artigo para o Microsoft Office Word 2003, consulte 826323.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

O Microsoft Word 2002 inclui dois novos métodos de entrada: reconhecimento de fala e reconhecimento de manuscrito.

O recurso de reconhecimento de fala permite que você fale literalmente com o computador por um microfone. Se o sistema atender aos requisitos, é possível ditar o texto no Word. Também é possível falar os comandos, de modo que, por exemplo, você possa alterar do modo de entrada para o Comando de Voz. Isto permite que você controle o Word sem clicar nos menus.

Este artigo lista os requisitos do sistema para o reconhecimento de voz. Este artigo também descreve as etapas mais comuns para solução de problemas que você pode tentar se o reconhecimento de voz não estiver funcionando corretamente.

Requisitos do sistema

Os requisitos mínimos do sistema para o reconhecimento de fala são os seguintes:
  • Processador Pentium de 400 MHz.
  • 128 MB de RAM. Mais memória aprimora o desempenho.
  • Microsoft Windows 98 ou posterior, ou Microsoft Windows NT 4.0 ou posterior.
  • Microsoft Internet Explorer 5 ou posterior.
  • Um microfone de alta qualidade de proximidade (headset) com compatibilidade de ajuste de ganho.
Se o sistema de computador não atender a estes requisitos mínimos, o recurso de reconhecimento de fala pode não instalar corretamente, ou o tempo de resposta de reconhecimento pode ser lento. Para que o reconhecimento de fala funcione de forma otimizada e sem um desempenho prejudicado, pode ser necessário aumentar a RAM, aumentar a velocidade do processador ou atualizar o sistema operacional.

SOLUÇÃO DE PROBLEMAS

Se o reconhecimento de fala não estiver funcionando em todos os programas do Microsoft Office, talvez seja necessário reparar a instalação do Office (ou Word), executando o Assistente de manutenção do Office.

Verificar um possível documento danificado

Se o reconhecimento de fala não funcionar em um documento específico, crie um novo documento do Word e teste o reconhecimento de fala. Se o reconhecimento de fala funcionar no novo documento, você pode ter um documento danificado (corrompido).

Se o reconhecimento de fala não funcionar no novo documento do Word, verifique se algum dos itens abaixo estão causando este problema:
  • Um complemento de terceiros
  • Um modelo Normal danificado
  • Uma configuração do Registro
Para determinar se algum destes itens está causando o problema, reconfigure o Word para usar suas configurações padrão.

Redefinir o Word para usar as configurações padrão

Os seguintes componentes são normalmente carregados ao iniciar o Microsoft Word:
  • A chave do Registro de dados
  • O modelo global Normal.dot
  • Complementos e modelos
  • Complementos COM
  • A chave do Registro Opções
Se um destes componentes estiver danificado ou for incompatível, você poderá ter problemas para acessar ou usar o recurso de reconhecimento de fala no Word. É possível evitar temporariamente estes itens durante a inicialização do Word com a opção /a.

Para iniciar o Word usando a chave /a, execute as seguintes etapas:
  1. Clique em Iniciar e em Executar.
  2. Na caixa de diálogo Executar, execute uma das seguintes ações:
    • Na caixa Abrir, digite Winword.exe /a.

      -ou-
    • Clique em Procurar. Localize e selecione o arquivo Winword.exe. Para fazer isto, execute as seguintes etapas:
      1. Na lista Examinar, selecione a pasta que contém os arquivos de programa do Word. Selecione o arquivo Winword.exe e clique em Abrir. Esta etapa preenche a caixa Abrir na caixa de diálogo Executar.
      2. Na caixa Abrir, mova o ponto de inserção depois do Winword.exe.

        OBSERVAÇÃO: O caminho para o arquivo Winword.exe na caixa de diálogo Executar fica entre aspas. Certifique-se de mover o ponto de inserção para a direita do fechamento das aspas.
      3. Digite um espaço e digite /a.

        O demonstrativo na caixa Abrir deve ser semelhante à seguinte:
        "C:\Arquivos de programas\Microsoft Office\Office10\Winword.exe" /a
  3. Na caixa de diálogo Executar, clique em OK.
Se o Word iniciar e o recurso de reconhecimento de fala funcionar corretamente ao usar a chave /a, o problema está com um dos componentes listados no início desta seção. Use o Utilitário de solução de problemas para determinar qual componente está causando o problema. Para usar o Utilitário de Solução de Problemas, pode ser necessário instalar o Support.dot.

Para obter mais informações sobre o utilitário de solução de problemas, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
289506 Como instalar e usar o modelo Support.dot no Word 2002
OBSERVAÇÃO: Se o problema ainda ocorrer ao iniciar o Word com a chave /a, não é necessário usar o Utilitário de solução de problemas.

Verificar a existência de uma possível configuração danificada no Registro e renomear as pastas de fala

Aviso O uso incorreto do Editor do Registro, ou outro método, pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. A modificação do Registro é de sua responsabilidade.

Execute as seguintes etapas para primeiro fazer back up e, em seguida, excluir a chave do Registro de fala:
  1. Encerre todos os programas do Office.
  2. Clique em Iniciar e em Executar.
  3. Na caixa Abrir, digite regedit e clique em OK.
  4. Expanda o Editor do Registro para a seguinte chave do Registro:
    HKEY_CURRENT_USER\Software\Microsoft\Speech
  5. Com a pasta de fala selecionada, clique em Exportar Arquivo de Registro no menu Registro. Salve esta pasta como um backup para que você consiga restaurar as configurações originais, se a chave do Registro não for o problema.

    OBSERVAÇÃO: No Microsoft Windows XP, clique em Exportar no menu File.
  6. Depois de exportar a chave Fala, clique em Excluir no menu Editar. Clique em Sim para a seguinte mensagem:
    Tem certeza que deseja excluir esta chave e todas as suas subchaves?
  7. No menu Registro, clique em Sair.

    OBSERVAÇÃO: No Microsoft Windows XP, clique em Sair no menu Arquivo.
Depois de exportar e excluir a chave Fala no Registro do Windows, renomeie as pastas Fala. Para fazer isto, execute as seguintes etapas:
  1. Clique com o botão direito do mouse em Iniciar e clique em Explorar.
  2. No Windows Explorer, localize a seguinte pasta:
    C:\Arquivos de programas\Arquivos comuns\Microsoft Shared\Fala
  3. Clique com o botão direito do mouse na pasta Fala e clique em Renomear.
  4. Dê o nome da pasta de Fala_antiga.
  5. No Windows Explorer, localize a seguinte pasta:
    C:\Arquivos de programas\Aquiuvos comuns\SpeechEngines
  6. Clique com o botão direito do mouse na pasta Fala e clique em Renomear.
  7. Dê o nome da pasta de Mecanismos_de_fala_antigos.
Depois de exportar e excluir a chave Fala no Registro do Windows e renomear as pastas Fala, repare a instalação do Office. Para obter mais informações, consulte a seção "Reparar o Office" neste artigo. Depois de reparar a instalação do Office, inicie o Microsoft Word e determine se o recurso de reconhecimento de fala está funcionando corretamente.

Se passar pelos mesmos problemas, você pode querer restaurar suas configurações do Registro originais de reconhecimento de fala. Para fazer isto, encerre todos os programas do Office e, em seguida, clique duas vezes no arquivo que você salvou na etapa 5.

Verificar possíveis conflitos de terceiros

Um programa de terceiros instalado no computador pode entrar em conflito com o reconhecimento de fala do Word. Para determinar se um programa de terceiros instalou ou atualizou todos os componentes usados pelo reconhecimento de fala, verifique os números de versão dos componentes de reconhecimento de fala.

A versão SAPI incluída no Office XP é 5.0.2602.00. Se a versão SAPI no computador for anterior a 5.0.2602.00, tente reparar a instalação do Office. Para obter mais informações, consulte a seção "Reparar o Office" deste artigo.

Arquivos SAPI (Speech Application Programming Interface)

Para verificar os números de versão dos arquivos SAPI, use o método apropriado para o computador:

Método 1: Verificar a guia sobre:
  1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle. (No Windows XP, clique em Iniciar e em Painel de Controle.).
  2. Clique duas vezes no ícone Comando de Voz.
  3. Clique na guia Sobre .
Método 2: Verificar as configurações:
  1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle. (No Windows XP, clique em Iniciar e emPainel de Controle.).
  2. Clique duas vezes no ícone Comando de Voz.
  3. Na guia Reconhecimento de Voz, clique em Configurações (em Idioma).
Método 3: Verificar a versão dos arquivos SAPI:

Para verificar a versão SAPI instalada no computador, execute as seguintes etapas:
  1. Clique com o botão direito do mouse em Iniciar e clique em Explorar no menu de atalho.
  2. No Windows Explorer, localize a seguinte pasta:
    C:\Arquivos de programas\Arquivos comuns\SpeechEngines\Microsoft\SR
  3. Clique com o botão direito do mouse no arquivo Spsreng.dll ou Spsrx.dll e clique em Propriedades no menu de atalho.
  4. Verifique a versão do arquivo na guia Versão.

Arquivos relacionados ao reconhecimento de fala

Para verificar as versões de outros arquivos relacionados ao reconhecimento de fala, execute as seguintes etapas:
  1. Clique em Iniciar, aponte para Localizar e clique em Arquivos ou pastas.
  2. na caixa Nome, digite Msctf.dll e clique em Pesquisar Agora.
  3. Clique com o botão direito do mouse no arquivo Msctf.dll e clique em Propriedades no menu de atalho.
  4. Clique na guia Versão e observe o número da versão.
  5. Repita as etapas de 2 a 4 para verificar o arquivo Ctfmon.exe.
O número da versão do Msctf.dll e Ctfmon.exe, incluído no Office XP, é 5.1.2409.7 Se o número da versão destes arquivos no computador for anterior ao 5.1.2409.7, tente reparar a instalação do Office. Para obter mais informações, consulte a seção "Reparar o Office" deste artigo.

Para obter mais informações sobre um conflito conhecido de terceiros com o Text Bridge e o reconhecimento de fala no Word 2002, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
302598 O modo ditado não funciona ao iniciar o reconhecimento de fala

Reparar o Office

  1. Encerre todos os programas do Windows.
  2. Clique em Iniciar, aponte para Configurações e clique em Painel de controle. (No Windows XP, clique em Iniciar e emPainel de Controle.).
  3. Clique duas vezes no ícone Adicionar/Remover Programas e execute as etapas do sistema operacional do computador.
    • No Microsoft Windows 98 ou no Microsoft Windows NT 4.0:
      • Se você instalou o programa Word como parte do Office, clique em Microsoft Office na guia Instalar/Desinstalar, e clique em Adicionar/Remover.

        -ou-
      • Se você instalou o Word como programa autônomo, clique em Microsoft Word na guia Instalar/Desinstalar, e clique em Adicionar/Remover.
    • No Microsoft Windows XP, Microsoft Windows Millennium Edition (Me) ou Microsoft Windows 2000:
      • Se você instalou o Word como parte do Office, clique em Microsoft Office na caixa Programas Instalados, e clique em Alterar.

        -ou-
      • Se você instalou o Word como um programa autônomo, clique em Microsoft Office na caixa Programas Instalados, e clique em Alterar.
  4. No Assistente de Manutenção do Office, clique em Reparar o Office.
  5. Selecione a opção Detectar e Reparar erros na instalação do meu Office e clique em OK.
IMPORTANTE: Como uma etapa adicional de solução de problemas, é possível executar um utilitário de disco de sistema, como o ScanDisk ou o Desfragmentador de disco, antes de reparar o Office. Para localizar estes utilitário do Windows, clique em Iniciar, aponte para Programas (no Windows XP, aponte para Todos os Programas), aponte para Acessórios e para Ferramentas do Sistema.

Determinar se o problema está relacionado ao hardware

Se você não possui a funcionalidade de reconhecimento de fala no computador, mas o reconhecimento de fala parece estar instalado e ativo, talvez haja um problema com o microfone ou outro dispositivo de hardware. Para determinar se o microfone tem um problema, execute as seguintes etapas:
  1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle. (No Windows XP, clique em Iniciar e em Painel de Controle.).
  2. Clique duas vezes em Serviços de Texto. (No Windows XP, clique em Outras Opções do Painel de Controle na seção Consultar Também, e clique em Serviços de Texto.)
  3. Clique em Configurar Microfone. (No Windows XP, selecione Reconhecimento de Voz na lista Serviços Instalados, e clique em Propriedades. Na guia Reconhecimento de Voz, clique em Configurar Microfone.)
A atividade na tela do volume do microfone indica que o microfone está funcionando corretamente.

Se você não vir atividade na tela do volume do microfone, o computador pode não estar gravando o som. Para testar o som no sistema, use o Gravador de Som. Para fazer isto, execute as seguintes etapas:
  1. Clique em Iniciar, aponte para Programas (no Windows XP, aponte para Todos os Programas), aponte para Acessórios, para Entretenimento e clique em Gravador de Som.
  2. Clique no botão Gravar e fale no microfone.
Se não houver atividade ao falar no microfone, a placa de som ou outro driver de hardware pode ter um problema.

Para obter mais informações sobre como solucionar problemas de microfone no Windows 98, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
266677 Como solucionar problemas de microfone

Determinar se o problema está com o TIP (processador de entrada de texto)

Se o recurso reconhecimento de texto manuscrito no Word funcionar corretamente, mas o reconhecimento de fala não, o processador de entrada de texto poderá estar danificado.

Para corrigir este problema, remova e, em seguida, reinstale o recurso de reconhecimento de fala usando o programa de Instalação do Office.

Verificar as configurações de idioma e de teclado

Os processadores de entrada de texto têm idiomas específicos. Para determinar se o idioma está configurado para Inglês americano, execute as seguintes etapas:
  1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle. (No Windows XP, clique em Iniciar e em Painel de Controle.).
  2. Clique duas vezes em Serviços de Texto. (No Windows XP, clique em Outras Opções do Painel de Controle na seção Consultar Também, e clique em Serviços de Texto.)
  3. Clique na guia Configurações. Verifique se o Idioma Padrão está configurado para Inglês (Estados Unidos).
  4. Na lista Serviços Instalados, confirme se o teclado americano está listado como um teclado instalado. Se o teclado americano não estiver listado, execute as seguintes etapas:
    1. Clique em Adicionar.
    2. Na caixa de diálogo Definir Idioma, altere a caixa Idioma para Inglês (Estados Unidos).
    3. Clique em OK.

Verificar problemas multilíngüe

Se você estiver executando o Windows NT 4.0 com a versão chinês simplificada do Office ou a versão japonês do Office, o modo de comando de voz ficará disponível somente no Word 2002. O reconhecimento de fala não fica disponível se você estiver executando uma versão autônoma do Microsoft Access 2002, do Microsoft Excel 2002, do Microsoft FrontPage 2002, do Microsoft Outlook 2002, do Microsoft Powerpoint 2002 ou do Microsoft Publisher 2002.

Se nem o modo ditado ou o modo de Comando de Voz aparece na barra Idioma do Office, você pode estar usando um IME (Editor de Método de Entrada) de uma versão anterior do Microsoft Office.

Para usar o reconhecimento de fala, você deve usar um IME incluído no Office XP ou o Multilingual User Interface Pack do Microsoft Office XP.

Para obter mais informações, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
293624 O IME Global não funciona após a instalação do Office XP



Referências

Para obter mais informações sobre o reconhecimento de fala, clique em Ajuda do Microsoft Word no menu Ajuda, digite fala no Assistente do Office ou Assistente de resposta e clique em Pesquisar para exibir o tópico.
Para obter as informações mais atualizadas sobre o desenvolvimento do reconhecimento de fala na Microsoft, favor visitar o seguinte site da Microsoft (em inglês):
http://www.microsoft.com/speech/
Para obter mais informações sobre reconhecimento de fala no Word 2002, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
278927 Descrição dos métodos de reconhecimento de fala e de texto manuscrito no Word 2002
283160 Perguntas freqüentes sobre o recurso de reconhecimento de texto manuscrito do Word 2003 e do Word 2002
304861 Documento sobre "Reconhecimento de texto manuscrito no Office XP" disponível para download
304860 Descrição do documento sobre "Reconhecimento de fala no Office XP"


Propriedades

ID do artigo: 295947 - Última revisão: quarta-feira, 23 de agosto de 2006 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2002 Standard Edition
Palavras-chave: 
kbspeech kbtshoot kbhowtomaster KB295947

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com