Identificativo articolo: 296088 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si avvia Microsoft Outlook o si tenta di aprire un file delle cartelle personali (pst) oppure un file delle cartelle fuori rete (ost), Ŕ possibile che venga visualizzato il seguente messaggio di errore:
Errori nel file <percorso_file>. Chiudere tutte le applicazioni abilitate alla posta elettronica ed eseguire l'UtilitÓ di ripristino Posta in arrivo.
dove <percorso_file> Ŕ il percorso del file pst.

Se si esegue l'UtilitÓ di ripristino Posta in arrivo (Scanpst.exe), il problema non viene risolto.

Cause

Questo problema si verifica perchÚ per i file pst e ost esiste una limitazione delle dimensioni di 2 gigabyte (GB) e il messaggio di errore viene visualizzato quando tale limitazione viene superata. Non Ŕ possibile correggere questo problema con l'UtilitÓ di ripristino Posta in arrivo.

Risoluzione

Per risolvere il problema, scaricare il seguente strumento dall'Area download Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/downloads/details.aspx?FamilyID=B33B1DFF-6F50-411D-BBDF-82019DDA602E&amp;displaylang=en
NOTA: utilizzare lo strumento per creare una copia troncata del file pst. La copia generata dallo strumento non conterrÓ tutti i dati originali perchÚ lo strumento taglia dal file una quantitÓ di dati definita dall'utente.

Limitazioni di recupero dell'utilitÓ di troncamento di 2 GB:
  • ╚ necessario che sul disco rigido siano disponibili almeno 2 GB di spazio per creare una copia del file pst.
  • L'utilitÓ tronca il file pst a una dimensione inferiore a 2 GB. Per disporre di un'area di lavoro sufficiente, troncare il file da 20 a 25 megabyte (MB) in meno del limite di 2 GB. I dati troncati vengono rimossi dalla nuova copia, pertanto alcuni messaggi non saranno presenti nella copia recuperata.
╚ possibile utilizzare questo processo per tentare di recuperare i dati, anche se non fornisce risultati positivi al 100%. Se lo strumento funziona, non recupererÓ tutti i dati, infatti quelli troncati saranno mancanti.

Per recuperare i dati utilizzare la procedura riportata di seguito:
  1. Scaricare lo strumento dall'Area download Microsoft al seguente indirizzo (informazioni in lingua inglese):
    http://www.microsoft.com/downloads/details.aspx?FamilyID=B33B1DFF-6F50-411D-BBDF-82019DDA602E&amp;displaylang=en
  2. Estrarre il file 2gb152.exe in una cartella vuota. Dovrebbero essere visualizzati i seguenti cinque file:
    • Msstdfmt.dll
    • Msvbvm60.dll
    • Pst2gb.exe
    • Readme.rtf
    • Readme.txt
  3. Avviare il programma Pst2gb.exe.
  4. Scegliere Sfoglia per selezionare il file pst con dimensioni eccedenti i limiti, quindi scegliereApri.
  5. Scegliere Crea, selezionare il nome e il percorso del file di dati troncato che si desidera creare, quindi scegliereSalva.
  6. Immettere la quantitÓ di dati da troncare nel file pst. Non esiste una dimensione corretta da utilizzare. ╚ possibile ottenere i migliori risultati utilizzando una dimensione da 20 a 25 MB, ma potrebbe essere necessario troncare una quantitÓ inferiore o superiore. Se si troncano ad esempio 25 MB di dati e il processo funziona, ripeterlo e troncare il file pst originale di soli 15 MB. Se funziona, provare con 5 MB. Se con 25 MB il processo non funziona, ripeterlo e provare a troncare il file pst originale di 35 MB. Se non funziona, aumentare la quantitÓ fino a ottenere il risultato desiderato.
  7. Eseguire l'UtilitÓ di ripristino Posta in arrivo (il file Scanpst.exe) sul file pst pi¨ piccolo.
  8. Aprire il file pst recuperato in Outlook.
  9. Questo passaggio Ŕ consigliato ma facoltativo. Se il file si apre, fare clic con il pulsante destro del mouse sulla cartella principale del file pst, scegliereProprietÓ, quindi fare clic su Comprimi per avviare la compressione. Per un file di queste dimensioni la compressione potrebbe richiedere da 4 a 8 ore circa.
  10. Se il file non si apre, eliminare il file pst troncato e ripetere il processo con il file pst originale. Troncare una maggiore quantitÓ di dati rispetto al primo tentativo, quindi ripetere il processo.
  11. Installare l'aggiornamento o la correzione rapida seguente a seconda della versione di Outlook in esecuzione.
    Questi aggiornamenti impediscono al file pst di Outlook di eccedere la dimensione massima di 2 GB. Utilizzare uno dei metodi seguenti per gestire la dimensione dei file pst:

    • Utilizzare pi¨ file pst.
    • Utilizzare la funzione di archivio.
    • Salvare gli allegati in una cartella del file system ed eliminarli dai messaggi.
La versione in lingua inglese di questo strumento deve avere i seguenti attributi di file (o successivi):

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine di questo articolo.

Informazioni

197316 Utilizzo dello strumento Manutenzione Posta in arrivo per recuperare i messaggi in Outlook 2000 installato con l'opzione SocietÓ o gruppo di lavoro
╚ possibile che venga visualizzato un messaggio di errore analogo al seguente all'avvio dell'utilitÓ di troncamento di 2 GB:
Errore di runtime "713": Classe non registrata. I seguenti file devono essere installati nel computer. MSSTDFMT.DLL
Se viene visualizzato questo messaggio di errore, attenersi alla seguente procedura:

Microsoft Windows 98, Microsoft Windows 98 SE, Microsoft Windows ME

  1. Copiare il file MSstdfmt.dll nella cartella C:\Windows\System.
  2. Aprire un prompt dei comandi, quindi digitare il seguente comando:
    REGSVR32 C:\Windows\System\MSSTDFMT.DLL

Microsoft Windows NT, Microsoft Windows 2000 e Microsoft Windows XP

  1. Copiare il file MSstdfmt.dll nella cartella C:\<dirwin>\System32.
  2. Aprire un prompt dei comandi e digitare il seguente comando
    REGSVR32 C:\windir\System32\MSSTDFMT.DLL
    , dove windir Ŕ la directory WINNT o Windows.
Nota: questo Ŕ un articolo a "PUBBLICAZIONE RAPIDA", creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento vengono fornite "cosý come sono" in risposta alle problematiche riscontrate. A causa della rapiditÓ con cui vengono resi disponibili, i materiali possono contenere errori di battitura e sono soggetti a modifica senza preavviso, in qualsiasi momento. Per altre considerazioni, vedere le Condizioni per l'utilizzo.

ProprietÓ

Identificativo articolo: 296088 - Ultima modifica: mercoledý 8 gennaio 2014 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 98 Standard Edition
  • Microsoft Outlook 97 Standard Edition
Chiavi:á
kbhotfixserver kbqfe kberrmsg kbprb KB296088
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com