Artigo: 296088 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT296088
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando iniciar o Microsoft Outlook ou tentar abrir um ficheiro de pastas pessoais (.pst) ou um ficheiro de pastas offline (.ost), poderá receber a seguinte mensagem de erro:
Foram detectados erros no ficheiro <caminho_do_ficheiro>. Termine todas as aplicações de correio e depois utilize a Ferramenta de reparação da pasta 'A Receber'.
em que <caminho_do_ficheiro> é o caminho do ficheiro .pst.

Se executar a Ferramenta de reparação da pasta 'A receber' (Scanpst.exe), o ficheiro não resolve o problema.

Causa

Este problema ocorre porque os ficheiros .pst e .ost têm um limite de tamanho de 2 gigabytes (GB) e a mensagem de erro ocorre quando este limite é ultrapassado. A Ferramenta de reparação da caixa 'A receber' não consegue corrigir este problema.

Resolução

Para resolver este problema, transfira o seguinte ficheiro a partir do centro de transferências da Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=B33B1DFF-6F50-411D-BBDF-82019DDA602E&amp;displaylang=en
NOTA: utilize a ferramenta para criar uma cópia truncada do ficheiro .pst. A cópia que é produzida depois de executada a ferramenta não contém todos os dados originais, uma vez que a ferramenta elimina uma quantidade de dados do ficheiro determinada pelo utilizador.

Limitações de recuperação do utilitário de truncagem a 2 GB:
  • Tem de ter pelo menos 2 GB de espaço livre no disco rígido (para efectuar uma cópia do ficheiro .pst).
  • O utilitário trunca o ficheiro .pst a um valor inferior a 2 GB. Para ter espaço de trabalho suficiente, efectue a truncagem do ficheiro entre 20 e 25 megabytes (MB) abaixo do limite de 2 GB. Os dados truncados são removidos da nova cópia, o que significa que algumas mensagens estão em falta da cópia recuperada.
Pode utilizar este processo para tentar recuperar os dados, mas não tem 100% de êxito. Se esta ferramenta funcionar, não recupera todos os dados (os dados truncados estão em falta).

Utilize os seguintes passos para recuperar os dados:
  1. Transfira a ferramenta a partir da seguinte hiperligação do centro de transferências da Microsoft:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=B33B1DFF-6F50-411D-BBDF-82019DDA602E&amp;displaylang=en
  2. Extraia o ficheiro 2gb152.exe para uma pasta vazia. Deverá visualizar os seguintes cinco ficheiros:
    • Msstdfmt.dll
    • Msvbvm60.dll
    • Pst2gb.exe
    • Readme.rtf
    • Readme.txt
  3. Inicie o programa Pst2gb.exe.
  4. Clique em Browse para seleccionar o ficheiro .pst de tamanho excedido e clique em Abrir.
  5. Clique em Create, seleccione o nome e localização do ficheiro de dados truncado que pretende criar e clique em Guardar.
  6. Escreva a quantidade de dados que pretende truncar no ficheiro .pst. Não existe uma quantidade correcta que possa ser utilizada. Pode obter os melhores resultados se utilizar 20 a 25 MB, mas poderá ter de truncar uma quantidade maior ou menor. Por exemplo, se truncar 25 MB de dados e o processo funcionar, repita o processo e efectue a truncagem do ficheiro .pst original de tamanho excedido em apenas 15 MB. Se este procedimento funcionar, tente o processo com 5 MB. Se 25 MB não funcionar, repita o processo e efectue a truncagem do ficheiro .pst original em 35 MB. Se o processo não funcionar, aumente a quantidade até o processo ser efectuado com êxito.
  7. Execute a Ferramenta de reparação da pasta 'A Receber' (o ficheiro Scanpst.exe) no ficheiro .pst mais pequeno.
  8. Abra o ficheiro .pst reparado no Outlook.
  9. (Recomenda-se a execução deste passo, mas é opcional). Se o ficheiro abrir, clique com o botão direito do rato na pasta raiz do ficheiro .pst, clique em Propriedades e, em seguida, clique em Compactar agora para iniciar a compressão. Para um ficheiro deste tamanho, a compressão pode demorar aproximadamente 4 a 8 horas.
  10. Se o ficheiro não abrir, ignore o ficheiro .pst truncado e repita o processo com o ficheiro .pst original. Efectue a truncagem de mais dados do que na primeira tentativa e tente novamente o processo.
  11. Instale a seguinte actualização ou correcção, dependendo da versão do Outlook de que dispõe. Para tal, consulte o seguinte artigo da base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
    245025 OFF2000: Como obter e instalar a actualização Microsoft Office 2000 SR-1/SR-1a
    Estas actualizações impedem o Outlook de permitir que o ficheiro .pst exceda o tamanho máximo de 2 GB. Utilize um dos seguintes métodos para gerir o tamanho dos ficheiros .pst:

    • Utilize mais do que um ficheiro .pst.
    • Utilize a funcionalidade de arquivo.
    • Guarde anexos numa pasta de sistema de ficheiros e elimine-os das mensagens.
A versão em inglês desta ferramenta deve ter os seguintes atributos de ficheiro ou posteriores:

Ponto Da Situação

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

197316 Como utilizar a ferramenta de reparação da pasta 'A receber' para recuperar mensagens no Outlook 2000 instalado com a opção 'Empresa ou grupo de trabalho'
É possível que receba a seguinte mensagem de erro quando tentar executar o utilitário de truncagem a 2 GB:
Run-time Error '713': Class not Registered. You need the following file to be installed on your machine. MSSTDFMT.DLL
Se receber esta mensagem de erro, utilize os seguintes passos:

Microsoft Windows 98, Microsoft Windows 98 SE e Microsoft Windows ME

  1. Copie o ficheiro MSstdfmt.dll para a pasta C:\Windows\System.
  2. Abra uma linha de comandos e escreva o seguinte comando:
    REGSVR32 C:\Windows\System\MSSTDFMT.DLL

Microsoft Windows NT, Microsoft Windows 2000 e Microsoft Windows XP

  1. Copie o MSstdfmt.dll para a pasta C:\<windir>\System32.
  2. Abra uma linha de comandos e escreva o seguinte comando
    REGSVR32 C:\windir\System32\MSSTDFMT.DLL
    em que windir é o directório WINNT ou Windows.

Propriedades

Artigo: 296088 - Última revisão: 29 de maio de 2006 - Revisão: 6.4
A informação contida neste artigo aplica-se a:
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 98 Standard Edition
  • Microsoft Outlook 97 Standard Edition
Palavras-chave: 
kbhotfixserver kbqfe kberrmsg kbprb KB296088

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com