MS01-025: Patch Available for New Variant of the "Malformed Hit-Highlighting" Vulnerability

Article translations Article translations
Article ID: 296185 - View products that this article applies to.
This article was previously published under Q296185
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

A new variant of the Malformed Hit-Highlighting vulnerability has been discovered that affects both Index Server 2.0 and Indexing Service in Microsoft Windows 2000. The new variant has exactly the same scope as the original vulnerability. If an attacker provides an invalid search request, he or she can read files that reside on the Web server. The new patch eliminates all known variants of the vulnerability.

Mitigating Factors:
  • The vulnerability would only allow files to be read. File cannot be added, changed, or deleted through this vulnerability.
  • Server-side files should not contain sensitive data. If you follow this recommendation, there would be no sensitive data to compromise through this vulnerability.
  • The vulnerability would only allow files that reside on the Web server (and in the same logical drive as the server's root directory) to be read. It would not allow files elsewhere on the server, or files that reside on a remote server, to be read.

RESOLUTION

Indexing Service

This problem was first corrected in Windows 2000 Service Pack 3. The English version of this fix should have the following file attributes or later:
   Date        Time    Version        Size    File name
   ------------------------------------------------------
   04/12/2001  03:40p  5.0.2195.3498  42,768  Webhits.dll
				

Index Server 2.0

Windows NT 4.0

To resolve this problem, obtain the individual package referenced below or obtain the Windows NT 4.0 Security Rollup Package. For additional information on the SRP, click the article number below to view the article in the Microsoft Knowledge Base:
299444 Post-Windows NT 4.0 Service Pack 6a Security Rollup Package (SRP)
The following file is available for download from the Microsoft Download Center:
Collapse this imageExpand this image
Download
Download Q296185i.exe now
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

The English version of this fix should have the following file attributes or later:
   Date        Time    Version     Size    File name
   ---------------------------------------------------
   04/12/2001  03:51p  5.0.1781.3  42,256  Webhits.dll
				
NOTE: Due to file dependencies, this hotfix requires Microsoft Windows NT 4.0 Service Pack 3 or later.

Windows NT Server version 4.0, Terminal Server Edition

To resolve this problem, obtain the Windows NT Server 4.0, Terminal Server Edition, Security Rollup Package (SRP). For additional information about the SRP, click the article number below to view the article in the Microsoft Knowledge Base:
317636 Windows NT Server 4.0, Terminal Server Edition, Security Rollup Package

STATUS

Microsoft has confirmed that this problem may cause a degree of security vulnerability in Indexing Service in Windows 2000 and Index Server 2.0. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:
296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot
For more information about this vulnerability, see the following Microsoft Web site:
http://www.microsoft.com/technet/security/bulletin/MS01-025.mspx

Properties

Article ID: 296185 - Last Review: October 23, 2013 - Revision: 4.2
APPLIES TO
  • Microsoft Index Server 2.0
  • Microsoft Windows Indexing Service 2.0
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix kbgraphxlinkcritical kbsechack kbsecurity kbsecvulnerability kbwin2000presp3fix kbwin2000sp3fix KB296185

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com