ID do artigo: 296241 - Última revisão: quarta-feira, 22 de março de 2006 - Revisão: 5.1

A proteção de arquivo do Windows pode não iniciar

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Sintomas

Ao efetuar logon em um computador com o Windows 2000, você pode receber a seguinte mensagem da proteção de arquivo do Windows:
Arquivos requeridos para a execução apropriada do Windows foram substituídos por versões desconhecidas. Para manter a estabilidade do sistema, o Windows deve restaurar as versões originais desses arquivos.

Insira o CD do Windows 2000 Server agora.
Ao inserir o CD do Windows 2000 a caixa de mensagem fecha.

Quando você examina o log de eventos do sistema, o seguinte evento pode constar nele:
Origem: Proteção de arquivos do Windows
Identificação do evento: 64033
Descrição: A proteção de arquivo do Windows não pôde ser inicializada. O código específico de erro é 0xc000000f.
Quando você tenta usar o comando sfc /scannow ele pode não funcionar e você recebe a seguinte mensagem de erro:
A proteção de arquivo do Windows não pôde iniciar uma verificação nos arquivos protegidos do sistema. O código específico é 0x000006ba [O RPC Server não está disponível.].

Causa

Este comportamento ocorre se o certificado de carimbo de data/hora VeriSign foi removido do computador. O certificado está listado como: "Emitido para: No Liability Accepted, (c)97 VeriSign, Inc.".

Para determinar se este certificado foi removido do sistema, execute as seguintes etapas:
  1. Localize um computador com o Windows 2000 que apresente os seguintes sintomas.
  2. Clique em Iniciar, em Executar, digite mmc e clique em OK.
  3. No Console de gerenciamento da Microsoft, clique em Console e em Adicionar/remover snap-in.
  4. Na caixa de diálogo Adicionar ou remover, clique em Adicionar.
  5. Clique em Certificados e em Adicionar.
  6. Clique em Conta de computador e em Avançar.
  7. Clique em Computador local e em Concluir.
  8. Clique em Fechar e em OK.
  9. Na raiz de console, clique duas vezes em Certificados (Computador local).
  10. Clique duas vezes em Autoridades de certificação raiz confiáveis e clique em Certificados.
  11. No painel de detalhes, localize o certificado No Liability Accepted. Se não houver o certificado, execute as etapas descritas na seção "Resolução" para exportar o certificado de outra estação de trabalho e importá-lo.

Resolução

Para resolver este comportamento, o certificado precisa ser restaurado ao seu local de origem. Para exportar o certificado de um computador com base no Windows 2000, execute as seguintes etapas:
  1. Localize um computador com o Windows 2000.
  2. Clique em Iniciar e em Executar.
  3. Na caixa Abrir digite: MMC.
  4. Quando o MMC (Console de gerenciamento da Microsoft) for exibido, clique em Console e em Adicionar/remover snap-in.
  5. Na janela Adicionar/remover, clique em Adicionar.
  6. Quando a lista de snap-ins disponíveis for exibida, clique em Certificados e em Adicionar.
  7. Clique em Conta de computador.
  8. Click Avançar.
  9. Clique em Computador local e em Concluir.
  10. Clique em Fechar e em OK para fechar a janela Adicionar/remover snap-in.
  11. Em Raiz do console, clique duas vezes em Certificados (Computador local).
  12. Clique duas vezes em Autoridades de certificação raiz confiáveis e em Certificados.
  13. No painel à direita, são exibidos os certificados instalados. Role a lista para baixo para localizar o certificado No Liability Accepted.
  14. Clique com o botão direito do mouse no certificado, clique em Todas as tarefas e clique em Exportar.
  15. No assistente de exportação, clique em Avançar, em X.509 binário codificado por DER (*cer), e em Avançar.
  16. Na caixa Nome de arquivo digite o nome do arquivo para salvá-lo (por exemplo, C:\Cert). Uma extensão .cer é adicionada ao nome do arquivo.
  17. Transfira este arquivo para o computador que está recebendo a mensagem de erro.
Depois de o arquivo ser transferido para o computador que está exibindo a mensagem de erro, execute as seguintes etapas para importá-lo:
  1. Clique em Iniciar e em Executar.
  2. Na caixa Abrir digite: MMC.
  3. Quando o MMC iniciar, clique em Console e em Adicionar/remover snap-in.
  4. Na janela Adicionar/remover, clique em Adicionar.
  5. Quando a lista de snap-ins disponíveis for exibida, clique em Certificados e em Adicionar.
  6. Clique em Conta de computador.
  7. Click Avançar.
  8. Clique em Computador local e em Concluir.
  9. Clique em Fechar e em OK para fechar a janela Adicionar/remover snap-in.
  10. Em Raiz do console, clique duas vezes em Certificados (Computador local).
  11. Clique com o botão direito do mouse em Autoridades de certificação raiz confiáveis, clique em Todas as tarefas e em Importar.
  12. No assistente, clique em Avançar e localize o arquivo que você transferiu do outro computador. (Você pode ter que alterar o campo "Todos arquivos" para exibir os certificados X.509.)
  13. Ao selecionar o arquivo, clique em Avançar.
  14. Coloque o certificado no armazenamento de Autoridades de certificação raiz confiáveis e clique em Avançar.
  15. Clique em Concluir. Uma caixa de diálogo é exibida, indicando se a operação foi ou não concluída com êxito.
  16. Depois de transferir o certificado, reinicie o computador e observe se o comportamento foi solucionado.

Mais Informações

Para obter informações adicionais sobre certificados raiz confiáveis, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento da Microsoft:
293781  (http://support.microsoft.com/kb/293781/ ) Certificados raiz confiáveis necessários pelo Windows Server 2003, pelo Windows XP e pelo Windows 2000
222193  (http://support.microsoft.com/kb/222193/ ) Descrição do recurso de Proteção de Arquivo do Windows

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Palavras-chave: 
kbenv kberrmsg kbprb KB296241