Article ID: 296339 - Last Review: July 26, 2007 - Revision: 3.5

Script Error When You Send Web Page by E-Mail

This article was previously published under Q296339
Expand all | Collapse all

SYMPTOMS

In Microsoft Internet Explorer, you may receive a script error message similar to the following when you attempt to send a Web page by e-mail:
Internet Explorer Script Error
An error has occurred in the script on this page.
Line: 0
Char: 0
Error: Access is denied to http://Web Server/filename.htc
Code: 0
URL: outbind://117 (Outlook) or mhtml:mid://00000000/ (Outlook Express)
NOTE: You receive this error message regardless of whether Internet Explorer is configured to display a notification about every script error or whether your e-mail client supports Active Scripting in HTML e-mail.

CAUSE

This behavior can occur if the Web page that you attempt to send as e-mail contains imported files that cannot be accessed by your e-mail client. For example, if a Web page author uses an IMPORT processing instruction that refers to an HTML Component (.HTC) file that contains a tag definition, this behavior occurs when either Microsoft Outlook or Microsoft Outlook Express attempts to access the .HTC file that the author has referenced.

WORKAROUND

To work around this issue, send a link to the Web page address by e-mail. To do this, follow these steps:
  1. Establish a connection to the Internet, and then start Internet Explorer.
  2. Navigate to the Web page that you want to send as e-mail.
  3. On the File menu, point to Send, and then click Link by E-Mail.
After the recipient receives the e-mail and clicks the link, his or her browser navigates to the Web page.

NOTE: This workaround sends a link to the recipient, not to the actual Web page.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For developer information about using the IMPORT processing instruction to refer to an HTML Component (.HTC) file that contains a tag definition, browse to the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/ms535171.aspx (http://msdn2.microsoft.com/en-us/library/ms535171.aspx)

APPLIES TO
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.5
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 5.01 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows XP Professional x64 Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Keywords: 
kbbug kberrmsg KB296339
 

Article Translations