XADM: El programa de instalación no puede registrar el archivo de EXOLEDB.dll

Seleccione idioma Seleccione idioma
Id. de artículo: 296436 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

Síntomas

Durante el proceso de instalación o actualización de Exchange 2000, puede dejar de instalación y se muestra un error relacionado con el registro de EXOLEDB.dll. En el registro de instalación de Exchange 2000, puede recibir uno de los mensajes de error siguientes:
El comando
regsvr32 /s exoledb.dll
error, devuelve código de error 5 (acceso denegado).
-o bien -
El programa de instalación falló con 0xc103798a registrar el protocolo dav base.

Causa

Este error puede producirse si los archivos .dll, que el archivo de EXOLEDB.dll depende, no están registrados.

Solución

Para evitar este error, registrar manualmente los archivos .DLL dependientes de (Msdaurl.dll Msdaipp.dll y Oledb32.dll) escribiendo el comando siguiente desde un símbolo donde name .dll es el nombre del archivo .dll que se desea registrar:
regsvr32 name .dll
Por ejemplo, para registrar el archivo Msdaurl.dll, escriba el comando siguiente desde un símbolo del sistema:
regsvr32 msdaurl.dll
Generalmente, los archivos Msdaurl.dll Msdaipp.dll y Oledb32.dll se encuentran en la carpeta %RaízDelSistema%\Archivos de programa\Archivos comunes\System\Ole DB. Tiene que ejecutar el comando regsvr32 en el directorio en el que se encuentran los archivos .dll.

Después de registrar estos archivos, puede hacer clic en Reintentar en el cuadro de diálogo Configurar para permitir que el programa registrar el ExOLEDB.dll y continuar con la instalación de instalación de Exchange.

Más información

Para obtener información adicional con respecto al uso de Regsvr32, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
249873Explicación del uso y los mensajes de error de Regsvr32

Propiedades

Id. de artículo: 296436 - Última revisión: miércoles, 5 de febrero de 2014 - Versión: 1.4
La información de este artículo se refiere a:
  • Microsoft Exchange 2000 Server Standard Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbprb KB296436 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 296436

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com