XADM: Instalação não pode registrar o arquivo EXOLEDB.dll

Traduções deste artigo Traduções deste artigo
ID do artigo: 296436 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Sintomas

Durante o processo de instalação ou atualização de Exchange 2000, a instalação pode parar e é exibido um erro sobre o registro dos EXOLEDB.dll. No log de instalação do Exchange 2000, você pode receber uma das seguintes mensagens de erro:
O comando
regsvr32 /s exoledb.dll
Falha, retornando código de erro 5 (acesso negado).
- ou -
Falha da instalação com 0xc103798a registrar o protocolo dav base.

Causa

Este erro pode ocorrer se os arquivos .dll, dos quais o arquivo EXOLEDB.dll é dependente, não estiverem registrados.

Como Contornar

Para contornar este erro, registre manualmente os arquivos .dll dependentes (Msdaurl.dll, Msdaipp.dll e Oledb32.dll) digitando o seguinte comando no prompt de comando onde name .dll é o nome do arquivo .dll que você deseja registrar:
regsvr32 name .dll
Por exemplo, para registrar o arquivo Msdaurl.dll, digite o seguinte comando de um prompt de comando:
regsvr32 msdaurl.dll
Geralmente, os arquivos Msdaurl.dll MSDAIPP.dll e Oledb32.dll estão localizados na pasta %SystemRoot%\Program Files\Common Files\System\Ole DB. Você precisará executar o comando regsvr32 no diretório em que os arquivos .dll estão localizados.

Após registrar esses arquivos, você poderá clicar em tentar novamente na caixa de diálogo configuração para permitir a instalação do Exchange registrar o EXOLEDB.dll e continuar com a instalação.

Mais Informações

Para obter informações adicionais sobre o uso do Regsvr32, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
249873Explicação do uso do Regsvr32 e mensagens de erro

Propriedades

ID do artigo: 296436 - Última revisão: quarta-feira, 23 de outubro de 2013 - Revisão: 1.4
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange 2000 Server Standard Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbprb KB296436 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 296436

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com