MS01-022: WebDAV Service Provider Can Allow Scripts to Levy Requests as a User

Article translations Article translations
Article ID: 296441 - View products that this article applies to.
This article was previously published under Q296441
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

The Microsoft Data Access Component Internet Publishing Provider provides access to Web Distributed Authoring and Versioning (WebDAV) resources over the Internet. By design, it should differentiate between requests that are made by a user and those that are made by a script that is running in the user's browser. However, because of an implementation flaw, it handles all requests in the security context of the user. Therefore, if a user browses to a Web page or opens an HTML e-mail message that contains script, that script could access Web-based resources as the user.

The specific actions that a malicious user could take by using this vulnerability would depend on the Web-based resources that are available to the user, and on the user's privileges on those resources. However, it is likely that at a minimum, the malicious user could browse the user's intranet, and potentially access Web-based e-mail messages as well.

Notes:
  • The malicious user would need to possess significant inside information (such as server names, folder structures, and other user-specific and network-specific information) to carry out a successful attack. This vulnerability would therefore most likely be used as part of an insider attack.
  • Because of the way that WebDAV requests are authenticated, the vulnerability could not be exploited against stand-alone computers.
  • The vulnerability could not be exploited if Active Scripting was disabled in the security zone in which the script was opened.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that you determine are at risk of attack. Evaluate the computer's physical accessibility, network and Internet connectivity, and other factors to determine the degree of risk to the computer. See the associated Microsoft Security Bulletin to help determine the degree of risk. This hotfix may receive additional testing. If the computer is sufficiently at risk, we recommend that you apply this hotfix now.

To resolve this problem immediately, download the hotfix by following the instructions later in this article or contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled, if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. You can install this patch on any of the following operating systems:
  • Windows 95
  • Windows 98
  • Windows 98 Second Edition
  • Windows Millennium Edition (Me)
  • Windows NT 4.0 Workstation Service Pack 6a
  • Windows NT 4.0 Server; and Server, Enterprise Edition; Service Pack 6a
  • Windows NT 4.0 Server, Terminal Server Edition, Service Pack 6
  • Windows 2000 Professional, Windows 2000 Server, Windows 2000 Advanced Server, or Windows 2000 Datacenter Server
  • Windows 2000 Professional with Service Pack 1, Windows 2000 Server with Service Pack 1, or Windows 2000 Advanced Server with Service Pack 1
The following file is available for download from the Microsoft Download Center:
Collapse this imageExpand this image
Download
Download Rbupdate.exe now
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file. The English version of this fix should have the following file attributes or later:
   Date        Time    Version       Size     File name
   ------------------------------------------------------
   04/05/2001  12:45p  8.102.4004.0  561,152  Msdaipp.10
   04/04/2001  05:59p  8.103.4004.0  573,440  Msdaipp.15
   04/08/2001  01:10p                 45,056  Rb_inst.exe

STATUS

Microsoft has confirmed that this problem may cause a degree of security vulnerability in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:
296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot
To determine if your computer is vulnerable, find the Msdaipp.dll file on your computer. If this file is not present, your computer is not affected by this vulnerability and you do not need the patch. If this file is present, right-click the file, click Properties, click the Version tab, and then compare the version to the versions that are listed below:
Collapse this tableExpand this table
Version numberStatus
8.102.1403.0Affected
8.103.2402.0Affected
8.103.2519.0Affected
All other versionsUnaffected
For more information about this vulnerability, see the following Microsoft Web site:
http://www.microsoft.com/technet/security/bulletin/MS01-022.mspx

Properties

Article ID: 296441 - Last Review: October 23, 2013 - Revision: 5.3
APPLIES TO
  • Microsoft Windows NT Server 4.0, Terminal Server Edition Service Pack 4
  • Microsoft Windows NT Server 4.0, Terminal Server Edition Service Pack 5
  • Microsoft Windows NT Server 4.0, Terminal Server Edition Service Pack 6
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 95
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows Millennium Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT 4.0 Service Pack 1
  • Microsoft Windows NT 4.0 Service Pack 2
  • Microsoft Windows NT 4.0 Service Pack 3
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
  • Microsoft Windows NT 4.0 Service Pack 6a
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
  • Microsoft Windows NT 4.0 Service Pack 6a
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Keywords: 
kbnosurvey kbarchive kbbug kbfix kbgraphxlinkcritical kbwin2000presp4fix kbsecvulnerability kbqfe kbsecurity kbsecbulletin kbsechack KB296441

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com