Visio 図面を他の Office プログラムに貼り付けるまたは挿入する方法

文書翻訳 文書翻訳
文書番号: 296826 - 対象製品
この記事は、以前は次の ID で公開されていました: JP296826
すべて展開する | すべて折りたたむ

目次

はじめに

この資料では、Microsoft Visio 図面からオブジェクトをコピーして、他のプログラムに貼り付ける複数の方法について説明します。

オブジェクトを Visio から別のプログラムにコピーするには、状況に応じて以下のいずれかの方法を使用します。

方法 1 : [種類によって選択] または [種類を指定して選択] を使用する

Microsoft Office Visio 2007、Microsoft Office Visio 2003、および Microsoft Visio 2002 では、[種類によって選択] を使用できます。Microsoft Visio 2000 では、[種類を指定して選択] を使用できます。[種類によって選択] または [種類を指定して選択] を使用するには、次の手順を実行します。
  1. Visio を起動して、図面を開きます。
  2. Visio 2007、Visio 2003、または Visio 2002 では、[編集] メニューの [種類によって選択] をクリックします。Visio 2000 の場合は、[種類を指定して選択] をクリックします。
  3. [種類によって選択] ダイアログ ボックスまたは [種類を指定して選択] ダイアログ ボックスで、次のいずれかの手順を実行します。
    • [図形の種類] をクリックします。次に、以下のチェック ボックスをオンまたはオフにします。
      • 図形
      • グループ
      • ガイド
      • OLE オブジェクト
      • メタファイル
      • ビットマップ
      Visio 2003 では、次の図形の種類も利用できます。
      • インク オブジェクト
    • [レイヤ] をクリックしてから、レイヤの隣にある必要なチェック ボックスをオンにします (またはレイヤ名をクリックします)。
  4. [OK] をクリックします。
  5. [編集] メニューの [コピー] をクリックします。
  6. Visio オブジェクトを貼り付ける、コピー先のファイルに切り替えます。

    たとえば、Visio オブジェクトを Microsoft Word 文書に貼り付ける場合には、Word を起動してから Visio オブジェクトを貼り付ける文書を開きます。
  7. [編集] メニューの [貼り付け] または [形式を選択して貼り付け] をクリックし、Visio オブジェクトを挿入します。

方法 2 : [すべて選択] を使用する

[すべて選択] を使用するには、次の手順を実行します。
  1. Visio を起動して、図面を開きます。
  2. [編集] メニューの [すべて選択] (または、[すべてを選択]) をクリックします。
  3. Visio オブジェクトを貼り付ける、コピー先のファイルに切り替えます。

    たとえば、Visio オブジェクトを Word 文書に貼り付ける場合には、Word を起動してから Visio オブジェクトを貼り付ける文書を開きます。
  4. [編集] メニューの [貼り付け] または [形式を選択して貼り付け] をクリックし、Visio オブジェクトを挿入します。

方法 3 : [図面のコピー] を使用する

[図面のコピー] を使用するには、次の手順を実行します。
  1. Visio を起動して、図面を開きます。
  2. Visio で何も選択されていないことを確認します。
  3. [編集] メニューの [図面のコピー] をクリックします。

    これによって、表示している図面のページがコピーされます。
  4. Visio オブジェクトを貼り付ける、コピー先のファイルに切り替えます。
    たとえば、Visio オブジェクトを Word 文書に貼り付ける場合には、Word を起動してから Visio オブジェクトを貼り付ける文書を開きます。
  5. [編集] メニューの [貼り付け] または [形式を選択して貼り付け] をクリックし、Visio オブジェクトを挿入します。

方法 4 : Visio 図面をグラフィック ファイルとして保存する

Visio 図面をグラフィック ファイルとして保存するには、次の手順を実行します。
  1. Visio を起動して、図面を開きます。
  2. コピーするオブジェクトを選択します。

    : 図面のページ全体をコピーする場合は、Visio の図面でオブジェクトが何も選択されていないことを確認します。図面のオブジェクトを選択すると、選択したオブジェクトだけが結果のグラフィック ファイルに表示されます。
  3. [ファイル] メニューの [名前を付けて保存] をクリックします。
  4. [ファイルの種類] ボックスの一覧から、保存するグラフィック ファイルの種類をクリックし、[保存] をクリックします。次に示すグラフィック ファイルの種類は、Visio 2007、Visio 2003、Visio 2002、および Visio 2000 で共通のものです。これら共通のグラフィック ファイルの種類が [ファイルの種類] ボックスに表示されます。
    • 拡張メタファイル (*.emf)
    • グラフィックス インターチェンジ形式 (*.gif)
    • JPEG ファイル インタージェンジ形式 (*.jpg)
    • ポータブル ネットワーク グラフィックス (*.png)
    • TIFF (*.tif)
    • 拡張圧縮メタファイル (*.emz)
    • Windows ビットマップ (*.bmp、*.dib)
    • Windows メタファイル (*.wmf)
    Visio 2007 および Visio 2003 の場合、共通のグラフィック ファイルの種類の他に次のグラフィック ファイルの種類も表示されます。
    • スケーラブル ベクタ グラフィックス - 圧縮 (*.svgz)
    • スケーラブル ベクタ グラフィックス (*.svg)
    Visio 2002 および Visio 2000 の場合、共通のグラフィック ファイルの種類の他に次のグラフィック ファイルの種類も表示されます。
    • Macintosh PICT Format (*.pct)
    • Zsoft PC Paintbrush Bitmap (*.pcx)
    • Adobe Illustrator File (*.ai)
    • Computer Graphics Metafile (*.cgm)
    • Encapsulated PostScript File (*.eps)
    • Postscript File (*.ps)
    • IGES Drawing File Format (*.igs)
    : [名前を付けて保存] ダイアログ ボックスを使用して図形または図面オブジェクトをエクスポートすると、[出力オプション] ダイアログ ボックスが表示されることがあります。このダイアログ ボックスでは、エクスポート先のファイルの設定を指定できます。[出力オプション] ダイアログ ボックスに表示されるオプションは、使用するグラフィック ファイルの形式によって異なります。
  5. Visio オブジェクトを貼り付ける、コピー先のファイルに切り替えます。

    たとえば、Visio オブジェクトを Word 文書に貼り付ける場合には、Word を起動してから Visio オブジェクトを貼り付ける文書を開きます。
  6. [挿入] メニューの [図] をポイントし、[ファイルから] をクリックします。
  7. Visio から保存したグラフィック ファイルを選択して、[挿入] をクリックします。

    : この方法では、図形、テキスト、塗りつぶしの書式は保持されます。ただし、レイヤ プロパティは維持されません。たとえば、図形が非表示レイヤに指定された場合、グラフィック ファイルを挿入すると、その図形は表示されなくなります。

方法 5 : Visio 2000 で [Visio 図面を挿入] ボタンを使用する

この方法は、Visio 2000 のみに適用されます。[Visio 図面を挿入] をインストールして使用するには、次の手順を実行します。
  1. Microsoft Word、Microsoft Excel、および Microsoft PowerPoint のツール バーに [Visio 図面を挿入] をインストールするには、"Visio ボタンを挿入" プログラムを実行します。通常、このプログラムは次のフォルダにあります。
    C:\Program Files\Visio\System\Custom
  2. [Visio 図面を挿入] を使用するには、[Visio 図面を挿入] ボタンをクリックしてから、[図面の種類の選択] ダイアログ ボックスの [テンプレートの参照] をクリックします。
  3. [テンプレートの選択] ダイアログ ボックスで、[ファイルの種類] ボックスの一覧の [図面 (*.vsd)] をクリックします。インポートする図面をクリックしてから [開く] をクリックします。

    : レイヤがロックされている場合や、非表示になっている場合は、まず、レイヤの非表示やロックを解除して、図面のすべての要素を取り込むようにします。

関連情報

Visio 2007 での Visio の図形や図面のエクスポートに使用できる形式の詳細については、Visio 2007 のヘルプを参照してください。これを行うには、[ヘルプ] メニューの [Microsoft Office Visio ヘルプ] をクリックして、[検索] ボックスに図形のエクスポート可能な形式と入力し、Enter キーを押してトピックの内容を表示します。

Visio 2003 での Visio の図形や図面のエクスポートに使用できる形式の詳細については、Visio 2003 のヘルプを参照してください。これを行うには、[ヘルプ] メニューの [Microsoft Office Visio ヘルプ] をクリックして、[検索] ボックスに図形のエクスポート可能な形式と入力し、Enter キーを押してトピックの内容を表示します。

Visio 2002 での Visio の図形や図面のエクスポートに使用できる形式の詳細については、Visio 2002 のヘルプを参照してください。これを行うには、[ヘルプ] メニューの [Microsoft Visio ヘルプ] をクリックして、アンサー ウィザードの [何について調べますか] ボックスに図形のエクスポートと入力し、Enter キーを押してトピックの内容を表示します。

図形を Visio 2000 から他のプログラムにコピーする方法の詳細については、[ヘルプ] メニューの [Visio ヘルプ] をクリックし、[検索] タブの [キーワードを入力してください] ボックスにコピー コマンドと入力し、[検索] をクリックして表示されるトピックを参照してください。

プロパティ

文書番号: 296826 - 最終更新日: 2007年3月20日 - リビジョン: 4.2
この資料は以下の製品について記述したものです。
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
  • Microsoft Visio Professional Version 2002
  • Microsoft Visio Standard Version 2002
  • Microsoft Visio 2000 Enterprise Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Standard Edition
  • Microsoft Visio 2000 Technical Edition
キーワード:?
kbhowto KB296826
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com