文章编号: 296931 - 最后修改: 2007年12月4日 - 修订: 4.3

在安装 Office 时安装程序无法注册模块 msjetoledb40.dll"错误消息

系统提示此文章适用于与您所使用的操作系统不同的操作系统。文章内容可能与您无关,并且已被禁用。
展开全部 | 关闭全部

症状

当安装了 Microsoft Office XP 时您可能会收到以下错误消息:
1904 时出错。安装程序无法注册模块 C:\WINDOWS\SYSTEM\msjetoledb40.dll。如果您单击取消或忽略,重新运行安装程序并重新安装或修复 Office 安装。如果出现了问题,请与 Microsoft 产品支持服务 (PSS) 联系以获得帮助。有关如何与 PSS 联系,请参阅 D:\FILES\OSP\1033\FILE\WINDOWS\HELP\PSS10.TXT 的信息。

原因

如果满足下列所有条件都都为真,则可能会出现此问题:
  • 基于 Microsoft Windows 98 的计算机上或在一台基于 Microsoft Windows 98 第二版的计算机上安装 Microsoft Office XP。
  • 需要安装 Office 系统文件更新。
  • 软件程序如 Dell OpenManage 客户端工具 (OMCI) 6.0,已安装并且正在使用该 Msjetoledb40.dll 文件。
文件 Msjetoledb40.dll 是所需的系统文件的 Office XP 安装过程中系统文件更新。某些软件可能会使用此文件不允许在 Office XP 的过程中正确注册该文件的安装。

解决方案

有三种方法可用来解决此问题。使用方法 1 或方法 2,如果您已经安装了软件使用 DLL 的文件,并且您将收到错误消息。如果未安装任何软件的使用 DLL 文件,但您必须在您同时具有 Office XP 的计算机上安装此类软件,请使用方法 3。

方法 1: 重新安装系统文件更新

Office XP 安装程序完成后,请按照下列步骤重新安装系统文件更新。

注意您将需要重新启动计算机。
  1. 单击 开始,指向 设置,然后单击 控制面板
  2. 双击 添加/删除程序
  3. 单击 系统文件更新,然后单击 添加/删除
  4. 单击 修复系统文件更新,然后单击 下一步
  5. 单击 重新安装系统文件更新,然后单击 安装
  6. 单击 确定,然后单击 以重新启动计算机。

方法 2: 手动注册 Msjetoledb40.dll 文件

注意这些步骤假设您收到"症状"部分中所描述的错误消息。
  1. 当您收到错误消息时,单击 忽略。系统文件更新完成成功安装。
  2. 在您的 Office XP 安装程序继续操作之前,请按照下列步骤操作:
    1. 双击桌面上 我的电脑 图标。
    2. 找到 C:\Windows\System 文件夹。

      注意此路径可能不同,具体取决于您的操作系统的安装位置。
    3. 找到 Msjeto~1.dll 文件。
    4. 用鼠标右键单击该文件,然后单击 重命名
    5. Msjetoledb40.dll 更改文件的名称。
    6. 关闭 我的电脑
    7. 单击 开始、 单击 运行,在 打开 框中键入 regsvr32 msjetoledb40.dll,然后单击 确定
  3. 完成您的 Office XP 安装程序的其余部分。

方法 3: 安装 Office XP 之前安装其他软件

如果您的计算机上尚未安装其他软件,但您需要具有 Office XP 并安装了其他软件应第一次安装 Office XP。这样可以避免使用 Msjetoledb40.dll 文件会导致错误消息时出现的冲突。

本文讨论了在第三方产品是由独立于 Microsoft 的公司生产的。Microsoft 会使没有担保,或暗示或其他方式,性能或可靠性,这些产品。

更多信息

有关更多有关如何解决 Office XP 的安装问题的文章:
Click here to view a list of Troubleshooting Installation of Office XP: Pick Your Operating System articles (http://support.microsoft.com/search/default.aspx?catalog=lcid%3d1033&spid=914&query=officexpsetupdwts&adv=&mode=s&cat=false)

这篇文章中的信息适用于:
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 98 第二版
  • Microsoft Office 2000 标准版
  • Microsoft Office XP 专业版
  • Microsoft Office XP 中小企业版
  • Microsoft Office XP 标准版
  • Microsoft Office XP Students and Teachers
  • Microsoft Office XP Developer Edition
  • Microsoft Access 2002 标准版
  • Microsoft Excel 2002 标准版
  • Microsoft FrontPage 2002 标准版
  • Microsoft Outlook 2002 标准版
  • Microsoft PowerPoint 2002 标准版
  • Microsoft Word 2002 标准版
关键字:?
kbmt kbsetup kbtshoot kberrmsg kbprb KB296931 KbMtzh
机器翻译机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 296931? (http://support.microsoft.com/kb/296931/en-us/ )
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。