Article ID: 297064 - Last Review: February 28, 2007 - Revision: 2.5

Error Message "Snap-in Failed to Initialize" When You Use Microsoft Management Console

This article was previously published under Q297064
Notice
This article applies to Windows 2000. Support for Windows 2000 ends on July 13, 2010. The Windows 2000 End-of-Support Solution Center (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fwin2000) is a starting point for planning your migration strategy from Windows 2000. For more information see the Microsoft Support Lifecycle Policy (http://support.microsoft.com/lifecycle/) .
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SYMPTOMS

When you attempt to start Microsoft Management Console (MMC), you may receive the following message, where the "#" symbols represent the class identification (ID) of the attribute:
Snap-in failed to initialize.
Name: - not available
Clsid: {########-####-####-####-############}

CAUSE

This problem can occur when a program that has an associated MMC snap-in, is removed and leaves an orphaned entry in the registry.

RESOLUTION

To resolve this problem:
  1. Ignore the message in the Symptoms section and click OK to start MMC.
  2. Click Console.
  3. Click Add\Remove Snap-in.
  4. Click the orphaned snap-in. (The snap-in should not have an icon.)
  5. Click Remove.
  6. Click OK to close the Add\Remove snap-in window.
  7. Save your changes to the console.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Keywords: 
kberrmsg kbprb KB297064
 

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