Visio2002: Ausführen von Beispielcode aus Knowledge Base-Artikeln

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 297304 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde zuvor veröffentlicht unter D297304
Dieser Artikel wurde archiviert. Er wird im vorliegenden Zustand bereitgestellt und nicht mehr aktualisiert.
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
297304 Visio2002: How to Run Sample Code from Knowledge Base Articles
In Artikel 277011 wird dieses Thema für Microsoft Visio 2000 behandelt.
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Die Microsoft Knowledge Base enthält viele Artikel mit Beispielcode für VBA-Makros (VBA = Visual Basic für Applikationen). Viele dieser Makros veranschaulichen Grundkonzepte der Programmierung in Visual Basic für Microsoft Visio. Dieser Artikel beschreibt, wie Sie mithilfe der Beispielcodes Makros erstellen und diese Makros ausführen können.

Weitere Informationen

Die Verwendung der hier aufgeführten Information, Makro- oder Programmcodes geschieht auf Ihre eigene Verantwortung. Microsoft stellt Ihnen diese Informationen sowie Makro- und Programmlistings ohne Gewähr auf Richtigkeit, Vollständigkeit und/oder Funktionalität sowie ohne Anspruch auf Support zur Verfügung. Die zur Verfügung gestellten Makro- und Programmierungsbeispiele sollen lediglich exemplarisch die Funktionsweise des Beispiels aufzeigen. Microsoft Visio speichert Makros in einem Modul innerhalb eines Projekts, das in einer Vorlage (.vst), einer Schablone (.vss) oder einer Zeichnung (.vsd) gespeichert ist. Sie müssen zunächst ein neues VBA-Makro in einer Visio-Vorlage, -Schablone oder -Zeichnung hinzufügen (oder ein vorhandenes Makro auswählen), um den Beispielcode eines Knowledge Base-Artikels nutzen zu können. Danach können Sie den Beispielcode in diesem Makro einfügen oder eingeben.

Erstellen eines neuen Makros

  1. Öffnen oder erstellen Sie je nach Bedarf eine Visio-Vorlage, -Schablone oder -Zeichnung.
  2. Zeigen Sie im Menü Extras auf Makro und klicken Sie dann auf Makros.
  3. Klicken Sie in der Liste Makros in auf den Pfad oder das Modul, in dem Sie das Makro speichern möchten.
  4. Geben Sie im Feld Makroname einen Namen für das Makro ein.
  5. Klicken Sie auf Erstellen, um den Visual Basic-Editor zu öffnen.
  6. Führen Sie einen der folgenden Schritte aus:
    • Geben Sie den Makrocode zwischen den Zeilen Sub Macroname() und End Sub ein.
      Sub macroname()
         Type your macro code here
      End Sub
    • Gehen Sie folgendermaßen vor, um den Beispielcode zu kopieren und in Ihrem Makro einzufügen:
      Sub macroname()
       
      End Sub
      1. Wechseln Sie zu dem Programm, mit dem Sie den Microsoft Knowledge Base-Artikel anzeigen, z.B. Microsoft Internet Explorer.
      2. Halten Sie die Taste STRG gedrückt und klicken Sie einmal auf den Code, um ihn zu markieren.
      3. Klicken Sie im Menü Bearbeiten auf Kopieren.
      4. Wechseln Sie zum Visual Basic-Editor.
      5. Markieren Sie im Visual Basic-Editor im Makro den vorhandenen Codetext von Sub Macroname() bis End Sub.
      6. Klicken Sie im Menü Bearbeiten auf Einfügen.

        Hinweis: Beim Einfügen wird der vorhandene Codetext durch den Code ersetzt, den Sie aus dem Knowledge Base-Artikel kopiert haben.
  7. Klicken Sie im Menü Datei auf Schließen und zurück zu Visio, nachdem Sie den Code für Ihr Makro eingegeben oder eingefügt haben.

    Hinweis: Verwenden Sie die [Tabulator]-Taste, um Text einzurücken. Zeilen, die mit einem Apostroph (') beginnen, sind Kommentare, die zur Ausführung des Makros nicht benötigt werden. Kommentare können jedoch sinnvoll sein, um zu erläutern, wie das Makro funktioniert.

Hinzufügen von Beispielcode zu einem Modul

Um Code zu einem Modul hinzufügen zu können, muss ein Modul haben vorhanden sein oder erstellt werden. Gehen Sie hierzu folgendermaßen vor:
  1. Öffnen oder erstellen Sie je nach Bedarf eine Visio-Vorlage, -Schablone oder -Zeichnung.
  2. Zeigen Sie im Menü Extras auf Makro und klicken Sie auf Visual Basic-Editor.
  3. Klicken Sie im Projektfenster des Visual Basic-Editor (standardmäßig oben links) auf das Projektsymbol, das denselben Namen hat wie Ihre Vorlage, Schablone oder Zeichnung. Wenn Sie Ihre Vorlage oder Zeichnung noch nicht gespeichert haben, wird ein Projektname wie z.B. "Projekt(Zeichnung1)" angezeigt.
  4. Klicken Sie im Menü Einfügen auf Modul, wenn das Projekt, das Sie angeklickt haben, keinen Ordner namens Module enthält.
  5. Klicken Sie irgendwo in das Codefenster des Moduls, das Sie erstellen möchten. Das Codefenster befindet sich in der Regel oben rechts im Visual Basic-Editor.
  6. Fügen Sie den Beispielcode genauso ein, wie er im Knowledge Base-Artikel erscheint, einschließlich der Zeilen Sub Macroname() und End Sub.

    Hinweis: Weitere Informationen zum Eingeben oder Einfügen des Makrocodes finden Sie in diesem Artikel im Abschnitt "Erstellen eines neuen Makros".
  7. Klicken Sie im Menü Datei auf Schließen und zurück zu Visio, nachdem Sie den Code für Ihr Makro eingegeben oder eingefügt haben.

Ausführen des Makros

  1. Zeigen Sie im Menü Extras auf Makro und klicken Sie auf Makros.
  2. Wählen Sie den Namen des Makros in der Liste Makroname aus und klicken Sie auf Ausführen.
Es kann sein, dass Microsoft Visual Basic für Applikationen folgende Warnmeldung anzeigt:
Die Makros im Projekt wurden deaktiviert. Schlagen Sie bitte in der Onlinehilfe oder der Dokumentation der Host-Anwendung nach, wie Sie die Makros aktivieren können.
In diesem Fall wurde die Makrosicherheitsstufe in Visio auf Hoch eingestellt, oder Makros wurden deaktiviert.

Weitere Informationen finden Sie in folgendem Artikel der Microsoft Knowledge Base:
297136 Visio2002: "The Macros in the Project Are Disabled" Message When You Run a Macro

Verweise

Die Microsoft Visio-Hilfe enthält zahlreiche Themen, die sich mit der Verwendung von Makros befassen. In der Visual Basic-Hilfe finden Sie ausführliche Informationen zum Verfassen eigenen Codes.

Weitere Informationen zu Hilfestellung in Bezug auf Visual Basic für Applikationen finden Sie in folgendem Artikel der Microsoft Knowledge Base:
297319 Visio2002: Programming Resources for Visual Basic for Applications


Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Eigenschaften

Artikel-ID: 297304 - Geändert am: Donnerstag, 6. Februar 2014 - Version: 1.3
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Visual Basic for Applications 6.0
Keywords: 
kbnosurvey kbarchive kbdta kbhowto KB297304
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com