Visio2002: How to Run Sample Code from Knowledge Base Articles

Article translations Article translations
Article ID: 297304 - View products that this article applies to.
This article was previously published under Q297304
This article has been archived. It is offered "as is" and will no longer be updated.
For a Microsoft Visio 2000 version of this article, see 277011.
Expand all | Collapse all

On This Page

SUMMARY

The Microsoft Knowledge Base contains many articles that contain sample code for Visual Basic for Applications macros. Many of these macros illustrate basic concepts of programming in Visual Basic for Microsoft Visio. This article contains instructions on how to use the sample code to create a new macro and how to run that macro.

MORE INFORMATION

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements. Microsoft Visio stores macros in a module within a project that is stored in a template (.vst), a stencil (.vss), or a drawing (.vsd). To use the sample code in a Knowledge Base article, you must first add a new Visual Basic macro (or select an existing macro) in a Visio template, stencil, or drawing. Then you can paste or type the sample code into this macro.

To Create a New Macro

  1. Open or create a Visio template, stencil, or drawing as appropriate.
  2. On the Tools menu, point to Macro, and then click Macros.
  3. In the Macros In list, click the location or module where you want to save the macro.
  4. In the Macro Name box, type a name for the macro.
  5. Click Create to open the Visual Basic Editor.
  6. Do one of the following:
    • Type the macro code between the Sub Macroname() line and the End Sub line.
      Sub macroname()
         Type your macro code here
      End Sub
      						
    • Copy and paste the sample code to your macro by following these steps:
      Sub macroname()
       
      End Sub
      						
      1. Switch to the program that you are using to view the Microsoft Knowledge Base article, such as Microsoft Internet Explorer.
      2. To select the sample code, hold down the CTRL key and then single-click the code.
      3. On the Edit menu, click Copy.
      4. Switch to the Visual Basic Editor.
      5. In the Visual Basic Editor, select the existing code text of Sub Macroname() to the End Sub of the macro.
      6. On the Edit menu, click Paste.

        NOTE: When you paste, the existing code text will be replaced with the code that you copied from the Knowledge Base article.
  7. After typing or pasting the code for your macro, click Close and Return to Visio on the File menu.

    NOTE: Use the TAB key to indent text. Lines that begin with an apostrophe (') are comments that are not required to run the macro. However, you may want to type comments to make it easier to understand what the macro is doing.

To Add the Sample Code to a Module

To add code to a module, you must either have an existing module or create a new module. To do this, follow these steps:
  1. Open or create a Visio template, stencil, or drawing as appropriate.
  2. On the Tools menu, point to Macro and then click Visual Basic Editor.
  3. In the Project window of the Visual Basic Editor (by default this is in the upper-left corner), click the project icon with the same name as your template, stencil, or drawing. If you have not yet saved your template or drawing, the project name will be similar to Project(Drawing1).
  4. If the project that you clicked does not contain a folder called Modules underneath it, click Module on the Insert menu.
  5. Click anywhere in the code window of the module that you want to create. The code window is usually in the upper-right corner of the Visual Basic Editor.
  6. Type or paste the sample code exactly as it appears in the Knowledge Base article, including the Sub Macroname() and End Sub lines.

    NOTE: For more information about typing or pasting the macro code, please see the "To Create a New Macro" section in this article.
  7. After typing or pasting the code for your macro, click Close and Return to Visio on the File menu.

To Run the Macro

  1. On the Tools menu, point to Macro and then click Macros.
  2. Select the name of the macro in the Macro Name list, and then click Run.
If Microsoft Visual Basic for Applications warns you with the following message
The macros in the project are disabled. Please refer to the online help or documentation of the host application determine how to enable macros.
the macro security level in Visio is set to High, or macros are disabled.

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
297136 Visio2002: "The Macros in the Project Are Disabled" Message When You Run a Macro

REFERENCES

Microsoft Visio Help contains numerous topics about working with macros. Visual Basic Help contains extensive information about writing your own code.

For additional information about getting help with Visual Basic forApplications, click the article number below to view the article in the Microsoft Knowledge Base:
297319 Visio2002: Programming Resources for Visual Basic for Applications

Properties

Article ID: 297304 - Last Review: October 23, 2013 - Revision: 3.3
APPLIES TO
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Visio 2002 Professional Edition
Keywords: 
kbnosurvey kbarchive kbhowto KB297304

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com