文書番号: 297684 - 対象製品
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目次

現象

この資料の対象製品として記載されているいずれかのバージョンの Windows を実行しているコンピューターで、ネットワーク共有にドライブを割り当てている場合、このドライブを一定時間以上利用しないと、ドライブへの接続が切断され、エクスプローラーでこのドライブのアイコンを確認すると、赤色の "X" が表示されていることがあります。ただし、このドライブにアクセスするか、ドライブを参照すると、接続は直ちに再確立されます。

原因

この問題が発生するのは、システムでは、使用されていないセッションで余分なサーバー リソースが消費されるのを防ぐために、指定されたタイムアウト期間 (既定では 15 分) を経過してもアイドル状態にある接続が切断されるためです。再度接続が要求されると、接続は直ちに再確立されます。

解決方法

このページで既定のタイムアウト期間を変更するには、「Fix it で解決する」セクションに進んでください。自分でこの問題を解決するには、「自分で解決する」セクションに進んでください。


: Microsoft Windows 95 ベースおよび Microsoft Windows 98 ベースのコンピューター上に共有リソースがある場合は、既定のタイムアウト期間を変更できません。

Fix it で解決する



この問題を自動的に解決するには、[この問題を解決する] ボタンまたはリンクをクリックします。[ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、このウィザードの手順に従います。


この問題を解決する
Microsoft Fix it 50494


注意事項
  • 共有リソースが存在するコンピューター上で、この Fix it ソリューションを実行する必要があります。
  • このウィザードは英語版のみとなります。ただし、自動的な解決は英語版以外の Windows でも機能します。
  • 使用しているコンピューターに問題がない場合、Fix it ソリューションをフラッシュ ドライブまたは CD に保存して、問題のあるコンピューターで実行することができます。

次に、「問題が解決されたかどうかの確認」セクションに進んでください。



自分で解決する

この問題を解決するには、ネットワーク共有のあるコンピューターに設定されている既定のタイムアウト期間を変更します。これを行うには、次のいずれかの方法を使用します。

レジストリ エディタ

警告: レジストリ エディターの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディターの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディターは、自己の責任においてご使用ください。

レジストリ エディターを使用して既定のタイムアウト期間を長くします。これを行うには、次の手順を実行した後、レジストリ エディターを終了します。

: この方法では、Server サービスの自動切断機能に設定されている既定のタイムアウト期間を変更することはできますが、この機能自体を無効にすることはできません。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに、Windows 2000 または Windows Server 2003 の場合は regedit、Windows NT 4.0 の場合は「regedt32」と入力し、[OK] をクリックします。
  2. 次のレジストリ キーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
  3. 右側のウィンドウで、[autodisconnect] 値をクリックし、[編集] メニューの [修正] をクリックします。[autodisconnect] 値が存在しない場合は、次の手順を実行します。
    1. [編集] メニューの [新規] をポイントし、[REG_DWORD 値] をクリックします。
    2. autodisconnect」と入力し、Enter キーを押します。
  4. [編集] メニューの [変更] をクリックします。
  5. [16 進] をクリックします。
  6. [値のデータ] ボックスに「ffffffff」と入力し、[OK] をクリックします。
: アイドル時間が KeepConn で設定されている期間を超えると、クライアント側セッションの接続が自動的に切断されます。このため、AutoDisConnect と KeepConn のうち、値が短く設定されている方の期間に従って、セッションの接続が切断されます。UNC 接続中のクライアント側のタイムアウト期間を変更するには、KeepConn に任意の時間を指定します。
次のレジストリ キーを見つけてクリックします。
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\lanmanworkstation\parameters
値: KeepConn
データ型:REG_DWORD
範囲: 1 〜 65,535 (秒)
既定値: 600 秒 = 10 分

コマンド ライン

: この方法を使用すると、Server サービスの自動調整機能を無効にできる場合があります。

Server サービスの自動切断機能に設定されている既定のタイムアウト期間を変更するには、コマンド プロンプトを開き、次の行を入力し、Enter キーを押します。
net config server /autodisconnect:number
number には、ネットワーク ドライブ接続を切断するまでのサーバーの待機時間を、分単位で入力します。このコマンドに設定できる最大値は 65,535 です。

: 自動切断の値を 0 (ゼロ) に設定しても、自動切断機能自体は無効になりません。ネットワーク ドライブ接続にアイドル時間が数秒でも発生すると Server サービスによって接続が切断されます。

自動切断機能を無効にするには、コマンド プロンプトを開き、次の行を入力し、Enter キーを押します。
net config server /autodisconnect:-1

問題が解決されたかどうかの確認

  • 問題が解決されたかどうかを確認します。問題が解決された場合、このセクションの作業は完了していることになります。問題が解決されていない場合は、サポートに問い合わせることができます。
  • マイクロソフトはフィードバックをお待ちしています。この解決方法に関するフィードバックを提供する、または問題を報告するには、"Fix it for me" ブログ (英語) にコメントを記入するか、電子メール メッセージ (日本語可) を送信してください。

詳細

以前のプログラムの中には、ドライブへの接続が切断されると、ファイルの保存やデータへのアクセスができないものがあります。ただし、そのようなプログラムでも、ドライブへの接続が切断されるまでは正常に機能します。

既定のタイムアウト期間を長くする方法の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
138365 Windows NT と Windows 2000 での Autodisconnect の動作
128167 Server サービスの構成および調整

プロパティ

文書番号: 297684 - 最終更新日: 2010年9月14日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Service Pack 3
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 Enterprise
  • Windows 7 Enterprise
キーワード:?
kbenv kbprb kbfixme kbmsifixme KB297684
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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