コンピュータを再起動するたびに、新しいハードウェアの検出ウィザードでプリンタ デバイスが検出される

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文書番号: 298370 - 対象製品
この記事は、以前は次の ID で公開されていました: JP298370
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
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現象

コンピュータを再起動するたびに、以前インストールしたプリンタが (新しくインストールしたプリンタではないにもかかわらず) 新しいハードウェアの検出ウィザードによって検出されることがあります。

原因

この問題は、以下の条件のいずれかに該当する場合に発生することがあります。
  • プリンタ ドライバがインストールにプラグ アンド プレイを使用しません。
  • 次のレジストリ キーが破損しています。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\LPTENUM

回避策

この問題を回避するには、新しいハードウェアの検出ウィザードが新しいプリンタを検出できない場合でも、ウィザードのすべての手順を完了します。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

この問題を解決するには、更新されたドライバの入手、または使用しているプリンタで新しいハードウェアの検出ウィザードを完了するための具体的な手順について、プリンタの製造元にお問い合わせください。

たとえば、ヒューレット・パッカード社のプリンタを使用している場合は、以下のヒューレット・パッカード社の Web サイトを参照してください。
http://welcome.hp.com/country/jp/ja/support.html?pageDisplay=support
レジストリ エディタを使用して、破損したレジストリ キーを削除するには、以下の手順を実行します。
  1. 管理者のアカウントを使用してコンピュータにログオンします。
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  3. [名前] ボックスに regedit と入力し、[OK] をクリックします。
  4. 次のレジストリ キーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\LPTENUM
  5. レジストリ キーを右クリックし、[削除] をクリックします。
  6. [キーの削除の確認] で、[はい] をクリックします。
  7. レジストリ エディタを終了し、コンピュータを再起動します。
Windows XP の再起動時に、プリンタが検出され、それに対するサポート ファイルがインストールされます。プリンタがインストールされると、Windows XP を起動してもプリンタは検出されません。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、将来予告なしに変更されることがあります。マイクロソフトは、掲載している情報に対して、いかなる責任も負わないものとします。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 298370 (最終更新日 2005-06-10) を基に作成したものです。

プロパティ

文書番号: 298370 - 最終更新日: 2007年12月1日 - リビジョン: 5.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition
キーワード:?
kbhardware kbenv kbprb KB298370
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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