O assistente de novo hardware poderá detectar a impressora depois de cada reinício do computador

Traduções de Artigos Traduções de Artigos
Artigo: 298370 - Ver produtos para os quais este artigo se aplica.
Importante: este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o pode restaurar se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
256986 Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Sintomas

Sempre que reiniciar o computador, o Assistente de novo hardware encontrado (Found New Hardware Wizard) poderá detectar a impressora instalada anteriormente, apesar de não ser uma impressora recentemente instalada.

Causa

Este problema pode ocorrer caso se verifique uma das seguintes condições:
  • O controlador da impressora não utiliza Plug and Play para a instalação.
  • A seguinte chave do registo ficou danificada:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\LPTENUM

Como contornar

Para contornar este problema, conclua todos os passos do assistente de novo hardware, apesar de o assistente não conseguir detectar uma impressora nova.

Resolução

Aviso: a utilização incorrecta do Editor de registo (Registry Editor) poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo (Registry Editor) possam ser resolvidos. Todo e qualquer risco decorrente da utilização do Editor de registo (Registry Editor) é da responsabilidade do utilizador.

Para resolver este problema, contacte o fabricante da impressora para obter um controlador actualizado ou instruções específicas sobre como concluir o Assistente de novo hardware encontrado (Found New Hardware Wizard) para a sua impressora em particular.

Por exemplo, visite o seguinte Web site da HP para obter informações sobre as impressoras HP:
http://h10025.www1.hp.com/ewfrf/wc/siteHome?lc=pt&cc=pt&dlc=pt
Para utilizar o Editor de registo (Registry Editor) para remover a chave de registo danificada, siga estes passos:
  1. Inicie sessão no computador utilizando uma conta de administrador.
  2. Clique em Iniciar (Start) e clique em Executar (Run).
  3. Na caixa Abrir (Open), escreva regedit e clique em OK.
  4. Localize e clique na seguinte chave de registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\LPTENUM
  5. Clique com o botão direito do rato na chave de registo e clique em Eliminar (Delete).
  6. Em Confirmar eliminação de chaves (Confirm Key Delete), clique em Sim (Yes).
  7. Feche o Editor de registo (Registry Editor) e reinicie o computador.
Quando o Windows XP for reiniciado, detectará a impressora e instalará suporte para a mesma. Depois de a impressora estar instalada, já não será detectada de cada vez que iniciar o Windows XP.

Ponto Da Situação

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Os produtos de outros fabricantes referidos neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não concede nenhuma garantia, implícita ou de outra natureza, relativamente ao desempenho ou à fiabilidade destes produtos.

A Microsoft fornece informações de contacto de outros fabricantes para o ajudar na obtenção de suporte técnico. Estas informações de contacto poderão ser alteradas sem aviso prévio. A Microsoft não garante o rigor das informações sobre o contacto destes fabricantes.

Propriedades

Artigo: 298370 - Última revisão: 1 de dezembro de 2007 - Revisão: 5.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition
Palavras-chave: 
kbhardware kbenv kbprb KB298370

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com