O Assistente para adicionar novo hardware pode detectar o dispositivo de impressora após cada reinicialização do computador

Traduções deste artigo Traduções deste artigo
ID do artigo: 298370 - Exibir os produtos aos quais esse artigo se aplica.
Importante Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e certifique-se de que sabe como restaurá-lo caso ocorra algum problema. Para obter informações adicionais sobre como fazer backup, restaurar e editar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft.
256986 Descrição do Registro do Microsoft Windows
Expandir tudo | Recolher tudo

Sintomas

Sempre que você reinicia o computador, o Assistente para adicionar novo hardware pode detectar a impressora instalada anteriormente, apesar de não ser uma impressora recém-instalada.

Causa

Esse problema poderá ocorrer se uma das seguintes condições for verdadeira:
  • O driver da impressora não usa Plug and Play para sua instalação.
  • A seguinte chave do Registro foi danificada:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\LPTENUM

Como Contornar

Para contornar esse problema, conclua todas as etapas no Assistente para adicionar novo hardware, mesmo que o assistente não detecte uma nova impressora.

Resolução

Aviso O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. O uso do Editor do Registro é de sua responsabilidade.

Para resolver esse problema, entre em contato com o fabricante da sua impressora para obter um driver atualizado ou instruções específicas sobre como concluir o Assistente para adicionar novo hardware para sua impressora específica.

Por exemplo, visite o seguinte site da HP para obter informações adicionais sobre as impressoras HP:
http://h10025.www1.hp.com/ewfrf/wc/siteHome?dlc=pt&lc=pt&cc=br
Para usar o Editor do Registro e remover a chave do Registro danificada, execute as seguintes etapas:
  1. Faça o logon no computador usando uma conta de administrador.
  2. Clique em Iniciar e em Executar.
  3. Na caixa Abrir, digite regedit e clique em OK.
  4. Localize e clique na seguinte chave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\LPTENUM
  5. Clique com o botão direito do mouse na chave do Registro e clique em Excluir.
  6. Em Confirmar a exclusão da chave, clique em Sim.
  7. Feche o Editor do Registro e reinicie o computador.
Quando o Windows XP reiniciar, ele detectará a impressora e o suporte para instalação. Após a instalação da impressora, ela não será mais detectada toda vez que o Windows XP for iniciado.

Situação

A Microsoft confirmou que esse é um erro nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informações

Os produtos de terceiros mencionados nesse artigo são produzidos por empresas independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

A Microsoft fornece informações de contato de terceiros para ajudá-lo a encontrar o suporte técnico. Essas informações podem ser alteradas sem notificação prévia. A Microsoft não garante a precisão dessas informações.

Propriedades

ID do artigo: 298370 - Última revisão: sábado, 1 de dezembro de 2007 - Revisão: 5.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition
Palavras-chave: 
kbhardware kbenv kbprb KB298370

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com