ID Artikel: 298408 - Kajian Terakhir: 24 September 2011 - Revisi: 2.0

IIS menghasilkan kesopanan redirect jika folder tanpa trailing garis miring diminta

Tips SistemThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Perbesar semua | Perkecil semua

GEJALA

Ketika browser meminta URL seperti http://www.servername.de/SubDir, browser akan diarahkan ke http://www.servername.de/SubDir/. Trailing garis miring disertakan pada akhir URL.

PENYEBAB

Internet Information Server (IIS) pertama memperlakukan SubDir sebagai berkas yang harus memberikan kembali ke browser. Jika file ini tidak dapat ditemukan, IIS memeriksa untuk melihat apakah sebuah direktori dengan nama ini. Jika direktori dengan nama ini ada, redirect kesopanan dengan pesan respon 302 "objek pindah" kembali ke browser. Pesan ini juga berisi informasi tentang lokasi baru direktori dengan trailing garis miring. Pada gilirannya, browser dimulai baru mendapatkan permintaan ke URL dengan trailing garis miring.

Dengan ini garis miring pada akhir URL, IIS memperlakukan ini sebagai sebuah direktori dan mencoba untuk mendapatkan baik dokumen standar dari direktori ini atau, jika tidak ada dokumen standar ada, mengembalikan daftar direktori atau pesan galat "Direktori daftar ditolak".

INFORMASI LEBIH LANJUT

Ketika browser meminta direktori virtual yang tidak berisi trailing garis miring, Internet Information Services (IIS) 6.0 kembali HTTP 301 "Dipindahkan secara permanen" pesan. Perilaku ini memungkinkan klien untuk menambahkan trailing garis miring pada kemudian permintaan ke direktori virtual.

Berlaku bagi:
  • Microsoft Internet Information Services 5.0
  • Microsoft Internet Information Services 6.0
  • Microsoft Internet Information Services 7.0
Kata kunci: 
kbpending kbprb kbmt KB298408 KbMtid
Penerjemahan MesinPenerjemahan Mesin
PENTING: Artikel ini diterjemahkan menggunakan perangkat lunak mesin penerjemah Microsoft dan bukan oleh seorang penerjemah. Microsoft menawarkan artikel yang diterjemahkan oleh seorang penerjemah maupun artikel yang diterjemahkan menggunakan mesin sehingga Anda akan memiliki akses ke seluruh artikel baru yang diterbitkan di Pangkalan Pengetahuan (Knowledge Base) dalam bahasa yang Anda gunakan. Namun, artikel yang diterjemahkan menggunakan mesin tidak selalu sempurna. Artikel tersebut mungkin memiliki kesalahan kosa kata, sintaksis, atau tata bahasa, hampir sama seperti orang asing yang berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab terhadap akurasi, kesalahan atau kerusakan yang disebabkan karena kesalahan penerjemahan konten atau penggunaannya oleh para pelanggan. Microsoft juga sering memperbarui perangkat lunak mesin penerjemah.
Klik disini untuk melihat versi Inggris dari artikel ini:298408  (http://support.microsoft.com/kb/298408/en-us/ )