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Article ID: 298618 - Last Review: March 6, 2009 - Revision: 6.0

You cannot download files that are 2 GB or larger

This article was previously published under Q298618
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SYMPTOMS

When you attempt to download a file from the Internet by using Hypertext Transfer Protocol (HTTP) in Microsoft Internet Explorer, you may find that the download does not complete. As a result, you cannot download the file.

CAUSE

This behavior can occur if you try to download a file that is larger than 2 gigabytes (GB) in Internet Explorer 6 or is larger than 4 GB in Internet Explorer 7.

WORKAROUND

To work around this problem, you can configure a Web site that is dedicated to downloading large files. To do this, disable the HTTP Keep-Alives Enabled option for a Web site that Internet Information Services (IIS) hosts. To disable this option, follow these steps:
  1. Open Internet Information Services Manager.
  2. Right-click the Web site that requires the change, and then click Properties.
  3. Clear the HTTP Keep-Alives Enabled check box that is located on the Web Site tab, and then click OK.
Notes
  • The HTTP Keep-Alives Enabled option enables a client that connects to the Web server to reuse the current TCP/IP session when it downloads all content from the Web server. When you disable this option, an Internet Explorer client can then download files of up to 4 GB. However, it also forces the client to establish a new TCP/IP session with the Web server for every content object that is downloaded from the Web page. Additionally, it creates extra TCP/IP overhead for both the server and the client which will adversely affect page load times
  • Windows Internet Explorer 7 can reliably download files up to 4 GB in size without the previously described change to the server. There is no workaround to enable Internet Explorer 7 to download files larger than 4 GB in size. Windows Internet Explorer 8 can reliably download files over 4 GB in size without the previously described change to the server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Internet Explorer, visit the following Microsoft Web site:
http://www.microsoft.com/windows/ie/default.mspx (http://www.microsoft.com/windows/ie/default.mspx)

APPLIES TO
  • Windows Internet Explorer 7
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Keywords: 
kbnofix kbprb KB298618

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